Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 9 of 9

Thread: Quick Question

  1. #1
    Yaemish is offline Cadillac Owners Connoisseur
    Automobile(s): 02 Seville, 04 SRX
    Join Date
    Sep 2003
    Location
    NY
    Posts
    1,232

    Quick Question

    I have a 96 Eldorado and today i went to change the coolant. I disconnect what I thought was the lower coolant hose that was at the bottom right running from something just in front of the radiator that looked like it was connected. A little oil came out so I put the hose back on and topped off my oil. There is no way I messaed anything up is there?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: Quick Question

    The thing in front of the radiator is the AC condensor. Was it pressurized?

    THe radiator hose is about 1 1/2 inches in diameter and squeezeable rubber.

  4. #3
    mcowden is offline Cadillac Owners Connoisseur
    Join Date
    Jun 2003
    Posts
    1,164

    Re: Quick Question

    Sounds like the transmission oil cooler. What color was it? Reddish means it was transmission fluid and you will be just fine. Just make sure the hoses connected to the cooler are tight.
    Mike

  5. #4
    Yaemish is offline Cadillac Owners Connoisseur
    Automobile(s): 02 Seville, 04 SRX
    Join Date
    Sep 2003
    Location
    NY
    Posts
    1,232

    Re: Quick Question

    Quote Originally Posted by zonie77
    The thing in front of the radiator is the AC condensor. Was it pressurized?

    THe radiator hose is about 1 1/2 inches in diameter and squeezeable rubber.
    I think that was it. Did I mess it up?

  6. #5
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: Quick Question

    What color was the oil? Red or yellow?

  7. #6
    Yaemish is offline Cadillac Owners Connoisseur
    Automobile(s): 02 Seville, 04 SRX
    Join Date
    Sep 2003
    Location
    NY
    Posts
    1,232

    Re: Quick Question

    yellow

  8. #7
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: Quick Question

    Was the AC working before. If it was there should have been a lot of pressure. If there wasn't much then the freon had leaked out previously. You didn't do any damage. You could have been hurt if it was full though.

  9. #8
    Yaemish is offline Cadillac Owners Connoisseur
    Automobile(s): 02 Seville, 04 SRX
    Join Date
    Sep 2003
    Location
    NY
    Posts
    1,232

    Re: Quick Question

    I haven't really been using the AC because its been so cold. I only lost a few ounces and then it stopped dripping.

  10. #9
    mcowden is offline Cadillac Owners Connoisseur
    Join Date
    Jun 2003
    Posts
    1,164

    Re: Quick Question

    There shouldn't be any oil in the condenser, though, especially not several ounces of it. With the lack of pressure I'd say that wasn't the condenser that got drained. If the system was low on pressure, you would see that the AC is always off and there would be a code set for it. I don't know what other oil would have been in that area other than the trans. oil cooler, but that should have been reddish in color. It could have been yellow- or brown-ish if it hasn't been changed for a while. I didn't think there was an engine oil cooler, but maybe I'm wrong about that or the car has a towing package installed. Either way, check the fluids, top off whatever is low, make sure all the connections down there are nice and tight and nothing is leaking, drive it and forget it. If you start hearing funny sounds when the AC compressor runs or it says the system is low, that will need to be checked, but I wouldn't worry about it too much.

    You know, the ABS brake pump is down there, but I didn't think it had any drain type plugs or rubber hoses on it. Don't think there are any power steering lines down there. Are you talking about on the driver side, as in somewhere beneath the air filter box and PCM?
    Mike


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum