Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 9 of 9

Thread: P0153 - HO2S Slow Response Bank 2 Sensor 1

  1. #1
    dukester is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Nov 2008
    Posts
    96

    P0153 - HO2S Slow Response Bank 2 Sensor 1

    Have a 1998 Deville, with 78K miles, at 60K, I had encountered the PO153 code (HO2S Slow Response Bank 2 Sensor 1) had the bank 2 sensor 1 02 sensor replaced with a Bosche.

    Then at 70K, another PO153, this time I replaced the same Bank 2 sensor 1 (Bosche).

    At 77K, another PO153, cleared the code, then at 77.3, PO153, cleared the code, then at 78K, PO153.

    Any advice here?

    In advance, thanks . ..



  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    dukester is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Nov 2008
    Posts
    96

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    Need to add, I had a bad Fuel Pressure Regulator (Great diagnosis from Ranger - many thanks), which was leaking gas into the intake vacuum.

    I just replaced it 100 miles ago, and removed the pos bat for 2 hours, to allow the computer to reset the fuel settings.

    I am wondering if the leaky FPR was causing problems on my 02 sensor?

  4. #3
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    56,842

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    By your statement, the FPR may have been your problem all along. O2 sensors react to rich and lean mixtures, so a rich condition caused by a raw fuel leak would surely mess up the air/fuel ratios and therefore the "expected" values set into the O2 sensor specs.

  5. #4
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    69
    Posts
    82,272

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    Your problem might be Bosche. I would have recommended you stick with A/C Delco.

  6. #5
    dukester is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Nov 2008
    Posts
    96

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    Ranger, why do you recommend AC/Delco over Bosche?

    I was told the Bosche was OEM replacement . . .

    And why do think it might be the BOsche?

    THX!

  7. #6
    dkozloski's Avatar
    dkozloski is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2006 STS V8 AWD, '95 Ford Ranger
    Join Date
    Jul 2004
    Location
    Fairbanks, Ak
    Age
    77
    Posts
    28,285

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    Many forum members have reported bad results with Bosche stuff.
    Don't mess with Binky Bear!


  8. #7
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    56,842

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    (Robert) Bosch equipment is "OEM style". Original is Delphi or ACDelco. BUT, what company actually made the sensor is the mystery........

  9. #8
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    69
    Posts
    82,272

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    From what I've heard, most Bosche part do not play well with Northstars.

  10. #9
    ewill3rd is offline Cadillac Technician
    Automobile(s): none
    Join Date
    Nov 2005
    Location
    WOODBRIDGE, VA
    Age
    49
    Posts
    11,051

    Re: P0153 - HO2S Slow Response Bank 2 Sensor 1

    The Bosch sensors are made for multiple applications, while in theory they should work the same no matter what they are in, who knows?
    I have seen a lot of Bosch replacements fail, N*'s do not like Bosch plugs for sure.

    That code should be an actual sensor malfunction, a specific set of conditions need to be met for that code to set.
    The only really important thing to remember is that Bank 2 is the front bank on a N*.
    Some people think it is the rear one.

    I don't see a lot of Delco part failures on O2 sensors, seems like buying one factory one would be cheaper than buying 3 Bosch parts.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum