93 runs rough when hot.
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Northstar Engines and System Technical Discussion Discussion, 93 runs rough when hot. in Cadillac Engine Technical Discussion; hi guys, my 93 sts runs rough only when hot . feels like a miss,stutter,.i already replaced the plugs,ign wires. ...
  1. #1
    silver duke is offline Cadillac Owners Member
    Automobile(s): 93 cadillac sts seville
    Join Date
    Oct 2005
    Location
    vancouver bc
    Posts
    44

    93 runs rough when hot.

    hi guys, my 93 sts runs rough only when hot . feels like a miss,stutter,.i already replaced the plugs,ign wires. no change, car never set any codes till today. however i don"t know if they are related to this problem.today. the abs light came on and the traction disabled came up. i checked codes got: p137,io32,a015 all current. (traction ctrl). i tried to take pcm snapshot, gave me pd01-.9. pcm input said lo 0 pi70? the pcm snap shot -.9 pdo1 never changed from idle or as i was driving. bad tps? i'm thinking of changing the coil packs ,tps and fuel filter,and clean egr. sts has 120 miles.never stalls but runs very rough when hot ,idling at lights and under load but no rpm drop off. any ideas i need to fix this asap

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    72,325

    Re: 93 runs rough when hot.

    All 8 injectors working?

  4. #3
    silver duke is offline Cadillac Owners Member
    Automobile(s): 93 cadillac sts seville
    Join Date
    Oct 2005
    Location
    vancouver bc
    Posts
    44

    Re: 93 runs rough when hot.

    when the car is cool it runs fine. after about 45 minutes to an hour the problem starts . when i let it cool down it is ok again but when hot same rough running and loss of power bad vibration shake at idle. i think if i had a bad injector the problem would be there all the time?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting