93 Eldorado T.C ignition issues
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 25
Northstar Engines and System Technical Discussion Discussion, 93 Eldorado T.C ignition issues in Cadillac Engine Technical Discussion; I need help please!! We have a 93 touring Coup w/ 83K. Last week it began stumbling before it reached ...
  1. #1
    jrcougars is offline Cadillac Owners Member
    Join Date
    Apr 2006
    Posts
    12

    93 Eldorado T.C ignition issues

    I need help please!! We have a 93 touring Coup w/ 83K. Last week it began
    stumbling before it reached operating temp. Now it stumbles all the time.
    It starts fine and has never failed to start and has never died. It will start to
    miss then even out and run fine for a min. or 2 then miss badly again then
    recover.
    it will idle flawlessly from cold start to about 150 degrees then start to stutter.
    It has 4 codes that keep re-occuring. They are..
    23- EST problem- ignition control
    25- 24X signal low
    30- Idle speed contorl
    and 83- one book has this one no crank signal a or b
    another has this one 24x signal high.....
    There is no miss past idle or WOT.
    I am sure the ISC code is due to the inability to maintain a constant idle.
    The ISCM is working itself to death...
    We have replaced.. Plugs, wires, ICM, and cam sensor as well as all 4 coils.
    the car has not been serviced prior to this issue, so I am ruling out tampering.
    Very interested in anyone's ideas....
    Thanks
    jim

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Eldorado T.C ignition issues

    Quote Originally Posted by jrcougars
    I need help please!! We have a 93 touring Coup w/ 83K. Last week it began
    stumbling before it reached operating temp. Now it stumbles all the time.
    It starts fine and has never failed to start and has never died. It will start to
    miss then even out and run fine for a min. or 2 then miss badly again then
    recover.
    it will idle flawlessly from cold start to about 150 degrees then start to stutter.
    It has 4 codes that keep re-occuring. They are..
    23- EST problem- ignition control
    25- 24X signal low
    30- Idle speed contorl
    and 83- one book has this one no crank signal a or b
    another has this one 24x signal high.....
    There is no miss past idle or WOT.
    I am sure the ISC code is due to the inability to maintain a constant idle.
    The ISCM is working itself to death...
    We have replaced.. Plugs, wires, ICM, and cam sensor as well as all 4 coils.
    the car has not been serviced prior to this issue, so I am ruling out tampering.
    Very interested in anyone's ideas....
    Thanks
    jim
    Hmm.... You likely have more than one problem, possibly an intermittant problem as well. For sure, you probably have one bad crank sensor. You can test for which it is by disconnecting one, trying to start it, and then repeating (with the other one plugged back in). Whichever crank sensor allows you to stay running is the good one. (it could also be the wiring to the "bad" sensor, keep that in mind)

    You may also have an intermittant short or open in your wiring. That's going to take a bit of work to find.

  4. #3
    jrcougars is offline Cadillac Owners Member
    Join Date
    Apr 2006
    Posts
    12

    Re: 93 Eldorado T.C ignition issues

    Thanks for the tip. I'll check it out.

  5. #4
    jrcougars is offline Cadillac Owners Member
    Join Date
    Apr 2006
    Posts
    12

    Re: 93 Eldorado T.C ignition issues

    I tried the sensor test.. no luck. it ran the same w/ either sensor conected....
    and that was poorly, but it ran...So it is back to the drawing board....

  6. #5
    peteski is offline Cadillac Owners Enthusiast
    Automobile(s): 85 Eldo Biarritz
    Join Date
    Dec 2003
    Location
    Northeast USA
    Posts
    808

    Re: 93 Eldorado T.C ignition issues

    24X signal is generated by the ICM and received by PCM. If it constantly comes up "low", and you replaced the ICM, then either the wiring harness or possibly the PCM could be defective.

    What you need it the HELM Factory Service Manual. It has diagnostic charts for troubleshooting error codes. That would help you in this case.

    Peteski

  7. #6
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Eldorado T.C ignition issues

    The next thing you need to do is verify whether the 24x signal is making it to the PCM. What you have to do is backprobe the blue PCM connector, pin F1, and check with your voltmeter set to frequency (hopefully you've got one that does, otherwise it becomes more difficult)

    Should be light blue/black. The PCM is probably located in some terrible location, like underneath the dash. It may require a lot of work to get to it.

  8. #7
    jrcougars is offline Cadillac Owners Member
    Join Date
    Apr 2006
    Posts
    12

    Re: 93 Eldorado T.C ignition issues

    yuck, this is getting ugly.... I would like to have one of those service manuals.
    ideas on where to score one. I don't have a G.M. buddy...

  9. #8
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Eldorado T.C ignition issues


  10. #9
    jrcougars is offline Cadillac Owners Member
    Join Date
    Apr 2006
    Posts
    12

    Re: 93 Eldorado T.C ignition issues

    Thanks for the link!!

  11. #10
    parts68 is offline Cadillac Owners Fanatic
    Automobile(s): 02 Escalade,96 Aurora,with Shelby engine
    Join Date
    Jan 2006
    Posts
    345

    Re: 93 Eldorado T.C ignition issues

    try ebay for a used one
    normally under $50

  12. #11
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: 93 Eldorado T.C ignition issues

    Depending on where you live the library may have Alldata available. In Phoenix and in San Diego it's available. You may have to go to the library to access it though.

  13. #12
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Eldorado T.C ignition issues

    yeah, they come up on ebay every so often. If you've got the time to wait... you can save about $80.

  14. #13
    jrcougars is offline Cadillac Owners Member
    Join Date
    Apr 2006
    Posts
    12

    Re: 93 Eldorado T.C ignition issues

    Thanks for the tips. I am going to dust off the old library card and see what happens..i think I will have better luck w/ e-bay though.. :-)

  15. #14
    jrcougars is offline Cadillac Owners Member
    Join Date
    Apr 2006
    Posts
    12

    Re: 93 Eldorado T.C ignition issues

    just found a pair of the GM service manuals on e-bay.They are on the way.
    Thanks. I will keep you all updated.
    I have to ask though, I am having a rough time with the car just devoloping
    wiring issues.. Is this a common problem?? I understand component failure, I can even stretch and go for a PCM failure out of the blue. But this car's hood
    has been up I swear only about 4 or 5 times in the last 6 years. i just changed
    the original serp. belt a year or so ago.... It is just not driven very often.
    The only time it gets wet is when it is washed.. (not my idea BTW)...LOL

  16. #15
    Rob_M's Avatar
    Rob_M is offline Cadillac Owners Enthusiast
    Automobile(s): 99 Cadillac STS
    Join Date
    May 2004
    Location
    Novato, CA
    Age
    41
    Posts
    956

    Re: 93 Eldorado T.C ignition issues

    I just had an issue where my TRACTION DISABLED light came on and off plus it would hesitate, had a loss of power(especially on the freeway at 45-65mph) and stall intermitently. I replaced everything under the sun: battery cables, isc motor,crank and cam sensors, igniton switch, icm, map sensor, fuel pump, 2 EBTCM's. Nothing worked eventhough my codes and the trouble tree pointed to the EBTCM. It would run great for up to a day or so then would have the problems all over. I ended up swapping the previous j-yard EBTCM for a new PCM at the junkyard for $100. Put it in and it hasn't skipped a beat. The moral of the story is that I spent close to 3 grand trying to chase the problem and it turns out to be the PCM. Plus, for our year, there was a TSB about surging/loss of power/and hesitaion and they came out with a newer PCM fixing the problem..... Hope that might help.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting