TRANSMISSION/Torque convertor problems??? HELP!!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 14 of 14
Northstar Engines and System Technical Discussion Discussion, TRANSMISSION/Torque convertor problems??? HELP!!! in Cadillac Engine Technical Discussion; So im driving about 65 on the highway when it seems like all of the sudden the car goes into ...
  1. #1
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377

    Exclamation TRANSMISSION/Torque convertor problems??? HELP!!!

    So im driving about 65 on the highway when it seems like all of the sudden the car goes into nuetral, SES light comes on and its starts jolting all over. i pull over, restart. no SES light, car goes from 1-2-3 fine, seemed kinda different but fine. then at about 55 or so when its supposed to go into OD it does the nuetral thing with the SES light back on. Now i get off the highway and drive the streets. now that the SES light is on. the car is locked into 2nd NO first gear, even if i put it in 1st. rev's keep rising, no 3rd, eventually gets to fast and goes back into nuetral till i slow down. but if i restart it it will start in 1st - 2-3 then when its supposed to go into 4th it goes into nutral, goes crazy all over again. reverse/park still work.

    then i get to where im going. car sits for 4 hours. i start comming home, leave it in 3 so it won't try to shift to 4th. works fine for a half hour, then when i put it in 4th it does it all over again. but know when i restart it is completely locked into 2nd. so im driving and i decide to see if it will go into 3rd, it seems like its in nuetral when im driving 40 or so up until i hit about 4k rpms, then all of the sudden it starts going, all the way till it hits the rev limiter (6.2k) in 2nd, does the nuetral thing again.

    any ideas? ive tried to get it scanned before to see what codes, and it never works its a 95 aurora, and i guess its obdI with some sort of wierd plug thats not the same as most obdI's.

    thanks

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377
    Thread Starter

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    actually it started to "catch" at like 3k, good grip at 3.2.

    probably what my stall speed is? 3k? no wonder its a dog off the line.

  4. #3
    epanightmare is offline Cadillac Owners Member
    Join Date
    Oct 2003
    Location
    Richmond Va.
    Age
    35
    Posts
    38

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    Quote Originally Posted by Dubya
    actually it started to "catch" at like 3k, good grip at 3.2.

    probably what my stall speed is? 3k? no wonder its a dog off the line.
    sounds like you have a internal malfunction of the trans, either a broken o.d. band/ over drive servo or a faulty oneway clutch .
    the reason that the tran will only run in second gear is because when the trans fault sets a code the PCM puts the trans into a limp mode so that you can get the car home..

    btw if the stall speed was 3k it would probably make a good street converter..

  5. #4
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377
    Thread Starter

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    turns out its a common problem for high mileage 95-96 aurora's. not sure if it is for a cadillac, but there the same transmissions. i ordered a valve replacement kit for $65 (or also known as shift solenoids) which included both solenoids.

    part should be in tomorrow morning, so ill intall them that night after school (but before work.....this should be fun )

  6. #5
    51magnum is offline Cadillac Owners Member
    Join Date
    Jul 2003
    Location
    Boise, ID
    Posts
    45

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    Quote Originally Posted by Dubya
    turns out its a common problem for high mileage 95-96 aurora's. not sure if it is for a cadillac, but there the same transmissions. i ordered a valve replacement kit for $65 (or also known as shift solenoids) which included both solenoids.

    part should be in tomorrow morning, so ill intall them that night after school (but before work.....this should be fun )
    Hey,
    Did you replace the solenoids yet? My wifes STS just started doing exactly what yours did. PLEASE let me know what you find, i.e. if it fixes the problem.

    Thanks a lot,
    Shane

  7. #6
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377
    Thread Starter

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    Yes, i did replace the solenoids, and it was physically broken. but the problem didn't go away. changing them was a pain too, when i opened it (lower control plate that houses solenoids) 3 ball bearings came out, couldn't find where they came from, still don't know.

    trust me, bring it to a cadillac dealer. another aurora owner had the same exact problem as me, same results. only he knew where to put the ball bearings when they came out! but he still has the problem

    im taking it to the dealer friday morning, ill let you know. i don't recommend at all that you try to fix it, the 4t80e is a extremely complicated transmission, very very hard to work with/on. wish i would have known

  8. #7
    51magnum is offline Cadillac Owners Member
    Join Date
    Jul 2003
    Location
    Boise, ID
    Posts
    45

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    Dubya,
    I did it last night and it completely fixed my problem. If you need some help ask. I have the diagams that show exactly where the balls go.

    sorry you didn't have any luck, by the way there are 4 ball bearings.

    Shane

  9. #8
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377
    Thread Starter

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    i have the service manual made for 95 aurora's/riviera's. and it said nothing about the ball bearings. you JUST changed the solenoid and it worked? im glad it worked for you, but it didn't for me cadillac has my car now.

    first thing they did when they called about 10 minutes ago "to change the valve body.....blah blah your looking at 11.8 hours in labor...blah" im like, sir, i had that out in a hour to a hour in a half........pause......"which one, there's two?" the bottom one, (yes i TOLD him this when i was there, why would i try to change something that takes 12 hours to get at!!!!) then he says "oh, i thought it was the side one, let me talk to the transmission specialist and get back to you"

    hopefully it was just a honest mistake, didn't leave a good taste in my mouth. anyone know where i can look up GM replacement time hours for various things, like say, a lower valve control body for a 95 4t80e???

  10. #9
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    Dubya,
    I'm in Phoenix Az, The library here has Alldata and Mitchell's available in the branches. You can't access it from the internet. Check with the library where you live and see what they have.
    The library here added them in the last few years because people were asking for them. They had Alldata first. About a year ago they asked me to fill out a request card for Mitchell's. They were justifying the need for it.
    So if they don't have it ask if there's a way you can request it. You may want it again in a while

    Anyway, they show service times.

  11. #10
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377
    Thread Starter

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    dealer just called. put it all in and back together, problems not fixed

    and the $$$ goes up...to what??? who knows

  12. #11
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377
    Thread Starter

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    UPDATE

    problems fixed, got it back monday

    the solenoid kit i bought came with a little bracket. i didn't take off a bracket, so i didn't put it on, didn't even know where it went. i guess that braket held the new valve filter in place, when caddy put the bracket on, it shifted fine. there wasn't a braket there for 134,000 miles, no idea why it needed one now, maybe the solenoids held it in place better before, then they updated the design, i dunno

    but it works

  13. #12
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    It is an update because the filter is what breaks the solenoids. Not sure why not having it on didn't let the trans shift.
    Possibly they reseated the solenoids and aren't saying.

  14. #13
    Dubya is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Posts
    377
    Thread Starter

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    nope, another aurora had the same problem and he fixed his right after mine by adding the bracket.

    they said the filter blocked the valve, maybe the new solenoids allowed it slide out further, because it slide out to the point of almost falling out

  15. #14
    51magnum is offline Cadillac Owners Member
    Join Date
    Jul 2003
    Location
    Boise, ID
    Posts
    45

    Re: TRANSMISSION/Torque convertor problems??? HELP!!!

    Dubya,
    I found the location of the balls on the AllDataDIY.com web site. I don't know what I would do with out this site. I have three different cars signed up and it has saved me thousands of dollars. I think it cost $25 bucks for the first car and then $14 bucks for additional cars. You have to signup each year paying the $14 but it is worth it. It gives all the TSB and great wiring diagrams. Check it out. I am glad your car is fixed.

    Later,
    Shane

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting