93 Northstar Stalls with no codes
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16
Northstar Engines and System Technical Discussion Discussion, 93 Northstar Stalls with no codes in Cadillac Engine Technical Discussion; I have replaced a fuel pump and TPS and get either no codes or the following codes - P042 P042 ...
  1. #1
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70

    93 Northstar Stalls with no codes

    I have replaced a fuel pump and TPS and get either no codes or the following codes - P042 P042 P071 P095. It runs and idles smoothly - when in drive it sputters and can only handle small amount of acceleration- if you try to give it gas it just sputters out and stalls. I thought a malfunctioning MAP sensor causes it to use defaults and still run relatively well - this is barely running with brief sprints of running normally. Is there a simple test for a defective PCM? I am starting to go gray with figuring out this problem.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Northstar Stalls with no codes

    have you changed the fuel filter?
    my camaro did the exact same thing - the old car dealer changed everything out (including the fuel pump) but left the old filter. Got it for cheap, changed the $10 filter, good as new.

    Upon reviewing your codes, I would remove the top cover of the intake (8 bolts around the perimiter, I think, maybe 10, NOT the 4 recessed ones), and replace the map sensor. Be sure to check the wiring for any knicks, and the connector for any crap as well.
    With that code 71, I'm surprised you didn't start there.

    I also looked at your other thread, and you mentioned it had a code 70 (TPS intermittant) as well. That's not surprising, considering the criteria for that code to be set. Basically, it will set a TPS code if it sees you open the throttle, but the MAP sensor doesn't follow it (i.e. it's broke).

  4. #3
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70
    Thread Starter

    Re: 93 Northstar Stalls with no codes

    There in lies my problem - it had been throwing TPS errors and behaving the same way - I replaced it and it still did the same thing - then I went over the wiring harness as best I could and found nothing - I read that with a failed MAP sensor it will use a generic reference - it is so barely running I figured it was not a generic reference it is running on - and its times of running well under load is only very brief if at all. I thought that the TPS and MAP failing nearly exactly at the same time was statistically not likely. Is there an overide I can put in to get me a week of better drivability?

  5. #4
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Northstar Stalls with no codes

    Read my edit for the TPS solution...

    It all goes back to the MAP sensor. I don't know what the PCM does in the event of a MAP failure. I would suspect it defaults to alpha-N control, which would mean really sucky drivability.

  6. #5
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70
    Thread Starter

    Re: 93 Northstar Stall with and without codes

    Just read the last two sentences of your response - that makes some sense. Yes- I replaced the fuel filter when I did the fuel pump- I must ask though - while limping home last night it threw no codes but acted the same way as this morning with codes?

  7. #6
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Northstar Stalls with no codes

    For codes to be set, certain parameters have to be met for certain amounts of time. It's possible the MAP sensor is only "slightly bad", causing it to meet the time parameters just slightly... so then you have an intermittant code.

  8. #7
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70
    Thread Starter

    Re: 93 Northstar Stalls with no codes

    One sort of constant has been when you give it gas it just stutters out to a stall. I have been viewing the MAP sensor output while driving and it appears to be giving continual information - the Barometric static pressure reading has been 83 or there abouts in southern Florida.

  9. #8
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Northstar Stalls with no codes

    The barometric reading should be close to 100 at sea level. If the MAP sensor doesn't change when you're driving, then that would be another clue.

  10. #9
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70
    Thread Starter

    Re: 93 Northstar Stalls with no codes

    There are two barometric readings I think - while in diagnostics I can see it moving while driving - it changes - the other reading I think is the local barometric pressure it reads 86.

  11. #10
    delzy's Avatar
    delzy is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Dev, 94 FW (crushed), 96 FW Limo (sold), 95 SLS (sold)
    Join Date
    Feb 2005
    Location
    The Last, Best Place
    Posts
    366

    Re: 93 Northstar Stalls with no codes

    OK, I'm not just going to come in here and tell you to start replacing parts on my hunch, but I thought I'd drop you a link to a thread where my car acted unpredictably and erratically. My repair was computer replacement. Cheaper than the ISC and not much more than the knock sensor that were both unnecessary. Good luck and pleas post results.

    http://www.cadillacforums.com/forums...ad.php?t=45720

  12. #11
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70
    Thread Starter

    Re: 93 Northstar Stalls with no codes

    I read your post earlier - I am thinking it is the PCM but I think I am going to splurge on the MAP sensor first - at this point I am in so far I might as well cough up the 120.00 for the MAP sensor- strangely while just running out I could not get the map sensor readings to change- that was not the case while watching it on the way home last night but it runs the exact same???

  13. #12
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 93 Northstar Stalls with no codes

    I'm sure you could get one for like $20 at a junkyard... Probably would be worth the drive.

    What does the "moving" baro reading say at idle? Should be around 30 I would think... The "actual" barometric reading is quite far off from ideal. It should be reading 100kPa +0/-5 or so.

    Have you had any backfires recently? Sometimes those can take out the MAP sensor... fracture the piezoelectric crystal...

  14. #13
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70
    Thread Starter

    Re: 93 Northstar Stalls with no codes

    I am getting reading in the 50's while idling - it doesn't change much and the reading is now 66 and remaining steady- I think both those are bogus readings and will be buying the sensor Saturday- I don't think a nicked wire or bad harness would be giving off those steady readings.

  15. #14
    Aaron J Williams's Avatar
    Aaron J Williams is offline Cadillac Owners Member
    Automobile(s): 61 ragtop,2 67 eldos,68 ragtop,68CDV,89SDV,90 fleet,93 ETC
    Join Date
    Apr 2005
    Location
    Luck Wisconsin
    Age
    48
    Posts
    75

    Re: 93 Northstar Stalls with no codes

    Just a couple of things here; according to GM the Baro should be between 97 and 105 Kpa depending on weather conditions.The failure condition required to set P071 is that the MAP sensor reading changes more than 6.3 kPa in 12.5 milliseconds.When the code sets the PCM uses a substitute value based on engine RPM and throttle position switch status.The thing that bugs me is why only the front bank oxygen sensor shows a lean reading (P042) instead of both banks showing lean? Anyway, there are a couple of easy tests you can do to check the MAP sensor. Turn the ignition on and go into diagnostics and select the MAP sensor data (PD02) then take the engine cover off and check the reading .10 to 84 kPa= replace the MAP sensor,85 to105 kPa apply 20" of vacuum to the MAP sensor and check the reading. It should be 26 to 34 kPa and if its not, replace the MAP sensor.Remove vacuum and see if the reading is the same as before applying the vacuum. If not,replace the MAP sensor. Every 1" of vacuum applied should equal a 3 to 4 kPa drop in paramater PD02 and make sure as you apply the vacuum slowly that there is no skip or jump in the PD02 parameter as that indicates a bad MAP sensor as well. Hope this helps.

  16. #15
    prosin is offline Cadillac Owners Member
    Automobile(s): Allante
    Join Date
    Sep 2005
    Age
    49
    Posts
    70
    Thread Starter

    Re: 93 Northstar Stalls with no codes

    TA-DA - A lunch time MAP replacement immediately gave me a local reading of 102 and 35 at idle- it runs perfectly now. I am somewhat leary that I am good to go though because it would mean that after replacing the TPS the MAP sensor failed- I guess they were both going bad.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting