weird?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 11 of 11
Northstar Engines and System Technical Discussion Discussion, weird? in Cadillac Engine Technical Discussion; Ok so usually these codes come up when i run them in my car for my service engine light. P1035 ...
  1. #1
    cadillac6's Avatar
    cadillac6 is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Location
    NC
    Age
    32
    Posts
    149

    weird?

    Ok so usually these codes come up when i run them in my car for my service engine light.

    P1035
    P0141
    P0147
    P0155
    AND
    P1139

    They usually read all of them but i check again and now the P1139 is just showing up. This means

    Ho2S "o2 bank1 sensor1 insuffiecient switching.

    Why did it used to read all of them and now is just reading this code? what does insufficient switching mean? help me out guys?!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    elwesso's Avatar
    elwesso is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V, 1994 Infiniti Q45
    Join Date
    Jan 2003
    Location
    Indiana
    Posts
    7,668

    Re: weird?

    Well all those other codes were probably history codes, and you cleared the codes and they went away.... Usually the history codes have to do with stuff like "engine near miss detected" or something along those lines.....

    Insufficient switchings means the o2 sensor needs to be replaced..... The o2 sensor during cruise or mild acceleration directly controls the injector open time (when at operating temp).... Anyway, the computer controls the injector open time when the o2 sensors arent doing a good job.....

    I dare say you will see some performance and gas mileage increase...... Also, i would replace ALL 02 sensors....

  4. #3
    cadillac6's Avatar
    cadillac6 is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Location
    NC
    Age
    32
    Posts
    149

    Re: weird?

    WES!!! I JUST REPLACED ALL OF THEM LESS THAN 2 WEEKS AGO!!!?? what is the deal here?

  5. #4
    elwesso's Avatar
    elwesso is offline Cadillac Owners Master
    Automobile(s): 2005 CTS-V, 1994 Infiniti Q45
    Join Date
    Jan 2003
    Location
    Indiana
    Posts
    7,668

    Re: weird?

    Oh..... Sorry, I didnt remember that you did that!!!! I have a lot of things to keep track of.....

    Anyway, I guess I would check the harness connections..... Without a FSM, im not sure what to say..... I bet its electrical.....

  6. #5
    DaveSmed's Avatar
    DaveSmed is offline Cadillac Owners Connoisseur
    Automobile(s): 1968 Cadillac Sedan deVille, 1994 Chevrolet G20
    Join Date
    Aug 2003
    Location
    Bucks County, PA
    Age
    27
    Posts
    2,795

    Re: weird?

    Did you by any chance get the "universal" O2 sensors? If so, how did you splice them in? A poor connection could cause that code and inaccurate info to be fed into the computer.

  7. #6
    cadillac6's Avatar
    cadillac6 is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Location
    NC
    Age
    32
    Posts
    149

    Re: weird?

    Quote Originally Posted by DaveSmed
    Did you by any chance get the "universal" O2 sensors? If so, how did you splice them in? A poor connection could cause that code and inaccurate info to be fed into the computer.
    I didnt put any universal o2 in. Didnt have to splice anything they all fit in there 2 before the cat and 2 after if im not mistaken. I just dont know what else to do!

  8. #7
    DaveSmed's Avatar
    DaveSmed is offline Cadillac Owners Connoisseur
    Automobile(s): 1968 Cadillac Sedan deVille, 1994 Chevrolet G20
    Join Date
    Aug 2003
    Location
    Bucks County, PA
    Age
    27
    Posts
    2,795

    Re: weird?

    Are the manifold sensors the same? If so, I would swap them and see if the code follows. If it does, take the sensor back. If it doesn't, it is almost definitely a wiring fault. Check the connector and the wires for heat damage.

  9. #8
    cadillac6's Avatar
    cadillac6 is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Location
    NC
    Age
    32
    Posts
    149

    Re: weird?

    Quote Originally Posted by DaveSmed
    Are the manifold sensors the same? If so, I would swap them and see if the code follows. If it does, take the sensor back. If it doesn't, it is almost definitely a wiring fault. Check the connector and the wires for heat damage.
    All my sensors are bosch. How do i swap the manifolds?

  10. #9
    DaveSmed's Avatar
    DaveSmed is offline Cadillac Owners Connoisseur
    Automobile(s): 1968 Cadillac Sedan deVille, 1994 Chevrolet G20
    Join Date
    Aug 2003
    Location
    Bucks County, PA
    Age
    27
    Posts
    2,795

    Re: weird?

    Not the manifolds, the O2 sensors. Before you do, check and see if they have the same connector.

  11. #10
    mcowden is offline Cadillac Owners Connoisseur
    Join Date
    Jun 2003
    Posts
    1,164

    Re: weird O2 sensors problem

    Quote Originally Posted by DaveSmed
    Not the manifolds, the O2 sensors. Before you do, check and see if they have the same connector.
    The "front" O2 sensors (accessible from engine compartment) are unheated and have a different connector than the heated "rear" sensors (one before and one after the cat). They are not interchangeable.

    It sounds like either bad wiring somewhere in the circuit or a bad O2 sensor. Yes, I realize they are new and it's frustrating, but you've got limited options at this point. Try switching the sensors before and after the catalytic and see if the code changes. If it does, you'll know it's a bad sensor. If not, it's probably bad wiring between the harness and computer but will require further diagnosis.
    Mike

  12. #11
    cadillac6's Avatar
    cadillac6 is offline Cadillac Owners Fanatic
    Join Date
    Oct 2003
    Location
    NC
    Age
    32
    Posts
    149

    Re: weird?

    Well i am taking it to the shop tomorrow and see what happens. I heard its probably a dirty fuel injector? oh well wish me luck and wish my pockets the same! i'll let you guys know

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting