Code problem, please help!!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Northstar Engines and System Technical Discussion Discussion, Code problem, please help!!! in Cadillac Engine Technical Discussion; I am getting the P026 and P027 intermittently. I can clear them or they clear themselves and come back on ...
  1. #1
    D-Mun is offline Cadillac Owners Member
    Join Date
    Oct 2004
    Posts
    2

    Question Code problem, please help!!!

    I am getting the P026 and P027 intermittently. I can clear them or they clear themselves and come back on and off. I have done some work, but nothing seems to correct it. No rhyme or reason to it. I also have the R026 what do I do about this one? Is this a dealer issue?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: Code problem, please help!!!

    Did you look up the code? The lists are at the top of the section.

    What model and year?

  4. #3
    D-Mun is offline Cadillac Owners Member
    Join Date
    Oct 2004
    Posts
    2
    Thread Starter

    Re: Code problem, please help!!!

    I did. The P026 and27 are shorted and open throttle signal switch. The R026 is Driver initiator circuit open (airbag).


    I had the throttle position sensor replaced. Anyother ideas?

    1993 STS N*

  5. #4
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: Code problem, please help!!!

    I've had the wiring to the intake area loose it's insulation. Check the intake harness wires.

    It goes from the bottom of the intake to a connector under the throttle body. Take the plastic covering off and see if the insulation is off some of the wires. You can repair it with new wire and shrink tubing. If this is your problem it can give you strange problems that the diagnostics can't find. The injectors,egr,and tps are on this harness.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting