96 Deville Northstar, No Oil Pressure out of the blue.
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 11 of 11
Northstar Engines and System Technical Discussion Discussion, 96 Deville Northstar, No Oil Pressure out of the blue. in Cadillac Engine Technical Discussion; This car has been a nightmare, a customer towed the car to me and a used engine to swap out ...
  1. #1
    rispeed is offline Cadillac Owners Member
    Join Date
    Aug 2005
    Posts
    6

    96 Deville Northstar, No Oil Pressure out of the blue.

    This car has been a nightmare, a customer towed the car to me and a used engine to swap out was a nightmare from the beginning, motor was completely seized so i had to slide it out of the transmission, anyways after everythings all done the motor ran awesome , except the coolant tube that runs on the back of the motor had a pinhole in it, which in itself is a nightmare to repair, then after the car ran for 30 minutes with no problems, it just lost all oil pressure and started ticking real loud.. i even primed the filter with oil before i put it on the car and cranked the motor over a rediculous ammount before connecting the coil packs. Is there something known on this engine ? Its a 95 Motor in a 96 Deville, swapped the intake over and changed the wiring to the knock sensor, but i know that would not cause this lol
    Please shed some light on this nightmare .

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    Have you checked with a mechanical gauge to confirm? Those oil pressure switches frequently bite the dust...

    Also, did you connect the oil cooler lines to the front of the oil filter housing? You CANNOT plug them with NPT fittings, oil MUST flow through there, so you have to either loop it around or install an oil cooler.

    btw- if you did the above ^^^ and ran it for 30 minutes, it's trashed.

    Here are the ports I'm talking about:

  4. #3
    starfox86's Avatar
    starfox86 is offline Cadillac Owners Fanatic
    Automobile(s): 1998 deville, 2000 sls, 2006 cts-v
    Join Date
    Feb 2005
    Location
    Milwaukee, WI
    Posts
    431

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    the engine will run without the oil switch. my 94 sls just had a bad ground cable in the back that cause it to go off for some weird reason. so you might want to check those. I believe mine was in the rear of the engine on the passengers side. I think you might have to drop the back of the engine down though to get to that.. But then again , that might not be your problem.

  5. #4
    rispeed is offline Cadillac Owners Member
    Join Date
    Aug 2005
    Posts
    6

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    Eldorado: Unfortuneatly i did check it with a guage and it has 0 pressure..

    It ran fine for 45 minutes had oil pressure it was fine, then all of a sudden it said shut engine off, now its shot...

    I changed the 96 oil filter adapter over to the 95 engine so there was no oil cooler in the car.

    RYan

  6. #5
    eldorado1 is offline Cadillac Owners Connoisseur
    Join Date
    Feb 2004
    Location
    FL
    Posts
    2,250

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    Quote Originally Posted by rispeed
    I changed the 96 oil filter adapter over to the 95 engine so there was no oil cooler in the car.
    And? On mine there's a piece of U shaped tubing between the two ports. This is the "oil cooler delete" option, if you will. If there's nothing connecting the two ports, the engine will starve for oil...

    Another option, some people have noticed no oil pressure when the harmonic balancer bolt comes undone a bit. Something about the oil pump requiring it to be torqued down adequately to function. Might want to check the torque on that.

  7. #6
    dkozloski's Avatar
    dkozloski is offline Cadillac Owners 10000+ Posts
    Automobile(s): 2006 STS V8 AWD, '95 Ford Ranger
    Join Date
    Jul 2004
    Location
    Fairbanks, Ak
    Age
    74
    Posts
    26,637

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    The oil pump is driven by clamp pressure from the harmonic balancer and bolt.

  8. #7
    BASSIN4FUN2003 is offline Cadillac Owners Member
    Join Date
    Jul 2004
    Location
    MESQUITE TEXAS
    Posts
    13

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    We had a problem with those sticking the check valve in the oil pump with trashyou might add about ten qaurts of oil to it and run it for a little while then drain it to the proper oil level and see if that cleans it out.there was a bulletin on this at one time.

  9. #8
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,372

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    I recall that being mentioned before. Putting about 18 qts. in the sump, submerges the pump in the event it lost it's prime and will reprime it and possibly flush the debris out of the check valve.

  10. #9
    rispeed is offline Cadillac Owners Member
    Join Date
    Aug 2005
    Posts
    6

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    I just tried putting the oil in ill let it sit for a while and see what happens..

    As i said, i took the oil filter adapter off the old engine, the one that ran so must have been okay before.

    I cant believe this would happen, this motor ran with no noises and plenty of oil pressure for almost a full hour then bam no oil pressure...



    Ryan

  11. #10
    rispeed is offline Cadillac Owners Member
    Join Date
    Aug 2005
    Posts
    6

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    filling the motor with oil fixed the oil pressure problem i ran it for like 5 minutes with 18 quarts of oil, it had plenty of oil pressure and motor was ticking very slightly.. Drained it out filled back up to proper level, ran sweet plenty of oil pressure for 1 hour, shut car off started back up no oil pressure

    Wtf...

    Looks like ill have to put another motor in, Good thing its not my motor!

  12. #11
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,372

    Re: 96 Deville Northstar, No Oil Pressure out of the blue.

    Sounds like the oil pump check valve rather than the motor.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting