Problem with my 1994 Eldorado engine - smoking
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Northstar Engines and System Technical Discussion Discussion, Problem with my 1994 Eldorado engine - smoking in Cadillac Engine Technical Discussion; I have a 1994 eldorado and i went to start it and notice some smoke coming from my exhaust so ...
  1. #1
    caddy1994 is offline Cadillac Owners Member
    Automobile(s): 1994 cadillac eldorado
    Join Date
    Apr 2011
    Posts
    25

    Problem with my 1994 Eldorado engine - smoking

    I have a 1994 eldorado and i went to start it and notice some smoke coming from my exhaust so i hit the accelerator a little bit and it was more and more looks like a greyish blueish smoke so i looked under the rear of the car and noticed something was wet on the floor so i ran my finger thru it and it was oil so my question is why would there be oil coming from my exhaust pipe and if someone had the same issue what did you do to fix it and how much did it cost you. I didnt drive it i just turned it off and left it parked anye help would be great. Thanks

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,893
    This happened all of a sudden? Had the car not been started in a long time.

  4. #3
    caddy1994 is offline Cadillac Owners Member
    Automobile(s): 1994 cadillac eldorado
    Join Date
    Apr 2011
    Posts
    25

    Re: problem with my engine

    It did sit for about maybe 6 months and than when i did start it finally it ran fine but i let it sit for maybe a week and it just happenex all of a,sudden so thats why it seemed weired cuz it ran fine before i let it sit for the week or so

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting