1997 STS - Long crank/start times - (Advice / Ideas)
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 15 of 52
Like Tree3Likes
Northstar Engines and System Technical Discussion Discussion, 1997 STS - Long crank/start times - (Advice / Ideas) in Cadillac Engine Technical Discussion; Hey guys I just wanted to know if anyone has seen this problem or has any idea's its very interesting, ...
  1. #1
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41

    1997 STS - Long crank/start times - (Advice / Ideas)

    Hey guys I just wanted to know if anyone has seen this problem or has any idea's its very interesting, here is exactly what is going on.

    Start the car - RPM's jump to about 1.5 for maybe 1 second drops to 750 and surges to 1k for 5 seconds then resets back to normal 750 RPM idle. (This all happens in maybe 3-7 seconds).
    This happens if the car was sitting for maybe 15 mins or more, but if I stop it pump gas and get back its not noticeable.

    No Codes Aside from Compressor code (just needs a new clutch) - This code has been here forever its never posed a problem.
    Zero problems after this 5 seconds starting, perfect acceleration nothing at all.

    Recently: All top-ups are done with the instructions from my manual
    Woke up to transmission leak lost maybe 1/2 quart tighten the line and topped with dexron VI (fluid was nice pink color)
    Spilled about 1 quart of power steering fluid looking for the transmission leak (Dont yell this is my first car, topped it up)

    Things to note:
    New spark plugs / wires & battery, cleaned EGR valve, idle air intake valve - oil at 13% life (changing soon)

    I'm taking it in tomorrow at 9am regardless but having some idea's might help myself or the mechanic.

    Thanks so much everyone!!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is offline Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    22,459
    When was the TB last cleaned?

  4. #3
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS Seville - High RPM just during start (Advice / Ideas)

    I did it in September when I got the car, but I am planning to do it along with my oil change and valve cleans in the next 10 days.

    I've updated the OP

    Thank you for your advice though! I will check it out if the mechanic doesn't find the problem.

  5. #4
    Submariner409's Avatar
    Submariner409 is offline If it won't run, install a sound system
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    45,596

    Re: 1997 STS Seville - High RPM just during start (Advice / Ideas)

    On cold start your engine should fast idle at about 1200 for 15 - 30 seconds, drop to 950 or so for about a minute, then down to normal 650 idle.

    Ambient air temp will change the times ^^ somewhat.

  6. #5
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS Seville - High RPM just during start (Advice / Ideas)

    So not sure if its my battery but I have a 850CCA Ac Delco in there and I've never had it do that even at -30C/-26F, it does do the spike to 1.5k for 3 seconds then down to 1k for 7 seconds then to about 700~750 normal idle (at -30C or -26F, anything at 0C/32F or hotter it does all that in about 3 seconds).

    My situation is its spiking to 1.5k for a second, then drops to 750 then surges to 1k for 5 seconds then goes back to 700~750. It is also taking longer cranking to get it going, its now about 15C or 60F in my garage and it does this or out side 0C or 32F it still does the same thing. Temperature seems to have no baring on the situation from what I can see.

  7. #6
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS Seville - High RPM just during start (Advice / Ideas)

    It seems from the mechanic I have a crack MAF sensor, I'm not sure what exactly is cracked I'll have to take a look when I get the car back. Estimating 800$ for parts and labour I think that's a bit high but I could be wrong anyways ill take a look when I get the car back.

    Thanks for the advice guys!

  8. #7
    Submariner409's Avatar
    Submariner409 is offline If it won't run, install a sound system
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    45,596

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    A used MAF is less than $40 and 20 minutes of labor. Yours is bolted directly to the TB face.

    "Cracked MAF" is a LOOOOONG stretch .....................

    You could always pull any set diagnostic trouble codes from the car's built-in scanner/reader/memory - right in the instrument panel. A "cracked MAF" is an emissions fault - No SES lights ???

  9. #8
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    That's exactly what I thought, I think the dude talking on the phone has no clue what the mechanic said or they are trying to rip me off. There are absolutely no codes or lights unfortunately. That is why I took it to the mechanic because whenever I see any codes (I check once a day) I just use this amazing forums and usually find some information about what it might be and how to fix it.

    Just to double check when we talk codes we mean pressing the "OFF" and Passenger temperature "UP" button at the same time? Or is there another way to get more codes?

    I'll update once I get the straight talk from the mechanic, I cannot thank you guys enough!!

  10. #9
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    Alright so boy was the mechanic RIGHT on the money the MAF is cracked to shit its barely holding on, I've order the whole assemble for tomorrow going to take it off and replace it. Sadly we dont have any scrappers or second hand stuff in kamloops so its 126$ brand new.

    My only other option is to order it from the states for maybe 45$ and wait 2 weeks or more, I already assume that's not very good for my engine so unless someone suggest something else I'll be putting in a new MAF tomorrow.

    If anyone knows any videos or guides or advice about doing it please let me know, but having cleaned the TB before I assume I just disconnect everything take the three bolts off and put it all back together?

    Cheers!

  11. #10
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,555

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    Yup. That all there is to it. Just don't drop those bolts.

  12. #11
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    Quote Originally Posted by Ranger View Post
    Yup. That all there is to it. Just don't drop those bolts.
    My buddy dropped one of those two stage bolts on the EGR valve last September, and man do I remember the amout of effort to find another (even the one I order from GM was wrong but it works).

    Thank you so much guys!

  13. #12
    Submariner409's Avatar
    Submariner409 is offline If it won't run, install a sound system
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    45,596

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    Your MAF work and TB cleaning are all down in Cadillac Tech Tips - Google something like "cadillac forums 1997 seville maf replacement" and "cadillac forums 1997 seville throttlebody cleaning".

    Here's your MAF, off the TB face. I cannot fathom how it got "cracked to shit".

  14. #13
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,555

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    I cannot fathom how it got "cracked to shit".
    Yeah, that would be tough to do, even intentionally.

  15. #14
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    Quote Originally Posted by Ranger View Post
    Yeah, that would be tough to do, even intentionally.
    I am not sure either but it is cracked, once I take it apart tomorrow ill see better and post some photos. I have the guides bookmark for TB cleaning and found the MAF replacement topic also, just wasn't sure if maybe their was a video or anything. Regardless I know ill figure it out so no need to discuss that any further.

  16. #15
    STS_FirstCar_Love is offline Cadillac Owners Member
    Automobile(s): 1997 Seville STS
    Join Date
    Oct 2013
    Age
    23
    Posts
    41
    Thread Starter

    Re: 1997 STS - High RPM just during start (Advice / Ideas)

    Here she is in all her glory, talking to a friend this might have happened if I didn't tighten my bolts after I cleaned my TB last September, but who knows I don't think I would do something as foolish as to not tighten all the bolts properly. Unless things need to be torqued I always tighten them enough that they don't come off but wont strip when I try to remove it again.
    DSC_0066.JPGDSC_0068.JPGDSC_0067.JPG

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting