Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
Northstar Engines and System Technical Discussion Discussion, Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes! in Cadillac Engine Technical Discussion; Hello and thanks in advance for any help. I have a '95 SLS with about 75k miles on it. It ...
  1. #1
    delzy's Avatar
    delzy is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Dev, 94 FW (crushed), 96 FW Limo (sold), 95 SLS (sold)
    Join Date
    Feb 2005
    Location
    The Last, Best Place
    Posts
    363

    Question Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Hello and thanks in advance for any help. I have a '95 SLS with about 75k miles on it. It has been an excellent car since we got it 5k miles ago. I apologize for the long post to follow, but hopefully, you will be able to help if given enough detail.

    I was on my way out of town for a second 2500 mile road trip and about 3 miles from home, the car just died. It wouldn't hold idle but would run if I feathered about half throttle. I slammed it in gear and limped back home. While driving home, it got stuck in 1st gear for a bit and then revved up to about 3000 at a stop light while I had it in neutral. We got back home and parked the caddy and loaded up my E-350 work van for the trip. That was a week and a half ago.

    Yesterday, I pulled the codes. They were all history, none current:
    P021 Shorted Throttle Position sensor
    P022 Open Throttle Position Sensor
    P026 Shorted Throttle Position Switch Circuit
    P032 Open MAP sensor
    P057 Shorted Transaxle Temperature Sensor
    P062 Cruise Control Vacuum Solenoid
    P070 Intermittent TP Sensor
    P091 Transaxle Range Switch Prob (Cruise)
    P094 Transaxle Shift 'A' solenoid Problem
    P095 Engine Stall Detected
    P132 Knock Sensor Circuitry Failure

    I believe these all happened on that one short drive.

    When I turned on the key (but not the engine), the ISC starts clicking for about 10 seconds. when I shut off the key, it clicks again for about 15 seconds steady. I have adjusted the ISC and cleaned the throttle body when we first got the car.

    So I start the car to see if its all just history, but no such luck. The cars idle is about 2000 rpm. I pull the copdes and all are the same except P132 (knock sensor circuitry failure) is current. I pull out my trusty FSM and start to diagnose the P132 according to the trouble tree:

    Backprobing PCM pin 1A13 gives about 8 volts for a couple seconds then drops down to an acceptable 0.48 VDC. So I start the car and the voltage rides between 8.5 and 10 volts. I shut down the engine, pull connector 1 and turn the ignition back on - 0VDC. Pull the connector and find about 3 ohms resistance on the circuit from terminal 1A13 to the terminal on the knock sensor connector. I check CKT 496 for shorts to any other pins on connector 1 and find none.

    I picked up an aftermarket knock sensor from my local NAPA warehouse for $40 and get it installed. I had to go through the passenger front wheel well. A nice tool would have been a 7/8" stubby open end, but of course I had to use a mini vice grip on the threads as I don't have any stubby wrenches. I cleared the codes, pulled the battery terminal for a minute or so and started up the car with the greatest of expectations.

    Same symptoms - fast idle, stall, unstable engine RPM. Still seeing about 9VDC on terminal 1A13 while the engine is running. Here are the new codes (history unless noted):
    P015 Open Engine Coolant Temp Sensor
    P026 - Current while running
    P032
    P061 Cruise Control Vent Solenoid Problem
    P062
    P070
    P071 Intermittent MAP sensor
    P073 Intermittent Engine Coolant Sensor
    P095
    P132 - Current while running
    I052

    I also pulled PD40 - knock retard angle (.7-1.6) and PD41 - Knock events (0).

    At this point, I'm thinking the PCM needs replacement. I'd rather not spend the $250 to learn the problem is in the harness or something stupid like that. How likely is it that a new PCM would be damaged if there is an existing problem in the harness or a component. Is there a good place to order the PCM to save a little jack?

    Also, will I need to get the car professionally serviced if I replace the PCM? How much should that cost if so?

    Maybe I'm in over my head here, but I'd really like to get this car fixed as cheaply as possible. It has been a great car, but I'm really not looking forward to my wife's "I TOLD YOU SO's!!" - She wanted a Toyota!!

    Please help. Speculation is welcome, but I'm really looking for someone who knows what I should do next.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    BeelzeBob's Avatar
    BeelzeBob is offline I'm a Cadillac Fanatic!
    Join Date
    Dec 2002
    Location
    Fort Lauderdale, Florida
    Age
    49
    Posts
    9,577

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Replace the idle speed control motor. If it is clicking like you say when you turn the key on then something is wrong. It is probably failed.

    Lots of info in the archives on the idle speed control motor and adjusting if you search using "idle speed control motor".

    You can run the idle speed control motor in and out manually with the onboard diagnostics or while the engine is idling to confirm that it is failed...but...if it is clicking with the key on and is adjusted remotely close to correct then it is failed. I assume that it was working fine for some time after the throttle body cleaning and idle speed control motor "adjustment" you mentioned? If so, then it is even more likely the ISC motor has failed.

    The MAP sensor sounds iffy also.... If it is setting the MAP sensor code then likely there is a problem with the sensor or the wiring leading to it.

    Concentrate on the MAP sensor code and the idle speed control to get it running correctly. None of the other codes have anything to do with the engine starting and running and idling correctly.

    I wouldn't suspect the PCM immediately. If the MAP sensor dies it can cause poor running and all sorts of other codes that use vacuum/map as a reference. If you think it is the PCM then drop it down from it's mount under the dash and tap on it. The simple "tap" test will often pinpoint a failed PCM as the tapping will cause it to right itself or go crazy.....


    Do you know how to use the on board diagnostic system to look at the PCM parameter readouts for engine data..?? That will tell you immediately if the TPS, MAP sensor, Coolant temp sensor, etc... is reading correctly or needs to be replaced..?? After the codes display on the onboard diagnostics, the PCM? prompt will show up. Answer "yes" using the HI button. When PCM DATA? shows up as a prompt use the HI button again to answer yes. There are about 30 PCM parameters now available for onboard viewing to check sensors, etc. PD01 is the TPS, PD02 is the MAP in kPa, PD03 is the Baro, PD04 is the coolant temp in C, etc... Your factory service manual has the complete list.


    BTW....everyone posting on the internet with a problem would LOVE the guarantee of a quick and positive answer. Without being there all you can get from anyone is speculation. No guarantees.

  4. #3
    delzy's Avatar
    delzy is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Dev, 94 FW (crushed), 96 FW Limo (sold), 95 SLS (sold)
    Join Date
    Feb 2005
    Location
    The Last, Best Place
    Posts
    363

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    bbob, Thanks for the reply. You clearly are someone who knows. I've been lurking this board for about 4 months and I've recognized your contributions as most valid. I thank you once again for a cohesive strategy to repair my car. I'll be sure to resurrect this thread with my findings when my repairs are complete.

  5. #4
    JFrancisco is offline Cadillac Owners Member
    Join Date
    Mar 2005
    Posts
    37

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Hi delzy, have you got your 95SLS back in good order? Sorry I have no "valid contributions" to share, but I'm hoping you can help me instead. I also have a 95SLS, bought it with 27K, had it for seven years, and now it has 140K. Has been a joy to own, never once having caused me a headache. I have been searching this website for a while, looking for someone who can tell me how to pull those pesky CODES but No Luck so far. How did you do it?

  6. #5
    delzy's Avatar
    delzy is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Dev, 94 FW (crushed), 96 FW Limo (sold), 95 SLS (sold)
    Join Date
    Feb 2005
    Location
    The Last, Best Place
    Posts
    363

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Just hold the off and warmer buttons for the climate control at the same time until the display flashes. Then they will spit right out at you.

  7. #6
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Check the intake wiring harness for insulation coming off the wires. Unwrap the covering at the connector under the throttle body so you can see the wires. If you have any copper exposed you'll have to repair or replace the harness.

    Many of your codes are related to things on that harness.

  8. #7
    raymondk is offline Cadillac Owners Fanatic
    Automobile(s): 88 CPE DV, 93 ELDO TOURING
    Join Date
    Apr 2004
    Location
    ZEBULON, NC
    Age
    65
    Posts
    128

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    When the tps is disconnected it exibits a similar condition. with the engine off, enter diagnostic mode for PCM, DATA. Pd 01 and check that the throttle sensor input goes from around 2 to around 80. If always "0" check for 0 to 5 volts at pin 1A? (i forget) tps input at the PCM. If 0-5 is present with throttle position and not indicating at PD01, check for battery voltage at PCM pin 2c &2D (orange #450). You are correct in not blaming the PCM. Mine is doing a similar act which straigened out when I lowered the PCM to the floor.

  9. #8
    oldgamer's Avatar
    oldgamer is offline Cadillac Owners Enthusiast
    Join Date
    Feb 2004
    Location
    Staten Island, NY
    Posts
    577

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Check all grounds just in case. Having so much not related codes can be result of bad grounds.

  10. #9
    delzy's Avatar
    delzy is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Dev, 94 FW (crushed), 96 FW Limo (sold), 95 SLS (sold)
    Join Date
    Feb 2005
    Location
    The Last, Best Place
    Posts
    363

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Thanks for the tips, I'll dig in again on Tuesday and post my findings. This help is greatly appreciated!

  11. #10
    delzy's Avatar
    delzy is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Dev, 94 FW (crushed), 96 FW Limo (sold), 95 SLS (sold)
    Join Date
    Feb 2005
    Location
    The Last, Best Place
    Posts
    363

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Well, I dug in on the Tuesday I said I would and was simply stumped. The voltages at the TPS and Knock Sensor Inputs were way out of whack. I replaced the knock sensor previously with no change then the ISC (Idle Speed Control Motor) - still no change. I cut the wire for the input of the TPS and the voltages were about 1 to 5 as expected. I then decided I would change the PCM. I found one on ebay brand new for $98 shipped. I forgot to check the transmission fluid life indicator before I replaced the PROM, but I managed to reset the warning.

    Anyways, the problem was in the computer. The car is fixed. My gut feeling in the beginning was computer or a major harness failure. My conclusion is if you experience a ton of codes and the computer has b+ and ground where it should, it is likely the computer. 45 days out of commission and $230 in unneeded parts could have been averted if I just would have swapped the computer out.

    Anyone know where I can cash in my PCM core?

    Thanks for all the help.

  12. #11
    zonie77 is offline Cadillac Owners Connoisseur
    Automobile(s): 94 ETC,97 STS
    Join Date
    Sep 2003
    Location
    Arizona
    Posts
    3,531

    Thumbs up Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    Delzy, thanks for letting us know what it was. Too many people never post what eventually fixed their problem!!!

    Did you check that wiring harness? If the computer fixed it I really don't expect it bad, but it would be nice to be sure that wasn't part of the problem.

  13. #12
    delzy's Avatar
    delzy is offline Cadillac Owners Fanatic
    Automobile(s): 2000 Dev, 94 FW (crushed), 96 FW Limo (sold), 95 SLS (sold)
    Join Date
    Feb 2005
    Location
    The Last, Best Place
    Posts
    363

    Re: Help Needed - 95 SLS Stalls then won't idle or Revs Like Crazy! Lots of codes!

    I'm speculating a failed diode in the PCM which botched up the reference voltages for the inputs, but that is just a guess. I did go over the harness quite carefully found no obvious damage. I am keeping my fingers crossed that it is not an intermittent short or failed component that made the PCM fail. If I learn anymore, I'll post in this thread any further info. BTW, thx for your earlier tip.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting