No 4th gear...
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Northstar Engines and System Technical Discussion Discussion, No 4th gear... in Cadillac Engine Technical Discussion; Noticed the little princess was getting lousy gas mileage; ran through the PCM data to discover it wasn't reaching 4th ...
  1. #1
    RLLOVETT is offline Cadillac Owners Fanatic
    Join Date
    Sep 2003
    Location
    Boston
    Posts
    192

    No 4th gear...

    Noticed the little princess was getting lousy gas mileage; ran through the PCM data to discover it wasn't reaching 4th gear; I can command 4th gear in the Override mode but it won't shift there on its own...haven't checked the trans fluid yet; just replaced the A-B solenoids a few months ago...any thoughts (besides trading, at 136k)? Thanks!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    32V_DOHC is offline Cadillac Owners Member
    Join Date
    Feb 2003
    Posts
    46

    Re: No 4th gear...

    Sounds like you are saying you can force an upshift using overrides and the trans upshifts. If that is the case then I would check the value for trans temp, TPS and VSS to see if they make sense. Sounds like a PCM, wiring, sensor problem that causes 4th not to be commanded.

    HTH

    John

  4. #3
    RLLOVETT is offline Cadillac Owners Fanatic
    Join Date
    Sep 2003
    Location
    Boston
    Posts
    192

    Re: No 4th gear...

    Thanks for the suggestions! Just checked the fluid which is full and a nice color but foamy...will update...

  5. #4
    RLLOVETT is offline Cadillac Owners Fanatic
    Join Date
    Sep 2003
    Location
    Boston
    Posts
    192

    Re: No 4th gear...

    Trans temp was about 43 (engine temp about 199, outside temp about 30F); Transaxle Pressure Switch reads correctly; Vehicle Speed Sensor reads a bit slower than the speedo...I'm leaning (praying) toward a loose connector due to sudden warming we've had here...

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting