STS High Idle
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 14 of 14
Northstar Engines and System Technical Discussion Discussion, STS High Idle in Cadillac Engine Technical Discussion; I have a 1993 STS that has recently been idling high, over 1200 RPM. Checked codes and came up with ...
  1. #1
    BSexton is offline Cadillac Owners Member
    Join Date
    Dec 2004
    Age
    59
    Posts
    14

    STS High Idle

    I have a 1993 STS that has recently been idling high, over 1200 RPM. Checked codes and came up with P030 which i understand to be ISC RPm out of range.Can someone tell me how to correct the high idle?
    Thanks, Bill

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,036

    Re: STS High Idle

    Search the archives. I am sure I have seen bbob explain how to properly adjust it. If that doesn't work, likely it is failing and needs replacing. I am assuming you know that ISC is the idle speed control motor or did the '93 use the idle speed control valve? If it is the valve, it will be located on the forward side of the T/B and may just be sticking and allowing too much bypass air causing a high idle.

  4. #3
    peteski is offline Cadillac Owners Enthusiast
    Automobile(s): 85 Eldo Biarritz
    Join Date
    Dec 2003
    Location
    Northeast USA
    Posts
    808

    Re: STS High Idle

    You might also want to check for vacuum leaks (at the intake manifold). My 93 was idling a litttle high (once it also set same error code as yours). What I found was a disconnected vacuum hose on the top of the throttle body (if that is what it is called). There is a rubber or plasic piece with 3 openings and 3 vacuum lines attached. One of mine was disconnected. That was allowing extra air into the intake manifold.

    I hooked it back up and it is now idling around 700RPMs.

    Peteski

  5. #4
    Spyder's Avatar
    Spyder is offline Cadillac Owners Master
    Automobile(s): None now...1972 Challenger=my pride and joy.
    Join Date
    May 2004
    Location
    Sonoma Co, CA
    Age
    31
    Posts
    5,685

    Re: STS High Idle

    My 94 STS just got a new ISC motor...was clicking and buzzing and making noises for ten or fifteen seconds at startup and shutdown, and towards the end started idling at around 1100, which caused it to run hot, around 230 in town with it being 45 degrees out...put the new one in and it fixed everything. Check the vacuum lines first though, as the ISC costs about $95 from napa...it is quick and easy to change out by yourself though.

  6. #5
    BSexton is offline Cadillac Owners Member
    Join Date
    Dec 2004
    Age
    59
    Posts
    14

    Re: STS High Idle

    I have also heard the 10 seconds of clicking after I shut the engine off. Is this an indication of a bad ISC motor? Also is there a website that would show pictures from a manual that would show where and what the ISC motor would look like on a 1993 STS?
    Thanks Bill

  7. #6
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,036

    Re: STS High Idle

    Yes, I think that is a sign of a failing ISC motor. Check the last page of this thread. There is a picture there. Also some good info in the thread.
    http://caddyinfo.ipbhost.com/index.p...opic=2969&st=0

  8. #7
    cart69's Avatar
    cart69 is offline Cadillac Owners Fanatic
    Automobile(s): 96STS engine only!! only thing left from my 96 after divorce
    Join Date
    Dec 2004
    Location
    Illinois
    Age
    34
    Posts
    150

    Re: STS High Idle

    i have the same code for isc out of range and my idle is high 1200 or so and just this morning i heard a weird clicking noise when i turned the key on, before i cranked the engine to start it, it did not make the noise when i got to work and turned the car off though, bad isc????

  9. #8
    Spyder's Avatar
    Spyder is offline Cadillac Owners Master
    Automobile(s): None now...1972 Challenger=my pride and joy.
    Join Date
    May 2004
    Location
    Sonoma Co, CA
    Age
    31
    Posts
    5,685

    Re: STS High Idle

    That's what mine was...clicking came first though, idle was fine for a couple of weeks worth of clicking, then it went to around 1200...replaced ISC, high idle and click went away...it still revs to about two grand at startup, which I havn't had time to fix yet, but I need to do some research. Try testing the ISC, outlined somewhere on this forum, or just replace it to fix the clicking andhigh idle.

  10. #9
    cart69's Avatar
    cart69 is offline Cadillac Owners Fanatic
    Automobile(s): 96STS engine only!! only thing left from my 96 after divorce
    Join Date
    Dec 2004
    Location
    Illinois
    Age
    34
    Posts
    150

    Re: STS High Idle

    mine has had the high idle ever since i got the car, but i just noticed the clicking the other day, so its probably been bad the whole time. when i took the intake off my carto clean the egr passages and stuff i put a small bit of high tack gasket sealer over all the o-rings type gaskets so i am pretty sure there inst a vaccum leak in the intake, so i guess napa i will go probably in the next few weeks since i dont have the 100 for it now, what were you saying about the 2000 rpm start mine just starts a little high for a second then goes to its normal idle spot,.

  11. #10
    Spyder's Avatar
    Spyder is offline Cadillac Owners Master
    Automobile(s): None now...1972 Challenger=my pride and joy.
    Join Date
    May 2004
    Location
    Sonoma Co, CA
    Age
    31
    Posts
    5,685

    Re: STS High Idle

    yea...about half of the time mine will rev up to rwo grand at start, then even out like it should...I havn't figured out what this is yet...I need to get busy with the search on this forum, cause I've read about it before it happened to mine, I just don't remember where it was.

  12. #11
    CAJUN-Z is offline Cadillac Owners Member
    Join Date
    Jun 2004
    Location
    New Orleans, LA.
    Age
    59
    Posts
    16

    Re: STS High Idle

    ...sounds like a vacuum leak....
    you can get a spray bottle of water and spray around manifold and such and you'll get a rough idle if the engines sucks some water...
    works for me...

  13. #12
    blunted is offline Cadillac Owners Enthusiast
    Automobile(s): '94 Eldorado , '12 CTS Coupe
    Join Date
    May 2004
    Location
    NYC
    Posts
    582

    Re: STS High Idle

    Interesting.. my car is also running a little hot and when I shut it I've heard clicking. I idle at about 800-900 rpm, I'm not getting any codes though.. bad ISC?

  14. #13
    Spyder's Avatar
    Spyder is offline Cadillac Owners Master
    Automobile(s): None now...1972 Challenger=my pride and joy.
    Join Date
    May 2004
    Location
    Sonoma Co, CA
    Age
    31
    Posts
    5,685

    Re: STS High Idle

    I never had any codes show up...once in a while I'd get an "rpm out of range -cruise" code, but that was once a week, and would clear itself right away.

  15. #14
    klt
    klt is offline Cadillac Owners Member
    Join Date
    Jul 2004
    Posts
    42

    Re: STS High Idle

    Hope I'm not adding confusion. If the high idle starts AFTER the engine warms up but not while engine is cold it might be the oxygen sensor. The computer doesn't check the output of the oxygen sensor until the temperature sensor indicates the engine has reached operating temperature. I had a bad oxygen sensor and a bad ISC motor. I got the idle speed back to normal by adjusting the ISC motor plunger but I still get the ISC clicking at engine turn on/off. I tried all of those adjustment procedures. Figured something else was bad that I never found what. Finally decided I could live with a few clicking noises.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting