2003 STS Idle/MAF/Coolant temp issues/Driving itself
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 21
Northstar Engines and System Technical Discussion Discussion, 2003 STS Idle/MAF/Coolant temp issues/Driving itself in Cadillac Engine Technical Discussion; Hey everyone, I have searched the forums and I cannot find the answer to my questions on my 2003 sts. ...
  1. #1
    kjanks is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Apr 2008
    Posts
    79

    2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Hey everyone,

    I have searched the forums and I cannot find the answer to my questions on my 2003 sts. I have about 86k on it now. I am experiencing high idles at times at about 1500 rpm, when it is around 600 rpm it feels like a bad misfire or stumble like it almost wants to stall out. Before I replaced the MAF it did stall out about 3 times. We used a scan tool and found that the MAF was faulty. Then a few weeks later after replacing the MAF. The light came on again saying "lean bank 1". What does that mean? So we cleared the code to see if it would come back on again. Now 2 weeks later the engine light is on again and I haven't had a chance to check it yet but I am assuming it is laying out the same code. It seems to really be sucking up gas and the coolant temp varies at times (which I understand it should) but this is a bit drastic and then it cools itself down after a bit coming to the 12:00 mark. Further, when it is running and you are driving the car at low rpms, it wants to drive itself and has a hard time slowing down and is shifting hard back into first. I have roached my breaks because of that issue alone. It lacks power on acceleration. It finally kicks its but into gear after 3k rpm and then it sorta shows its face. And it has a hard time decelling if you just want to slow down without the breaks! Does anyone have any idea what it could be?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,579

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Search for throttlebody and IAC cleaning procedures. Normal annual maintenance for a Northstar. Start in the Discussions, Engines forum: Cadillac Tech Tips.

    Your car has its own built-in code scan system. The chances that the MAF itself was faulty are very slim - air leak or electrical connection, yes - MAF, no.

    If you get a "lean bank 1" code, that's usually either an intake ducting leak or vacuum leak. Check the ducting band clamps at the intake duct resonator, MAF (both sides) and throttlebody.

  4. #3
    crezzy2k1 is offline Cadillac Owners Member
    Automobile(s): 2003 Seville STS 120K 2007 Ford Escape Hybrid 135K
    Join Date
    Nov 2011
    Location
    De Pere, WI
    Age
    29
    Posts
    50

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    As Sub said you have a vacuum leak somewhere, you may want to check the intake plenum, see subs profile page for where it is located.

  5. #4
    kjanks is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Apr 2008
    Posts
    79
    There definately sounds like a vacuum leak. I will check these things out on Sunday. What is the intake plenum? Thanks

    Do the manifold intakes crack easily on these? or does it just mean i need to replace the gasket.

    Where are the ducting band clamps at the intake duct reasonator? Thanks.

    Quote Originally Posted by submariner409 View Post
    Search for throttlebody and IAC cleaning procedures. Normal annual maintenance for a Northstar. Start in the Discussions, Engines forum: Cadillac Tech Tips.

    Your car has its own built-in code scan system. The chances that the MAF itself was faulty are very slim - air leak or electrical connection, yes - MAF, no.

    If you get a "lean bank 1" code, that's usually either an intake ducting leak or vacuum leak. Check the ducting band clamps at the intake duct resonator, MAF (both sides) and throttlebody.

  6. #5
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,350

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    The "plenum" is the rubber coupler between the TB and the intake manifold.

    The manifolds do not normally crack unless someone over torqued them.

    The "ducting bands" are all the intake ducting clamps anywhere on the intake ducts.

  7. #6
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,579

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Quote Originally Posted by kjanks View Post
    Do the manifold intakes crack easily on these? or does it just mean i need to replace the gasket.
    You really need to see what we're talking about...........click on my username, open the profile. 2 albums, 6 pages in the left column - many pictures and diagrams of the intake system. There is no intake manifold gasket as such. It uses 8 formed silicone seal rings and a metal/rubber connector (plenum) between the manifold and throttlebody.

  8. #7
    kjanks is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Apr 2008
    Posts
    79

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Ok i took a look at your photos. It makes sense now. I will have to see where the vaccuum leak is coming from. I will look at these photos again when I work on it on sunday. hope i can find what is wrong with it. when we replaced the maf. the original one was completely black on the screen. we cleaned it with maf cleaner but the code came on again and we ended up replacing it for a 100 bucks. i will get back to you guys and let you know what i find.

    Thanks

  9. #8
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,579

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    For this 2003 limited edition Seville - may I suggest that you look into subscribing the car to www.alldatadiy.com ?? It's the online GM service manual plus a LOT more - so much, in fact, that you have to get used to surfing around in the site pages and links.

    ........... and if you replaced the MAF and that darn intake duct resonator is not perfectly seated and clamped in its hole you WILL get MAF and/or mixture codes. If you intend to keep and maintain this car, do the "butt plug" modification shown in my albums. it will make your engine checks a LOT easier........... and FYI, the transmission is a dry sump unit: there should be NO fluid on the stick with the engine off.

  10. #9
    kjanks is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Apr 2008
    Posts
    79

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Hey guys! So i replaced the 8 gaskets in the manifold, replaced the plenum (it was cracked) and replaced the throttle body gasket. But I have a question I guess I'm just unsure... When I nail it getting on the freeway Wot it doesn't really kick itself in the pants until about 3500 rpm and then has that power. Is that normal for these engines??

  11. #10
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,579

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Depends on how hard you "nail it" and where the gas pedal is when and where a downshift occurs...........but for all intents and purposes your 2003 should pull very strongly from idle to 130 mph - with your foot through the firewall. These are small engines (in the cubic inch department) and they rely on rpm for power. If you don't force a merging speed downshift the engine struggles to move that 4,000# car.

    Just for grins and kicks, get to a (deserted ???) stretch of highway, turn OFF TC and A/C, anything else you can, and slow to <10 mph. Put the stick in 1 and leave it there. All clear ??? Nail it. The car will accelerate to 1-2 redline (6300 rpm) and shift. If you have the space and time, let it get to the 2-3 redline shift and flip your foot off the gas. Let the engine and transmission pull the car down to <20 mph. Still all clear ??? Do it again.

    Any complaints now ? The engine should pull strongly all the way through this maneuver (WOT). The transmission is smart - it will not let you break anything. Did you do my "butt plug" mod ? Is that intake ducting perfectly clamped ?

    In your car, in the underhood fuse box - if you pull fuse #24 the DRL's - and nothing else - are deactivated.

  12. #11
    kjanks is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Apr 2008
    Posts
    79

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Oh thanks!! I hate the DRL's! However, I have another question... How can I access the car's own scan tool through my navigation system? What is the code to imput. I have the check engine light on again and don't know why the car is running fine. So all I can think at this point is a possible O2 sensor. I did do the butt plug. Much cleaner look and works like a charm! Let me know or point me in the direction of the scan tool code if possible! Also, how can I watch dvd's through the nav system? It won't let me do it...

  13. #12
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,579

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    You don't use the HU or the NAV system to pull Diagnostic Trouble Codes. You use the 3 control buttons to the right of the DIC. Study the procedure for your year group and OBD-II protocol up ^^^ in the sticky thread "How to pull codes". (There is necessary info in ALL the stickys)

    You might want to snoop through Discussions, Item Specific, Audio, Video, Security.

    EDIT: For the cars with the 3 DIC control buttons - after you get familiar with their operation and function when in diagnostic mode you can use them to step through each module, one at a time, instead of an auto-scroll sequence. When presented with the query "All Codes" answer "No". Then you'll see the modules appear in alphabetical order - in this case "ABS ?" Answer "Yes". ABS codes (if any) display. You then get "Clear Codes ?" Answer either "Yes" or "No" as you see fit. The display will then go to the next module and you do the same pattern again. The ^/v rocker allows you to scroll forwards or backwards. To exit the diagnostic at any time, turn the key off.

  14. #13
    andyoww's Avatar
    andyoww is offline Cadillac Owners Member
    Automobile(s): 1997 Deville http://img.ly/7HqE
    Join Date
    Aug 2011
    Location
    Muscoda, WI
    Age
    40
    Posts
    30
    Quote Originally Posted by Submariner409
    Depends on how hard you "nail it" and where the gas pedal is when and where a downshift occurs...........but for all intents and purposes your 2003 should pull very strongly from idle to 130 mph - with your foot through the firewall. These are small engines (in the cubic inch department) and they rely on rpm for power. If you don't force a merging speed downshift the engine struggles to move that 4,000# car.

    Just for grins and kicks, get to a (deserted ???) stretch of highway, turn OFF TC and A/C, anything else you can, and slow to <10 mph. Put the stick in 1 and leave it there. All clear ??? Nail it. The car will accelerate to 1-2 redline (6300 rpm) and shift. If you have the space and time, let it get to the 2-3 redline shift and flip your foot off the gas. Let the engine and transmission pull the car down to <20 mph. Still all clear ??? Do it again.

    Any complaints now ? The engine should pull strongly all the way through this maneuver (WOT). The transmission is smart - it will not let you break anything.
    Holy crap that sounds like fun.

    Do the 97 Devilles do that same thing?
    Totally gonna try that after I replace my headgaskets.

  15. #14
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,579

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    Quote Originally Posted by andyoww View Post
    Holy crap that sounds like fun.
    Do the 97 Devilles do that same thing?
    The 4T80E controls should be the same but I think your VIN Y redline is a little lower than the VIN 9. Try it - you won't break anything.

    You might go up in the black bar ^^^ and read the whole Cadillac Technical Archive - a somewhat different method of WOT (among other really necessary Northstar operation and maintenance info.............)

  16. #15
    kjanks is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Apr 2008
    Posts
    79

    Re: 2003 STS Idle/MAF/Coolant temp issues/Driving itself

    I turned the light off. It was a check engine light for a catalytic converter. The light has not come back in a few days. I'd have to to assume it is burning all of the carbon out of the system b/c of how horrible it was running until I fixed it.

    Thanks

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting