Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 3 of 3

Thread: P0304 Misfire cylinder 4

  1. #1
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2015 Mazda3 S GT Hatchback 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    51
    Posts
    2,817

    P0304 Misfire cylinder 4

    My '08 DTS has gotten a new problem for about a week or so now. I have been driving the Seville so it hasn't been too bad for me. Anyway I am getting a P0304 code and the engine runs rough for about 5 minutes or so. And then it seems to smooth out after that. I am also getting Service Stabilitrak and Traction Control on the dash. Can the misfire code cause the stability system to be affected? I am guessing yes. Doesn't the stability system and the traction control cut out cylinders to keep the car steady? I will be calling the dealer tomorrow as I still have the Powertrain Warranty to fall back on.

    I am posting this here as well as the DTS and Seville forums. Need as many eyes as possible to see this post, thanks

    Don


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    56,808

    Re: P0304 Misfire cylinder 4

    This is the trouble with triple posts - I just gave an opinion up in Seville.

  4. #3
    Dadillac's Avatar
    Dadillac is offline Cadillac Owners Connoisseur
    Automobile(s): 2015 Mazda3 S GT Hatchback 2013 Kia Optima SXL
    Join Date
    Nov 2004
    Location
    Woodbridge NJ
    Age
    51
    Posts
    2,817

    Re: P0304 Misfire cylinder 4

    The triple posts was for many members to see it as not all members search all forums. Anyhow you were on the mark Sub. It was a cracked plug. Replaced it and all is well. Thanks

    Don


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum