99 STS stumbles, P1370a, P1371a, P1377a codes; At wits end with this car
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Northstar Engines and System Technical Discussion Discussion, 99 STS stumbles, P1370a, P1371a, P1377a codes; At wits end with this car in Cadillac Engine Technical Discussion; I have a 99 sts that I just re-installed the engine into after head gasket repair. The engine was stumbling/missing ...
  1. #1
    foxjohnc is offline Cadillac Owners Member
    Automobile(s): '97 DeVille present, '99 DeVille past
    Join Date
    Feb 2007
    Location
    Huntsville, AL
    Age
    27
    Posts
    43

    99 STS stumbles, P1370a, P1371a, P1377a codes; At wits end with this car

    I have a 99 sts that I just re-installed the engine into after head gasket repair. The engine was stumbling/missing prior to repair and I assumed it was due to the leaky gaskets. Well, the car is back together and running but the problem persists and I am at wits end trying to diagnose the cause of the issues. All wiring is in place, the body to engine and head to coil pack grounds are in place and clean. I have cleaned the ICM connections, swapped ICM and coil pack assy with known good one, re-routed plug wires to avoid interference, cleaned the cam sensor connection, swapped cam sensor with known good one, cleaned PCM connections, cleaned main harness to body and harness to fuse panel connections, and cleaned intake manifold harness connection.

    I am experiencing the following problems:

    Miss/stumble at idle and low rpms, seems to smooth out somewhat at higher rpms
    Service engine light illuminated with following codes current:

    P1370a IC 4x reference circuit too many pulses
    P1371a IC 4x reference circuit too few pulses
    P1377a IC cam pulse to 4x reference pulse

    If you clear the codes when the engine is idling, they come back immediately. However if you have the engine revved up to 2500+ rpm and clear the codes, they will not reappear until you let off the throttle. According to my scanner (mac mentor) the miss is not appearing on any cylinder in particular as it is not showing missfire data on any cylinder. It seems more like it is a multiple random missfire or fuel system fault but the codes do not reflect it.

    I have not checked the crankshaft sensors yet but I will this evening. They are connected and the wiring is clean however I may have them connected incorrectly. I have the grey plug connected to top sensor and black plug connected to bottom sensor. I believe this is correct but cannot find anything to say for certain. I was under the impression however, that if they were incorrectly connected the engine would not run at all.

    If anyone has any insight as to the source of my issues, please do not hesitate to chime in.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    foxjohnc is offline Cadillac Owners Member
    Automobile(s): '97 DeVille present, '99 DeVille past
    Join Date
    Feb 2007
    Location
    Huntsville, AL
    Age
    27
    Posts
    43

    Re: 99 STS stumbles, P1370a, P1371a, P1377a codes; At wits end with this car

    So I had some time last night to take a look at the car again.

    I thoroughly cleaned every electrical connection in the engine bay and then wire brushed every one of the grounds on the engine harness and going to ignition module. I also added a ground wire from the ICM to the rear head near ps pump and another one from ICM to strut tower.

    It is running smoother and p1370, p1371, p1377 codes are gone. It pulls hard from about 2,000 rpm to redline but still stumbles below 2k.

    However now I am showing a P0340 code (CMP sensor circuit malfunction). Just as before, if you keep it revved up to 2,500 rpm and clear the code it will not show back up. But as soon as you let off the gas, it starts sputtering and the code reappears.

    I have swapped cam sensors with a known good one and it made no difference. The correct sprocket is on the exhaust cam and the pin is in place. I have traced wiring from cam sensor to ICM and both wires have no resistance from plug to plug and are not shorted to hot or ground. I have also traced wires from ICM to PCM and all wires do not have any resistance nor are they shorted to hot or ground. Pins on computer and ignition module are clean and straight also.

    I am at a loss as to what the problem may be. At this point I am leaning towards an issue with the pcm but without the proper test equipment I will likely be throwing good money at a bad situation.

  4. #3
    tinylevi's Avatar
    tinylevi is offline Cadillac Owners Member
    Automobile(s): 1963 GMC w/ Northstar
    Join Date
    Apr 2011
    Location
    Northern Michigan
    Posts
    2

    Re: 99 STS stumbles, P1370a, P1371a, P1377a codes; At wits end with this car

    This might be a stupid question but have you checked the timing or for vacuum leaks? Check for vacuum leaks first. Then check the timing.

    Also if you can get a scope on it to look at the signals the sensors are sending it will tell you if the PCM is getting a good signal from the sensors or not. This would help pinpoint if it's the PCM (which I doubt). The waveform should go up first, then down. If it goes down first the wiring is backwards.

    I'll poke around for a waveform chart for a 99 STS and check back in if I find one.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting