O2 sensor trouble codes after engine installed
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
Northstar Engines and System Technical Discussion Discussion, O2 sensor trouble codes after engine installed in Cadillac Engine Technical Discussion; I took the Devile out for the first time after I studded the block.....and now I am fixing little things....like ...
  1. #1
    malibuandryan is offline Cadillac Owners Fanatic
    Automobile(s): 97 Deville Concours and 2000 STS both with NP studs
    Join Date
    Jan 2007
    Location
    INDIANA
    Posts
    110

    O2 sensor trouble codes after engine installed

    I took the Devile out for the first time after I studded the block.....and now I am fixing little things....like the O2 sensors..This is what I got

    p0135-O2 HEATER CKT MALFUNCTION
    p0141-O2 HEATER CKT MALFUNCTION
    p0147-O2 HEATER CKT MALFUNCTION
    p0174-System to lean bank 2
    p0300-random misfire

    along with rough idle.....other than that, it runs ok

    Ryan
    1997 Deville Concours

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Ranger's Avatar
    Ranger is online now Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    70,493

    Re: O2 sensor trouble codes after engine installed

    p0174-System to lean bank 2
    Check for a vacuum leak. Maybe the PCV valve grommet.
    p0135-O2 HEATER CKT MALFUNCTION
    p0141-O2 HEATER CKT MALFUNCTION
    p0147-O2 HEATER CKT MALFUNCTION
    See Ewill's posts here.
    http://www.cadillacforums.com/forums...g-me-nuts.html

  4. #3
    malibuandryan is offline Cadillac Owners Fanatic
    Automobile(s): 97 Deville Concours and 2000 STS both with NP studs
    Join Date
    Jan 2007
    Location
    INDIANA
    Posts
    110

    Update

    Found out what was wrong! I forgot to hook up a ground wire below left side of engine...and also had 2 coil packs that were not functioning right....Now it doesn't skip a beat at all Runs like a champ......Ryan

  5. #4
    malibuandryan is offline Cadillac Owners Fanatic
    Automobile(s): 97 Deville Concours and 2000 STS both with NP studs
    Join Date
    Jan 2007
    Location
    INDIANA
    Posts
    110

    Re: O2 sensor trouble codes after engine installed

    Ok...maybe I didn't find out what was wrong.....The same codes are now back on....Car runs fine.......I originally added more wire to the ground wire so I could ground it out on something solid..The original connector snapped off when I took out the engine...Codes did go away, but shortly appeared again.

    All codes read current even when engine is running/not running.....When I go to ground this wire, it will spark a little...so I do have power.

    Do you think adding this extra foot of wire is too long?? It is grounding out properly....Maybe this wiring is too sensitive??

    Originally this wire connected to the rear transmission to engine bracket (Just below EGR valve)..............also are these 3 codes referring to all O2 sensors except the front exhaust manifold?

    I have checked all fuses that are related to O2 sensors....I have even looked at wiring diagrams.......These sensors are driving me crazy

    Below is a grounds diagram for the O2 sensors


  6. #5
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    41,621

    Re: O2 sensor trouble codes after engine installed

    I have no idea if this is relevant, but the O2 sensor troubleshooting trees tell you not to bend, kink, or alter the sensor wiring as it is part of the sensor circuit "tuning". There's also something about one of the wires being a ground "clean air reference", so maybe if your new wire changes the resistance of the O2 sensor ground circuit, it might throw a code.

    Mind you, this is a SWAG (Scientific Wild Ass Guess)

  7. #6
    ponyboyt is offline Cadillac Owners Enthusiast
    Automobile(s): 97, 97, RIP 98, 99 STS with Jakes studs
    Join Date
    Apr 2009
    Location
    Ontario, Canada
    Age
    37
    Posts
    691

    Re: O2 sensor trouble codes after engine installed

    i've been having pretty much the same problem. My car has 4 O2 sensors and 3 of them keep throwing heater performance codes. It runs fine some times, ok some times, and like ass some times. Very intermittent.... always the same codes. Something ive been half-ass working on for a while now. Ill take a look at my wiring based on your diagram later today

    Edit: keep on top of it. I've been at mine for a long time. Every time i change something it seems like its fixed and then "Ok...maybe I didn't find out what was wrong.....The same codes are now back on".

  8. #7
    malibuandryan is offline Cadillac Owners Fanatic
    Automobile(s): 97 Deville Concours and 2000 STS both with NP studs
    Join Date
    Jan 2007
    Location
    INDIANA
    Posts
    110

    Re: O2 sensor trouble codes after engine installed

    I do have a standard obd2 scanner that is capable of Live Data....What should the volts be on these sensors........Ondemand5 (which is where I get all my stuff) tells something about 1 and 0 volts?? ....I don't understand.....My scanner is telling me that I'm getting some kind of volt measure on these sensors....some of them are .54 V......anyways if I'm getting some kinda of reading then they must be working, or barely working...Right???


    Ondeamand5 does mention something about altering wire.........I guess I'll try some extremely short wire........it's a pain in the ass trying to reach down there and tie together wires.

    As of right now I'm getting 23 MPG on highway and now have a too lean code that has showed up.

    Sometimes I get 1 current code. Others days I get 3 current codes all at once......What is happening

    If I can't figure this out soon......I guess I'll have to take it to the local dealer and have them figure this out...........Thanks again Ryan

  9. #8
    ponyboyt is offline Cadillac Owners Enthusiast
    Automobile(s): 97, 97, RIP 98, 99 STS with Jakes studs
    Join Date
    Apr 2009
    Location
    Ontario, Canada
    Age
    37
    Posts
    691

    Re: O2 sensor trouble codes after engine installed

    so according to that picture, the O2 sensor heaters share a common ground.

    FSM says P0135 is:

    DTC P0135 HO2S Heater Performance Bank 1 Sensor 1

    your post says:

    p0135-O2 HEATER CKT MALFUNCTION

    I also have P0135. Add P0155. Another similarity between mine and yours is that i have 3 out of 4 sensors malfunctioning. I would think that if it was a ground issue, all 4 sensors would be misbehaving. I have never had a code for my post-cat sensor. (if i remember right... it might be the pre-cat). I think my third code was P0147 but it hasnt popped up in weeks so not 100% sure. Its probably in a post in here somewhere... Basicly same situation. Mine hasnt run perfect since the engine was replaced. Something not put together right i think. Im getting voltage at the sensor according to spec in the FSM. I have a sway bar link to replace today, will see whats left over and ill look for a good meter to do more tests.

    P0135

    This diagnostic test is used to determine if the heating element in the rear oxygen sensor is operating properly. An oxygen sensor acts as a battery because it creates its own voltage once it reaches operating temperature. This voltage is produced when the oxygen content in the exhaust stream is different than that in the atmosphere. The heating element is energized through CKT 139 when the ignition is ON and allows the oxygen sensor to reach operating temperature quickly. This in turn allows the PCM to enter Closed Loop fuel control quicker. When cold the voltage that the PCM measures on the HO2S HI and LOW inputs is called bias voltage. If it takes too long for the HO2S to very above or below the bias voltage within a specific time since key ON DTC P0135 will set.

    Failure Condition
    The PCM monitors the rear heated oxygen sensor input to determine when its voltage becomes either 151 millivolt less than or 151 millivolt greater than average rear heated oxygen sensor bias voltage for 0.1 second. If it takes too long, DTC P0135 will set.

    Im not sure if i can paste the diagnostics procedure or not, ive seen people do it but is it allowed?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting