96 STS High Idle After Highway Run
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 24
Northstar Engines and System Technical Discussion Discussion, 96 STS High Idle After Highway Run in Cadillac Engine Technical Discussion; Our 96 STS runs normally around town but after 1/2 hr highway idles at 1200 to 1500. Seems like it ...
  1. #1
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

    96 STS High Idle After Highway Run

    Our 96 STS runs normally around town but after 1/2 hr highway idles at 1200 to 1500. Seems like it will come down after shutting off and starting again. Is the computer confused? Not sure at all what is wrong.

    Replaced the plugs 6 months ago due to misfire, helped but not completely. Seems the mileage dropped before I changed the plugs. Used to get 20+ average, now getting 17. Driving it hard with WOT will bring on Service Engine light which then goes out after some normal driving. There were a few codes one being misfire. Car has 150K miles and does not overheat.

    Thanks for any tips!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Skiller.'s Avatar
    Skiller. is offline Cadillac Owners Connoisseur
    Automobile(s): NONE
    Join Date
    Sep 2009
    Location
    Buffalo, NY
    Age
    25
    Posts
    2,027

    Re: 96 STS High Idle After Highway Run

    Did you replace the plugs with AC-Delco? What about the wires; how many miles are on them? I'm not positive about your high idle, but could have something to do with the throttle position sensor.

  4. #3
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

    Re: 96 STS High Idle After Highway Run

    I used #41-950 a few had the center electrode visibly off center. I was in a hurry and used them anyway.

  5. #4
    Skiller.'s Avatar
    Skiller. is offline Cadillac Owners Connoisseur
    Automobile(s): NONE
    Join Date
    Sep 2009
    Location
    Buffalo, NY
    Age
    25
    Posts
    2,027

    Re: 96 STS High Idle After Highway Run

    You've got the right plugs in there then..and the wires?

  6. #5
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

    Re: 96 STS High Idle After Highway Run

    Didn't do the wires and probably should.

  7. #6
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,376

    Re: 96 STS High Idle After Highway Run

    Seems the mileage dropped before I changed the plugs. Used to get 20+ average, now getting 17.
    Have you checked the FPR for a leak?

  8. #7
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,600

    Re: 96 STS High Idle After Highway Run

    I'll bet the TB is in need of a cleaning also.

    High idle after road trips and a SES after WOT - any vacuum leaks anywhere?

  9. #8
    eyekandyboats.inc's Avatar
    eyekandyboats.inc is offline Cadillac Owners Connoisseur
    Automobile(s): 2001 DTS(140K), 2000 ETC(284K), 1990 allante( 80K)
    Join Date
    Mar 2007
    Location
    Tottenham, Ontario,Canada
    Posts
    1,914

    Re: 96 STS High Idle After Highway Run

    carbon on the intake is my bet.. take off you air intake tube and check it out. i bet there is carbon in there causing it.

  10. #9
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

    Re: 96 STS High Idle After Highway Run

    Thanks everyone, I'm going to have to do some reading here since I don't have a lot of experience with the motor. Is there a thread on the best procedure for checking for vacuum leaks?

    Edit: I'll check FPR according to this thread: http://www.cadillacforums.com/forums...-pressure.html
    It does not have hot start issues.

    Edit: I'll try the TB cleaner to check for vacuum leaks: http://www.cadillacforums.com/forums...cuum-leak.html

    Edit: Cleaning the TB, 1998 close enough? http://www.cadillacforums.com/forums...ttle-body.html

  11. #10
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

    Re: 96 STS High Idle After Highway Run

    Pulled the codes:
    PC0139-HISTORY P0139 - Heated Oxygen Sensor (HO2S) Slow Response Bank 1 Sensor 2
    PC1406-HISTORY P1406 - EGR Valve Pintle Position Circuit
    IR1771-HISTORY Could not find specific code Integrated Radio????

    On clearning codes it will go for 2 or 3 days without new codes, then the service
    engine light comes on, with new codes. Then days later it often goes off again.
    I believe that the electrical system is flaky, but am certainly open to suggestions.

    Some time after I changed the plugs I put Techron in it and about an hour later
    the service engine light came on. After the next fill up it went off.

  12. #11
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

  13. #12
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,376

    Re: 96 STS High Idle After Highway Run

    I'd start with the EGR valve.

  14. #13
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

    Re: 96 STS High Idle After Highway Run

    I will do that, thanks again!

    It seems like it runs better after clearing the codes, is it in some sort of fall back mode when a history code is set but the service engine light is off?

  15. #14
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,376

    Re: 96 STS High Idle After Highway Run

    Not sure, but I don't think so.

  16. #15
    Pete1996 is offline Cadillac Owners Fanatic
    Automobile(s): 1996 STS
    Join Date
    Aug 2009
    Posts
    104

    Re: 96 STS High Idle After Highway Run

    Strange, it was doing the high idle thing consistently, now that I've cleared the codes it is not doing it since I've made two highway runs today. And as I said it seems to run better.

    I hope to get to cleaning the EGR ASAP.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting