Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 6 of 6

Thread: Service Suspension System

  1. #1
    Pedy1 is offline Cadillac Owners Member
    Automobile(s): sts
    Join Date
    May 2009
    Posts
    3

    Service Suspension System

    I have a 1999 Seville STS. For some reason the messages "Service Suspension System" and "Speed limited to 90" comes up on the dashboard. What could be the problem? How can i reset this or fix it?


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is online now If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS - 67,500 miles, 2014 Explorer XLT FWD
    Join Date
    Feb 2006
    Location
    MD Eastern Shore, Kent Island
    Age
    77
    Posts
    56,797

    Re: Service Suspension System

    Read the entire sticky thread at the top of the main Northstar page titled "How to pull codes". Practice and read any codes from your car's built-in code reader/scanner/ memory system. Write them all down, noting whether each is Current or History. Return to the sticky and open the link with "obd2" in the URL. Click on the blue links in the Master Index box to get the meanings of any P,B,C, or U codes found. Post them all here.

    You have some suspension control/mechanical problem which defaults the active suspension system to a set condition and speed limiter: safety default. You need to find out what has gone wrong in order to correct it. Simply clearing codes will not remove the fault.

  4. #3
    kjasey is offline Cadillac Owners Member
    Automobile(s): 1999 STS
    Join Date
    Dec 2009
    Location
    Ontario
    Age
    45
    Posts
    86

    Re: Service Suspension System

    I just replaced a sensor rod on the right side control arm. I replaced rod because the bolt snapped. I snapped her back into place but the "check suspension system" still appears on start up. Do i have this rod in right? Heres the pic.

  5. #4
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    69
    Posts
    82,262

    Re: Service Suspension System

    Looks right to me.

  6. #5
    tateos's Avatar
    tateos is offline Cadillac Owners Connoisseur
    Automobile(s): 1997 ETC (GAVE TO STEPSON 2011), 2000 DTS (RIP)
    Join Date
    Jul 2007
    Location
    FOUNTAIN HILLS, AZ
    Age
    60
    Posts
    1,702

    Re: Service Suspension System

    Do what Sub said - the code will tell you where to look

  7. #6
    kjasey is offline Cadillac Owners Member
    Automobile(s): 1999 STS
    Join Date
    Dec 2009
    Location
    Ontario
    Age
    45
    Posts
    86

    Re: Service Suspension System

    I have RSS 1761 and abs 1283 Code. Meaning right sensor malfunction. I have two rods at my disposal and still have stability system check come on. Maybe the arm swing the other way with the rod. I may have to see how the left side is hooked up. Is there any easy way to check the connections which seems to lead up into the engine somewhere?
    Last edited by kjasey; 03-09-10 at 10:16 PM.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum