01 Deville issues, no codes, no check engine light
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 10 of 10
Northstar Engines and System Technical Discussion Discussion, 01 Deville issues, no codes, no check engine light in Cadillac Engine Technical Discussion; Ok Guys I'm new to this thread and I need help. I purchased an 01 Deville with 120K on it ...
  1. #1
    cbgibson is offline Cadillac Owners Member
    Automobile(s): 2001 Deville
    Join Date
    Jul 2009
    Location
    Locust, NC
    Age
    33
    Posts
    4

    01 Deville issues, no codes, no check engine light

    Ok Guys I'm new to this thread and I need help. I purchased an 01 Deville with 120K on it about a month ago. Recently and intermittently, I'm having trouble with it.

    Occassionally, when I crank it up, it dies. I have to gently press the accelerator pedal when I crank it to keep it running. When it does do this and I am driving it, if I take my foot off the gas and the RPMs drop, it also cuts off. I have to keep my foot on the pedal to at least maintain 800 rpms to keep it from cutting off.

    Also, once or twice, it's like the throttle is sticking...every time it does it, it sticks at 2250rpm. but that is also intermittent and only happens when the other issue is not happening. Also, when this is happening, and I put it in park after driving it, the vehicle is idling at about 1500rpm.

    Like I said, the problems are intermittent, no check engine light is coming on, and no other problems are happening.

    PLEASE HELP! I have a family of 5 (with one more on the way) and I don't want to end up stranded somewhere!

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,475

    Re: 01 Deville issues, no codes, no check engine light

    Simple fix. Clean the TB.

  4. #3
    00 Deville's Avatar
    00 Deville is offline Cadillac Owners Connoisseur
    Automobile(s): 02 Deville / 04 Deville
    Join Date
    Mar 2004
    Location
    Wilmington, NC
    Age
    49
    Posts
    2,583

    Re: 01 Deville issues, no codes, no check engine light

    There's a step by step on how to clean the TB over in the Tech tips section of the board.

  5. #4
    cbgibson is offline Cadillac Owners Member
    Automobile(s): 2001 Deville
    Join Date
    Jul 2009
    Location
    Locust, NC
    Age
    33
    Posts
    4

    Re: 01 Deville issues, no codes, no check engine light

    Thanks guys...I took it apart and cleaned it, using the separate cleaners, and no more stalling! BUT, I'm now having a problem with it idling high while driving...its like it wants to stay at around 1300 RPMs when I try to stop, but once again, intermittent....any ideas?

  6. #5
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,676

    Re: 01 Deville issues, no codes, no check engine light

    Idle Speed Control (ISC) learn or restricted passages - TB cleaner and fuzzy pipe cleaners. Maybe Throttle Position Sensor (TPS) connector or fault.

    Use the sticky up top of the main Deville page or in the Tech thread, study up on your car's installed system, and pull your own trouble codes.

  7. #6
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,475

    Re: 01 Deville issues, no codes, no check engine light

    You might try pulling the IAC valve on the side of the TB and clean out the passages like Sub suggested, but if they where clogged I'd expect the opposite affect. Did you clean the TB bore REAL good as well as the throttle plate INCLUDING the perimeter? Remember, the plate perimeter seats in the bore closing off all air and then only the IAC valve controls the air flow. If the throttle plate does not seat, air gets past and the idle goes up.

  8. #7
    cbgibson is offline Cadillac Owners Member
    Automobile(s): 2001 Deville
    Join Date
    Jul 2009
    Location
    Locust, NC
    Age
    33
    Posts
    4

    Re: 01 Deville issues, no codes, no check engine light

    I cleaned the passage for the IAC as well as the throttle body.....both looked like new when finished. I also cleaned the IAC with the electronic cleaner.

  9. #8
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,475

    Re: 01 Deville issues, no codes, no check engine light

    Did that help?

  10. #9
    cbgibson is offline Cadillac Owners Member
    Automobile(s): 2001 Deville
    Join Date
    Jul 2009
    Location
    Locust, NC
    Age
    33
    Posts
    4

    Re: 01 Deville issues, no codes, no check engine light

    Ok...today it was hard starting, but no high idle....this thing is driving me crazy! I pulled the intake boot back off and double checked the butterfly flap, all is spotless...i pulled the iac back out, cleaned it again, and also recleaned the passage for it as well.......all this was done yesterday....and im still having problems.....

  11. #10
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,475

    Re: 01 Deville issues, no codes, no check engine light

    Have you checked for a ripped plenum? That's the rubber coupler between the TB and the intake. It usually rips on the bottom where it can't be see. Spray some Brakleen around it and listen for an RPM increase.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting