Any thoughts? Code P1350 p1375
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 15 of 15
Northstar Engines and System Technical Discussion Discussion, Any thoughts? Code P1350 p1375 in Cadillac Engine Technical Discussion; Hi all, I'm stumped yet again on my "hardly driven anymore" '99 Seville STS. I have the p1350 & p1375 ...
  1. #1
    RickyHenry's Avatar
    RickyHenry is offline Cadillac Owners Fanatic
    Automobile(s): 2004 Deville; 1999 Seville
    Join Date
    Mar 2008
    Posts
    134

    Question Any thoughts? Code P1350 p1375

    Hi all, I'm stumped yet again on my "hardly driven anymore" '99 Seville STS.

    I have the p1350 & p1375 codes coming back. This last 2 weeks I put in yet another set of brand new crankshaft position sensors, I created a brand new harness to house my new wires running from the ignition control module down to the ckp's and yet I still get this issues.

    For one, when I put in the new sensors, I rewired and purchased all new connectors to the 2 sensors and a new connector to the ICM. The car ran fine for about 5 miles, then after warming up, BAM!!!, p1350 & p1375 come back to haunt me, my SES light comes on and I lose all tachometer functionality.

    I turn the car off and let it sit for a few minutes, restart it and it's fine. I then run another 5 minutes and lose it again.

    I've done everything short of replacing the ICM and replacing the PCM. The book recommends replacing the PCM as a last resort but I don't think I would take it that far.

    Do you think I should just break down and buy a new ICM? Is there another issue I'm overlooking that may be causing this problem when the car warms up?

    Thanks for any input.





  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    RickyHenry's Avatar
    RickyHenry is offline Cadillac Owners Fanatic
    Automobile(s): 2004 Deville; 1999 Seville
    Join Date
    Mar 2008
    Posts
    134

    Re: Any thoughs? Code P1350 p1375

    It's supposed to read "Any Thoughts? Code P1350 P1375". My bad.

  4. #3
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,049

    Re: Any thoughts? Code P1350 p1375

    Title fixed. As for ICM or PCM, I'm not sure.

  5. #4
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,253

    Re: Any thoughts? Code P1350 p1375

    P1350 and 1375 have nothing to do with CKP's. Remove your entire coil pack and ICM, disassemble it, and clean every contact and connector. Use the diagrams posted endlessly in here and Northstar performance concerning proper plug to coil wiring hookup.

    Something's fishy with the ICM trigger signals, and you may just luck out with a good electrical cleanup.

    5 mile warmup is a tad long for the Loop transition, but that may figure in this, too.

    If, and only IF, you have an ICM hiccup, you won't be the first..................

  6. #5
    deepthinker22 is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Dec 2007
    Posts
    24

    Re: Any thoughts? Code P1350 p1375

    Sounds like a similar issue to what I'm currently experiencing. I just had the ICM changed. I will let you know if it takes care of the issue. BTW: I went like 3 or 4 driving trips of 5 mi before I had the code thrown at me, and yes some of those the engine was warm for quite some time. I'm also going to take a meter and check some of my ground connections.

  7. #6
    RickyHenry's Avatar
    RickyHenry is offline Cadillac Owners Fanatic
    Automobile(s): 2004 Deville; 1999 Seville
    Join Date
    Mar 2008
    Posts
    134

    Re: Any thoughts? Code P1350 p1375

    Are you sure it isn't related to crankshaft position sensors? I will try to cean out the ICM connectors tomorrow and if that doesn't help I will go buy a new ICM, a local junkyard will sell to me for $150 as opposed to the $800 the dealer is asking for it..

  8. #7
    deepthinker22 is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Dec 2007
    Posts
    24

    Re: Any thoughts? Code P1350 p1375

    ok, yeah, the guy "replaced" my ICM, funny it looks old. Also it didn't fix my issues. To top it off, I sent him the vehicle to fix the VSS. The car comes back with a "refurbished (pos cough cough) MAF", this ignition issue, 150mi added to the odometer, and oh yeah...Every other time I start I have to pull out the code scanner. BTW I also have a B1099 whatever that is.

  9. #8
    RickyHenry's Avatar
    RickyHenry is offline Cadillac Owners Fanatic
    Automobile(s): 2004 Deville; 1999 Seville
    Join Date
    Mar 2008
    Posts
    134

    Re: Any thoughts? Code P1350 p1375

    ok, i replaced my spark plug wires and put in a new ignition control module. To top it off, I replaced all coils on top of the ICM. Ran the car for about 5 miles, no problem, ran the car a 2nd time, while at idle, the RPMs would run up and down between 600 - 2000 rpms (at idle) until eventually leveling out. Ran the car again and got a hard start (cranking for about 20-30 seconds before a start would occur. Everytime I run the car and get it warmed up, if I turn it off, the i will have the hard start. If I let the car sit for 6+ hours it starts right up.

    Now, the killer. Started the car this morning, about the 6th time since I changed the plugs, ICM & coils.... codes (p1350 & p1375) came back and my Tach is back at reading no RPMs.

    Any luck over on your end?

  10. #9
    RickyHenry's Avatar
    RickyHenry is offline Cadillac Owners Fanatic
    Automobile(s): 2004 Deville; 1999 Seville
    Join Date
    Mar 2008
    Posts
    134

    Re: Any thoughts? Code P1350 p1375

    Just an update on this. After replacing both ckp sensors again, replacing the harness that connects the ckp's to the icm and replacing the connector ends at the ckp behind the exhaust manifold, i still had the problem.

    Now, the only thing I didn't replace was the 6prong connector end that connects the harness to the ICM. I believe the factory service manual calls it connector C3 but not positive.

    That little tiny connector costs $180 at the dealership!!!!!!!!!!!!!!

    Ok, so I pulled that thing apart and adjusted the metal connectors to where I think they were not connecting to the male connectors. Problem goes away when I plug in. After several days of operating and at heated temp, the connector fails adn I get the codes again. Here's the kicker, I unplug the connector, plug it back in, start the car and the problem is gone. It's like the connector is bending or something and losing it's seat when the car warms up.

    The good news is, I know what the problem is. The bad news is, I have messed with that connector too much and refuse to pay $180 for a little $2 part from the dealer, so I guess I will just live with plugging it in and out if it goes again.


  11. #10
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,253

    Re: Any thoughts? Code P1350 p1375

    One of those pins/wires in the connector body has a bad crimp. Junkyard and butt connector time - with a crimp tool from a GOOD stereo installer shop.

  12. #11
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,049

    Re: Any thoughts? Code P1350 p1375

    I recently installed a DTC floor console in my DHS. The T/C activate/deactivate button was a simple two wire connector. I wired it, but could not get the thing to work for the life of me. I could take it apart and touch the two wires together and get the T/C to toggle on and off. Tested the button and it was good. I fought this for weeks. Finally I pulled the two wires from the connector and one had the pin bent so there was no contact. I rebent it and put it back together and WALA it worked like it was supposed to. It was as simple as that, but hind sight is always 20/20.

  13. #12
    SupRNatural's Avatar
    SupRNatural is offline Cadillac Owners Fanatic
    Automobile(s): 1996 Montana Blue Eldorado,1982 Eldorado Biarritz Diesel
    Join Date
    Nov 2007
    Location
    USA
    Age
    49
    Posts
    148

    Re: Any thoughts? Code P1350 p1375

    I'm getting these codes also. I replaced ICM,New wires, still every once in a while I get the same 2 codes. I found a male plug wire severed on the lower right hand plug for the ICM. I purchased a water proof butt conector. I'm still trying to figure out wtf is going on. I also get a 1599 every once in a while. This car is like my ex wife, never satisfied..



    Quote Originally Posted by RickyHenry View Post
    ok, i replaced my spark plug wires and put in a new ignition control module. To top it off, I replaced all coils on top of the ICM. Ran the car for about 5 miles, no problem, ran the car a 2nd time, while at idle, the RPMs would run up and down between 600 - 2000 rpms (at idle) until eventually leveling out. Ran the car again and got a hard start (cranking for about 20-30 seconds before a start would occur. Everytime I run the car and get it warmed up, if I turn it off, the i will have the hard start. If I let the car sit for 6+ hours it starts right up.

    Now, the killer. Started the car this morning, about the 6th time since I changed the plugs, ICM & coils.... codes (p1350 & p1375) came back and my Tach is back at reading no RPMs.

    Any luck over on your end?

  14. #13
    coaster is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac 98sls
    Join Date
    May 2007
    Location
    San Francisco, California, Uni
    Posts
    204

    Re: Any thoughts? Code P1350 p1375

    I had the same code for awhile and i read your thread and sub409 suggest to clean the pins on the icm on both side and I remember that I change one of the coils and I unpluged both plugs on the icm.and change the coil and plug the pins back up and and three months later i get the 1350 and 1375 code reset and cleared code I would drive a few miles and the code would pop back up car would hicup and code came back so I left the car key in the on position and unplug the pin and cleaned the pins and plug them back up but made sure I put them on tight I mean push them on real good and so far no code before I would go just a few miles and code would pop up no more code try it may work

  15. #14
    frustratedcadiowner is offline Cadillac Owners Member
    Automobile(s): 96 seville
    Join Date
    Jun 2010
    Posts
    3

    Re: Any thoughts? Code P1350 p1375

    I'm having same issue. If your still out there please help!! Did you solve the problem?

  16. #15
    RoofMan is offline Cadillac Owners Member
    Join Date
    Nov 2004
    Posts
    31

    Re: Any thoughts? Code P1350 p1375

    My daughter has a 1996 De Ville that is doing the same thing with the codes and rpm readings, It also will have hard start and sometimes stall and restart hard with no rpm readings. Can someone tell us where we should start on the trouble shooting?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting