Strange Readings 1994 Deville Concourse N*
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
Northstar Engines and System Technical Discussion Discussion, Strange Readings 1994 Deville Concourse N* in Cadillac Engine Technical Discussion; Ok, in a few posts I had some questions and so far no one has responded, but I think I ...
  1. #1
    furluvcats is offline Cadillac Owners Member
    Join Date
    Jun 2004
    Posts
    11

    Strange Readings 1994 Deville Concourse N*

    Ok, in a few posts I had some questions and so far no one has responded, but I think I have pinpointed my problem. It all started with the low oil pressure. BUT now I do beleive it is in the cluster. Now I don't know what the cluster is, but from other posts here and what my mechanic initially told me, that is the diagnosis I have made. Here are some of the symptoms.

    1. The low oil pressure stop engine light will not turn off, even though there is pressure and the sendign unit has been replaced.

    2. I have not had a reading on the outside air temp in over a year. I thought it was the sensor next to the radiator, however when I put the car in diagnostic mode and then leave diagnostic, I get an accurate outside temp reading for about 3 seconds before it goes back to dash dash.

    3. For the last 2 days now, the fuel level has been fluctuating by about 4 gallons while i am driving. If it is parked, it still fluctuates some, but not as much.

    Now I really dont know anything about a cluster. Am I on the right track and is it something I can replace or repair myself? I really would appreciate any help anyone can give.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Roswell256's Avatar
    Roswell256 is offline Cadillac Owners Fanatic
    Join Date
    Feb 2004
    Location
    Quantico, VA
    Age
    33
    Posts
    285

    Re: Strange Readings 1994 Deville Concourse N*

    I think I've seen similer in my 94 Concours as every know and then I'll see the fuel jump from 18 - F - 16 - 17 - F - blah blah balh... it seems to do this for a while. Even when not moving or moving over a smooth surface. then it will quit and thats that. At first I thought it might be a the loose sending unit in the tank but its intermitant and from what you describe I'm now wondering if its my cluster burning out.

    I think by cluster they are refering to the instrument cluster. The pannel of LED's that makes up the display.

  4. #3
    furluvcats is offline Cadillac Owners Member
    Join Date
    Jun 2004
    Posts
    11
    Thread Starter

    Re: Strange Readings 1994 Deville Concourse N*

    Still no resolution on the low oil pressure. But The temp was just a quick fix with the outside temp sensor.

  5. #4
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,759

    Re: Strange Readings 1994 Deville Concourse N*

    Do you have low oil pressure or just low oil pressure indication? If it is indication, have you checked the sensor or is it the sending unit? Anyway I think it is mounted on the oil filter adapter. If it is actually low pressure I recall Bbob talking about a proceedure to cure a stuck check valve. If I recall it correctly, you overfill the crankcase by 8 qts. (yes, 15 qts in the sump) then rev to 2500 RPM.
    http://caddyinfo.ipbhost.com/index.p...w+oil+pressure
    http://caddyinfo.ipbhost.com/index.p...w+oil+pressure

  6. #5
    furluvcats is offline Cadillac Owners Member
    Join Date
    Jun 2004
    Posts
    11
    Thread Starter

    Re: Strange Readings 1994 Deville Concourse N*

    It is a low pressure reading. The pressure is fine. I have been told that the sensor is part of the sending unit which was already replaced. I have an appointment at 7:30 tommorow morning to have the wiring looked at. If it is not the wiring I have been told it is the cluster. I HOPE it is the wiring as I don't want to put even more money into it. If the sensor is not part of the sending unit for a 94 caddy deville concorse, then I would like to have that changed before the wiring. Does anyone know for sure?

    Brian

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting