help 2000 deville servive engine light
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
Northstar Engines and System Technical Discussion Discussion, help 2000 deville servive engine light in Cadillac Engine Technical Discussion; hello i have a cadillac 2000 deville no dts no dhs my service engine soon like came on i called ...
  1. #1
    gmello76 is offline Cadillac Owners Member
    Join Date
    Apr 2004
    Posts
    11

    help 2000 deville servive engine light

    hello i have a cadillac 2000 deville no dts no dhs my service engine soon like came on i called onstar and they do a dianogstic check they told me it came up power train and to take it to the dealer in 7 days. some times my rpm run a lil higher and some times it stalls out at the stop light with the engine being warm or cold and i get hesistaion and yesterday it sumbled a lilttle bit it onlyhave 57k miles on it i was wondering could it be a sensor something i hope its not the transgoing out because that would be a shame. if there was a problem withe the trans would it come up on the dash because it does have that option according to the owners manuel and some times i have to give it gas before it starts whats up with the northstars acting like this i head this engine is good for 200k miles


    any help is greatly loved thank you

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Playdrv4me's Avatar
    Playdrv4me is offline Cadillac Owners 10000+ Posts
    Automobile(s): 1992 STS / 2005 MB G500 / 2008 Mini Cooper Clubman S
    Join Date
    Nov 2003
    Location
    TPA / STL / ICT / SAT
    Posts
    11,684

    Re: help 2000 deville servive engine light

    I dont know about the RPM running higher, but I would certainly not worry about the transmission at this point. It sounds like the Crankshaft Position Sensors due to your stalling. This is a very common problem on 2000 and newer Northstars and your dealer should know how to fix it easily.

  4. #3
    OlManRivah's Avatar
    OlManRivah is offline Cadillac Owners Fanatic
    Join Date
    Mar 2004
    Location
    Central Virginia
    Posts
    112

    Re: help 2000 deville servive engine light

    Do a Forum search using "Stalling". This should give you some ideas. Also, the specific OBD-II codes should help. Better than "Power Train".

  5. #4
    gmello76 is offline Cadillac Owners Member
    Join Date
    Apr 2004
    Posts
    11

    Re: help 2000 deville servive engine light

    Quote Originally Posted by Playdrv4me
    I dont know about the RPM running higher, but I would certainly not worry about the transmission at this point. It sounds like the Crankshaft Position Sensors due to your stalling. This is a very common problem on 2000 and newer Northstars and your dealer should know how to fix it easily.

    thanks buddy for the advice i never knew this car had so many sensors do you know how much they usaully charge for a job like that at the dealer ship Crankshaft Position Sensors job i hope not that much the deville is still a great car

  6. #5
    Smokey's Avatar
    Smokey is offline Cadillac Owners Fanatic
    Join Date
    Dec 2003
    Location
    Lufkin, TX
    Posts
    119

    Smile Re: help 2000 deville servive engine light

    I too had the same problem on my 2000 Deville. I removed the air intake tube off the throttle body. I cleaned the throttle body and everything in there I could get to. No more sticky from idle gas pedal and no more hard to start/stalling. Been running fine every since. My Deville has 94,000 on it.

  7. #6
    gmello76 is offline Cadillac Owners Member
    Join Date
    Apr 2004
    Posts
    11

    Re: help 2000 deville servive engine light

    Quote Originally Posted by Smokey
    I too had the same problem on my 2000 Deville. I removed the air intake tube off the throttle body. I cleaned the throttle body and everything in there I could get to. No more sticky from idle gas pedal and no more hard to start/stalling. Been running fine every since. My Deville has 94,000 on it.


    thanks for reply

    where is the throttle located is it that black box with the big hose coming from two screws what did you use to clean it chemical spray did yo lac stall at the light did you get a rotten egg smell to around the lac holla back

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting