84 cadillac seville chargeing problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
HT4100 4.1, 4.5, 4.9 Discussion, 84 cadillac seville chargeing problem in Cadillac Engine Technical Discussion; I have a 84 seville that wont stay running. The problem is it will run for about 15 to 20 ...
  1. #1
    jeff jag is offline Cadillac Owners Member
    Join Date
    May 2005
    Posts
    3

    84 cadillac seville chargeing problem

    I have a 84 seville that wont stay running. The problem is it will run for about 15 to 20 minutes during a drive, and then begin to loose electrical power to the whole car. It acts as if it is the alternator going out but it isnt that or the battery. They both have been changed and tested. I checked the voltage while the car was in park and running. I got 12.04 volts, and the 20 minutes later I got 11.85. It is as if the alternator is not working, and yet it tests good. Is it a relay in the charging system or what?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    SolidGoldsteen's Avatar
    SolidGoldsteen is offline Cadillac Owners Fanatic
    Join Date
    Apr 2005
    Posts
    132

    Re: 84 cadillac seville chargeing problem

    Yeah it sounds like the alt isn't working, Like you said. Maybe the regulator is bad, or you have a bad connection to the rest of the charging system... I know that's not much help but no one else is saying anything.

  4. #3
    Catillac's Avatar
    Catillac is offline Cadillac Owners Member
    Automobile(s): (2) 1982 Seville Elegantes& (1) 1980 Eldorado Biarritz
    Join Date
    May 2005
    Location
    Pemberton, British Columbia
    Posts
    36

    Re: 84 cadillac seville chargeing problem

    I don't think your alternator is charging properly...your battery should be reading 14 to 14.5 volts. That's a proper charge to your battery. Maybe it's your voltage regulator?
    With a low charge to your battery, the more power your car uses, the battery can't keep up with the demand on it with such a low charge. :drinker

  5. #4
    jeff jag is offline Cadillac Owners Member
    Join Date
    May 2005
    Posts
    3

    Re: 84 cadillac seville chargeing problem

    Thank you for your help. I'm currently runing a test on the alt. It is stedily droping in voltage output. So I'll try another alternator.

  6. #5
    RickeyGary's Avatar
    RickeyGary is offline Cadillac Owners Member
    Join Date
    Nov 2004
    Location
    Chicago
    Age
    55
    Posts
    14

    Talking Re: 84 cadillac seville chargeing problem

    Your problem is not the alternator or regulator, the air pollution pump has gone bad and is drawing down the alternator. I had this same problem with a 85 Eldorado HT 4100.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting