1987 DeVille Conv. 4.1 ICM still sets idle to high
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
HT4100 4.1, 4.5, 4.9 Discussion, 1987 DeVille Conv. 4.1 ICM still sets idle to high in Cadillac Engine Technical Discussion; Dear Cadillac Enthusiasts Yes I know, another one with the same problem. I own a 1987 Cadillac DeVille Convertible with ...
  1. #1
    fretless's Avatar
    fretless is offline Cadillac Owners Member
    Automobile(s): 1987 Cadillac DeVille Convertible
    Join Date
    May 2013
    Location
    Zurich Switzerland
    Age
    53
    Posts
    10

    1987 DeVille Conv. 4.1 ICM still sets idle to high

    Dear Cadillac Enthusiasts

    Yes I know, another one with the same problem.
    I own a 1987 Cadillac DeVille Convertible with a 4.1 L Engine
    My problem started some when last year when the car was coasting, the car started to accelerate by itself and the service soon telltale came on. Diagnostic showed E 26 so I replaced the TPS but without success the symptom remained and the idle was still far too high (around 2500 rpm)
    In meantime I have tried the following steps.

    Replaced ECM and BCM with remanufactured ones.
    Replaced MAT sensor and coolant sensor.
    Triple checked for any vacuum leaks.
    Setup everything like minimum idle, TPS set to 0.5 volts and everything else according to the advises in the GM Service Manual.
    Still the same problem. As soon as the ISC is connected it starts to set the high idle again.
    But as soon I move the idle arm to accelerate the engine the ISC retracts to its minimum position and sets the idle to its normal RPM after the idle arm has snapped back to the idle position. Sometimes it keeps the proper settings for one or two cycles but then the problem starts all over again.
    In meantime I have disconnected the ISC after a good idle position was set which gives a hardcoded E27 (but this is just a workaround.) A connected ISC gives a E26 which is expected when the ISC sets the idler arm to far during engine start.
    Everything else is working properly.
    I really hope somebody could help me to find a solution. Nothing I have found on the web does really help for my problem

    Please let me know if my description is not clear enough as English is no my first Language

    Many thanks for your reply I really appreciate

    Kind regards from Switzerland

    Dan

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,341


    ICM - Ignition Control Module

    You're talking about the ISC - Idle Speed Control (motor).

    Did you adjust the ISC plunger when you were making your adjustments?

    Have you tried the idle learn procedure?

  4. #3
    fretless's Avatar
    fretless is offline Cadillac Owners Member
    Automobile(s): 1987 Cadillac DeVille Convertible
    Join Date
    May 2013
    Location
    Zurich Switzerland
    Age
    53
    Posts
    10

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    You're right I meant the ISC ... ;-)
    Yes I have adjusted the plunger by connecting power/ground to C and D pin to extract and retract while counting the volts as described in the Service manual, thought the settings has not changed and remained the same how it was before the problems started. Which means within expected range I don't remember by my own. I have tried both ways for relearning: first the battery disconnect reconnect after a minute or so and secondly the ignition on, enter diagnose mode, ignition off, wait ... and so on thing also. It first starts with a relative high but not excessive idle. But after approx. 20 seconds the idle starts to increases more and more and I fear that its not so good for the engine even when its warmed up (about 185 DgF) If I moved the idler arm manually so that it looses the contact to the ISC plunger then ISC retracts and sets the idle correct. I let the car Idling for about 15 minutes but no way. I have spent many many hours to setup and control everything again and again.

  5. #4
    Ranger's Avatar
    Ranger is online now Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    73,300

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    This might be better off in the engine (HT4100 4.1, 4.5, 4.9) forum. I'll move it for you.

  6. #5
    cadillac_al is online now Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    53
    Posts
    2,733

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    The ISC could just be worn out or defective. If you raised the idle to make it run without the ISC then it may be too high and confusing it. Min idle is supposed to be 450 rpm and the ISC gapped at .060", (from memory) and that's it. I always did the idle relearn from the owners manual but with a clean throttle body you don't really have to. You know the ISC is working right when you hear the engine speed up a little when you press the brakes.

  7. #6
    fretless's Avatar
    fretless is offline Cadillac Owners Member
    Automobile(s): 1987 Cadillac DeVille Convertible
    Join Date
    May 2013
    Location
    Zurich Switzerland
    Age
    53
    Posts
    10

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    Thanks for your answer. Yes the minimum idle was set to ~450 RPM with alternator of (grounding green plug)
    As I wrote previously the ISC retracts and then sets everything correctly after it looses the contact from the idler arm for a couple seconds.
    Even when I'm turning the steering wheel or switching on the AC the RPM increases slightly. The same behavior as it was before the problem has occurred the first time. But only for a while or until the engine is switched of. Replacing the ISC would be the last thing I could do before I replace the whole engine ;-) I fear that it could be a problem with the cabling between the ECM and another part. It's quite time consuming to test each wire. You mentioned "the ISC gapped at .060", (from memory) " the ISC does not retract down after the engine was switched off could this may be the problem? Or did you retract the ISC manually before you could count the 060 gap? Thank you all again.

  8. #7
    cadillac_al is online now Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    53
    Posts
    2,733

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    The way I do it is to give it some throttle with my right hand. This retracts the ISC plunger, and I unplug it with my left hand. Then release throttle, turn car off and adjust gap to .060 and plug it back in. It sounds like your ISC may be working since you hear the engine speed up when using AC etc.

  9. #8
    fretless's Avatar
    fretless is offline Cadillac Owners Member
    Automobile(s): 1987 Cadillac DeVille Convertible
    Join Date
    May 2013
    Location
    Zurich Switzerland
    Age
    53
    Posts
    10

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    Yes ISC retracts as soon as the plunger looses the contact to the throttle arm this is how I have set the current idle as a work around.
    I just unplug the ISC when the idle was set correct so that its not accelerating by itself next time I start the engine. In meantime I have ordered a new ISC anyway just to make sure that its not the ISC which usually fails not very often. I also don't believe it's the new ECM and even not that it was the old one. So I will take the opportunity to check the plugs and cable stuff of everything between the input sources and the ECM. What kind of data is needed by the ISC for its correct settings? One of them I assume are the values from the TPS position. Or does the ISC also needs some values from another sensor i.e. MAT or coolant sensor, speed sensor, or whatever? Thought the AC, Steering wheel etc. gives a proper signal as it was before. The schema in the service manual confuses me a bit. ;-)

    Sometimes I wish my old 79 Seville back...

  10. #9
    cadillac_al is online now Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    53
    Posts
    2,733

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    Are you setting a gap between the ISC and the throttle arm or are you using the unplugged ISC to set your idle? With the ISC fully retracted, you just set the gap and that should be all there is to it. Plug it back in and it should take over controlling the idle.

  11. #10
    fretless's Avatar
    fretless is offline Cadillac Owners Member
    Automobile(s): 1987 Cadillac DeVille Convertible
    Join Date
    May 2013
    Location
    Zurich Switzerland
    Age
    53
    Posts
    10

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    Yes I have set the gap after the ISC plunger was fully retracted, TPS is set at 0.5 Volts, minimum Idler Screw set to approx. 480 RPM (varies a little)
    Yesterday I found out that after the ISC plunger has extracted to set a higher RPM when it was expected i.e. the the steering wheel was turned around or AC switched on etc. the ISC plunger does not retract to set the correct RPM afterwards. The RPM increases then more and more. But as soon as I increase the throttle by hand or pedal, the ISC plunger retracts again and sets the correct idle RPM (~650) still code E26 even I have cleared them several times. ECM test passes the E 7.2 test also. This thing makes me crazy... If the car would not be a convertible in a very good condition I would bring them to the graveyard. I hate gremlins in electronic devices even they have four wheels on it.

  12. #11
    BigCadMan_1's Avatar
    BigCadMan_1 is offline Cadillac Owners Fanatic
    Automobile(s): 93 Eldorado 4.9
    Join Date
    Sep 2011
    Location
    Canada
    Posts
    401

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    I hate to chime in on this one but I had the same problem with a 1986 Sedan deVille. I work part time as a mechanic & the owner of the garage was a trouble shooter for Alfa-Romeo & a master mechanic for Audi. We have anywhere from 20 to 30 cars a week come through the shop & trust me when I say we see it all. Why am I telling you all this, because I had all the resources one would need to fix this problem & we could not. I replaced every part with-in the ignition to fuel diagnostic tree, replaced both ECM, BCM's & still zip! Paid GM 2 hours to trouble shoot & nothing but $200 bucks poorer! I traced every path from the fuse panels & was getting ready to do the same for all the relays but gave up! In the end we thought it might be a short somewhere in the wiring harness but like I said I gave up after 3 months and countless dollars. I disconnected the ISC (or else the car was unsafe to drive) sold the car as is & paid some back tax's.

    I have no advice for you, just this story. Take it as you like.

    BTW I'm sure carnut will chime in & give a good idea where to look next, I hope for all the best for you.

  13. #12
    fretless's Avatar
    fretless is offline Cadillac Owners Member
    Automobile(s): 1987 Cadillac DeVille Convertible
    Join Date
    May 2013
    Location
    Zurich Switzerland
    Age
    53
    Posts
    10

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    Thanks BigCadMan_1 for sharing your experience with me. This sounds no good. :-( Sometimes I'm suspecting the Plug but it's quite hard to find one here in Switzerland and ordering one from the US costs about 70 Bucks with shipping which seems to me like a robbery. This is a standard plug like those from coolant and and mat sensors for which they also charge fare too much. I assume certain people in Ebay and elsewhere wants to became rich by selling plugs ;-)

    But another question about the storage of the "learned" values. Are they store also within the PROM of the ECM like the rest (error codes, miles VIN etc.) ? If so then the PROM could also be a place to have a closer look. Then even when I have replaced the ECM the PROM remained the same. Does may somebody know a shop which can setup a PROM and also important will send it to Switzerland. ;-)
    I have found one in the net but this shop did not even replied to my email I have sent. And I assume that my English is not that bad that nobody understands it. ;-) However thanks all you guys for your assistance and your advices I really appreciate.

  14. #13
    BigCadMan_1's Avatar
    BigCadMan_1 is offline Cadillac Owners Fanatic
    Automobile(s): 93 Eldorado 4.9
    Join Date
    Sep 2011
    Location
    Canada
    Posts
    401

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    I do not think the PROM holds any old error codes, I could be wrong. I did BTW try a ECM from a 86 parts car without swapping out the PROM's and still had the same result. But keep in mind it was very difficult to do a long road test with the engine racing out of control the way it was!

  15. #14
    fretless's Avatar
    fretless is offline Cadillac Owners Member
    Automobile(s): 1987 Cadillac DeVille Convertible
    Join Date
    May 2013
    Location
    Zurich Switzerland
    Age
    53
    Posts
    10

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    Thanks for this. I'll look further or for some dynamite ...

  16. #15
    cadillac_al is online now Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    53
    Posts
    2,733

    Re: 1987 DeVille Conv. 4.1 ICM still sets idle to high

    Quote Originally Posted by BigCadMan_1 View Post
    I hate to chime in on this one but I had the same problem with a 1986 Sedan deVille. I work part time as a mechanic & the owner of the garage was a trouble shooter for Alfa-Romeo & a master mechanic for Audi. We have anywhere from 20 to 30 cars a week come through the shop & trust me when I say we see it all. Why am I telling you all this, because I had all the resources one would need to fix this problem & we could not. I replaced every part with-in the ignition to fuel diagnostic tree, replaced both ECM, BCM's & still zip! Paid GM 2 hours to trouble shoot & nothing but $200 bucks poorer! I traced every path from the fuse panels & was getting ready to do the same for all the relays but gave up! In the end we thought it might be a short somewhere in the wiring harness but like I said I gave up after 3 months and countless dollars. I disconnected the ISC (or else the car was unsafe to drive) sold the car as is & paid some back tax's.

    I have no advice for you, just this story. Take it as you like.

    BTW I'm sure carnut will chime in & give a good idea where to look next, I hope for all the best for you.
    Hey bigcadman, did you try a new ISC on this adventure? And a new one still didn't fix it? That would be depressing.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting