4.9 Horrible Idle
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 30
HT4100 4.1, 4.5, 4.9 Discussion, 4.9 Horrible Idle in Cadillac Engine Technical Discussion; ...
  1. #1
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    4.9 Horrible Idle

    I've recently fixed the timing (it was at 6º) and the ISC Motor on my car, and it now idles worse than it did before. It has idled badly every since the engine was replaced, but now it just keeps revving the engine up and down from about 600-1200 rpms. I am fairly sure it has a vacuum leak somewhere now, because it dies when attempting to set minimum air, but why would it get worse after making these adjustments? I've noticed the PCV valve is fairly loose, is this normal or could it be where my vacuum leak is? Also one of the fuel injectors can rotate back and forth, is this also a possible location for a vacuum leak? Also the driver's side of the defroster vent doesn't blow out hot air like the passenger's. I think the vents are controlled by vacuum, but I don't hear any hissing from anywhere in the dash though. The alternator's pulley is also wobbly and its fan is missing a fin and may be hitting the housing, but I wouldn't think that this would be enough to create this much of a problem. The alternator may also be bad, since I have a battery/charging problem, could this possibly create the problem? Sorry for such a long post.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,013

    Re: 4.9 Horrible Idle

    Quote Originally Posted by Enigmaticwraith View Post
    I've recently fixed the timing (it was at 6º) and the ISC Motor on my car, and it now idles worse than it did before. It has idled badly every since the engine was replaced, but now it just keeps revving the engine up and down from about 600-1200 rpms.
    The question is key: What was it before? The base timing is 10º...

    As far as the vacuum leak issues, did you test all possible areas with the carb cleaner to pinpoint? I wouldn't use it under the dash, of course, but if you're looking for a quick and easy way to pinpoint a vacuum leak, that's it...

    The alternator may cause a surging in the fact that it may not be supplying a constant and consistent voltage for the electronics to read true. If you know your having an issue with it, change it out.

    With the items you know are bad; replace them to rule them out. With the plethora of problems, start with the known's first.

  4. #3
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Quote Originally Posted by the recluse View Post
    The question is key: What was it before? The base timing is 10º...
    What was the idle, or what was the timing before? The idle used to be fairly stable around 650-700 rpm. The timing was at 6 deg, and I adjusted it to 12, which has made the engine run way better than previously... except at idle.

  5. #4
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    52
    Posts
    2,710

    Re: 4.9 Horrible Idle

    Is the SES light on? Are there any codes? Have you checked out all the threads here about ISC adjustment and cleaning EGR tubes? Probably should clean the throttle body too. The owners manual has a idle relearn procedure you could try if everything else is in spec. When I'm stumped I always check the vacuum and look for leaks.

  6. #5
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Quote Originally Posted by cadillac_al View Post
    Is the SES light on? Are there any codes? Have you checked out all the threads here about ISC adjustment and cleaning EGR tubes? Probably should clean the throttle body too. The owners manual has a idle relearn procedure you could try if everything else is in spec. When I'm stumped I always check the vacuum and look for leaks.
    The SES light isn't on, and there aren't any codes. I already cleaned the EGR tubes and throttle body, and I also already adjusted the ISC screw/plunger and performed the idle learn procedure.

  7. #6
    cctgene's Avatar
    cctgene is offline Cadillac Owners Fanatic
    Automobile(s): 1992 Seville
    Join Date
    Sep 2004
    Location
    Marietta, Georgia
    Age
    70
    Posts
    319

    Re: 4.9 Horrible Idle

    Just a thought, when you set the timing did you put a jumper on the A & B terminals of the ALDL connector?

  8. #7
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Quote Originally Posted by cctgene View Post
    Just a thought, when you set the timing did you put a jumper on the A & B terminals of the ALDL connector?
    Yeah.

  9. #8
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,013

    Re: 4.9 Horrible Idle

    If you've run a vacuum test and found none, then you'll probably have to move onto the MAP sensor, clogged CAT, fuel pressure sensor, and start testing the injectors; as these are notoriously nasty buggers for epic failing...

    To test the injectors, remove the air cleaner assembly form the engine bay and disconnect the harnesses that connect the ECM to the injectors. From here you can ohm out all the injectors to see if any are failing.

  10. #9
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,013

    Re: 4.9 Horrible Idle

    Double Post

  11. #10
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    I won't have time to test anything until Friday, however the car has 243000 some miles on it, and the fuel injectors have never been replaced to my knowledge, so I will defiantly check them.

  12. #11
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,013

    Re: 4.9 Horrible Idle

    Quote Originally Posted by Enigmaticwraith View Post
    ...the car has 243000 some miles on it...
    WOW.

    I wish I knew this awhile ago, the laundry list of possibilities can be lloooonnnngg.

  13. #12
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Quote Originally Posted by the recluse View Post
    WOW.

    I wish I knew this awhile ago, the laundry list of possibilities can be lloooonnnngg.
    The engine only has about 32000, and the transmission about 140000.

  14. #13
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    52
    Posts
    2,710

    Re: 4.9 Horrible Idle

    I'm stumped. Tell us more about the battery/charging problem. Low voltage can cause lots of problems in any vehicle. Is the alternator putting out 13.5 volts?

  15. #14
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    The alternator puts out 13 volts. It keeps the battery charged, but if I let the car sit for more than two or three days it won't start. So, I'm thinking it might have a shorted diode. Also it seems that the pulley and fan are warped. I already tried pulling all the fuses one by one to look for a source of the drain, but it wasn't any of them. I haven't went through the other fuse bank under the hood yet, though.

  16. #15
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,013

    Re: 4.9 Horrible Idle

    you could just have a dead battery...

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting