4.9 Horrible Idle - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 30 of 30
HT4100 4.1, 4.5, 4.9 Discussion, 4.9 Horrible Idle in Cadillac Engine Technical Discussion; The battery's been replaced twice in the last year......
  1. #16
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    The battery's been replaced twice in the last year...

  2. #17
    daniel58 is offline Cadillac Owners Fanatic
    Automobile(s): 58 Coupe Deville, 77 Coupe deville, 90 Deville
    Join Date
    Sep 2009
    Posts
    183

    Re: 4.9 Horrible Idle

    Having problems with the ISC on my 90/4.5 myself. I removed the ISC completely and jacked the min idle screw up to get 700rpm and the car runs fine with no codes. Worth a try to narrow down the causes.

  3. #18
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,016

    Re: 4.9 Horrible Idle

    Quote Originally Posted by Enigmaticwraith View Post
    The battery's been replaced twice in the last year...
    You've got a direct short to ground.

  4. #19
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    I finally had some time to test some stuff. I couldn't find a vacuum leak anywhere, and I checked the resistance of the injectors. 5 of them read 16.4 ohms, one reads 16.7 and the other two 16.9.

  5. #20
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,016

    Re: 4.9 Horrible Idle

    Quote Originally Posted by Enigmaticwraith View Post
    I finally had some time to test some stuff. I couldn't find a vacuum leak anywhere, and I checked the resistance of the injectors. 5 of them read 16.4 ohms, one reads 16.7 and the other two 16.9.
    Well that's good, they're within spec.

    Another possible issue here is a faulty FPS or fuel pressure sensor. Can be had for about $15 and changed out in about an hour. This little number can cause idle issues, hard starts, and stalls. Most of all, it doesn't trip codes. You can test if you have a fuel pressure gauge, but for the cost of one of those you can just replace it....

  6. #21
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Quote Originally Posted by the recluse View Post
    Well that's good, they're within spec.

    Another possible issue here is a faulty FPS or fuel pressure sensor. Can be had for about $15 and changed out in about an hour. This little number can cause idle issues, hard starts, and stalls. Most of all, it doesn't trip codes. You can test if you have a fuel pressure gauge, but for the cost of one of those you can just replace it....
    Thanks, I'll replace it as soon as I have time to work on it again. Another thing I noticed today: when I opened the throttle blades to double check the EGR tubes, I noticed that I could smell gas coming up out of the open throttle blades. Also, when I tested to check if the PCV valve was working, I noticed that the engine ran much more smoothly for the short time that the valve wasn't in place.

  7. #22
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    On the way to class today some new problems came up. The SES light came on and I have codes E98 (High RPM P/N to D/R in ISC Range) and E27 (Open Throttle Switch Signal). Also, when the car gets past around 15 mph, it now starts accelerating by itself until it hits about 30-35 mph.

  8. #23
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,016

    Re: 4.9 Horrible Idle

    Run/re-run ISC procedure now that the TPS is back in place.

  9. #24
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Quote Originally Posted by the recluse View Post
    Run/re-run ISC procedure now that the TPS is back in place.
    I already have. It's been adjusted to the correct gap, and it's had the idle learn performed.

  10. #25
    drewsdeville is offline Cadillac Owners Master
    Automobile(s): 2011 Crown Vic LX
    Join Date
    Oct 2004
    Location
    Oak Creek, WI
    Posts
    5,320

    Re: 4.9 Horrible Idle

    You are making progress. The new codes tell you that either the TPS is either grossly misadjusted or it's faulty (probably the reason it was disconnected). If correctly adjusting the TPS fails, replace it.

  11. #26
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Well, the codes can be crossed off the list of symptoms, along with the other stuff in that post. It seems the ISC connector came loose.

  12. #27
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,016

    Re: 4.9 Horrible Idle

    Quote Originally Posted by Enigmaticwraith View Post
    Well, the codes can be crossed off the list of symptoms, along with the other stuff in that post. It seems the ISC connector came loose.
    Fire your mechanic, he forgets to plug s**t back in...

  13. #28
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    Quote Originally Posted by the recluse View Post
    Fire your mechanic, he forgets to plug s**t back in...
    If only firing myself would actually accomplish anything...
    Anyway, I think it's definitely the alternator. I trickle charged the battery overnight and the idle was almost completely smooth this morning when I started it up. However, on the way to class my throttle got stuck open, which was a little scary. I pulled over to look, and the throttle cables were slack and the arm wasn't resting on the minimum air screw or the ISC plunger; it just seemed to have frozen. I fixed it by manually moving back up against the ISC plunger and it didn't do it again for the rest of the drive.

  14. #29
    Enigmaticwraith is offline Cadillac Owners Member
    Automobile(s): '93 Deville
    Join Date
    Jul 2010
    Location
    California
    Posts
    56

    Re: 4.9 Horrible Idle

    So, I replaced the alternator and it seems that all previous idle problems have been eliminated. Thanks for the help!
    One thing that was never answered and I'm still wondering about though is whether it's normal for some of the fuel injectors to be able to spin back and forth?

  15. #30
    the recluse is offline Cadillac Owners Connoisseur
    Automobile(s): 2002 STS, 1991 Eldorado
    Join Date
    Feb 2009
    Location
    Jacksonville, FL
    Posts
    1,016

    Re: 4.9 Horrible Idle

    The injector is only pushed in and held with a rubber ring on the bottom and top. The the top has a snap ring as a back up and the bottom is bolted down. Beyond that, the injector can rotate back and forth....

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting