Rough Idle
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 24
HT4100 4.1, 4.5, 4.9 Discussion, Rough Idle in Cadillac Engine Discussion; I have a 91 Sedan Deville and it idles great until I turn on the headlights, then it becomes very ...
  1. #1
    caddy john is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    Florida
    Posts
    31

    Rough Idle

    I have a 91 Sedan Deville and it idles great until I turn on the headlights, then it becomes very rough. It has a knocking sound, I have replaced the ISC snd I think I have set it up OK. I have replace the Oxygen sensor, cleaned the throttle body and the egr ports. I am at a loss, no codes. Please Help !


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    100
    100 is offline Cadillac Owners Enthusiast
    Automobile(s): 1995 Sedan De Ville (4.9 L)
    Join Date
    Oct 2003
    Location
    Woodridge, Illinois
    Posts
    581

    Re: Rough Idle

    So, the engine idles fine (and I suppose the car runs fine), unless you turn on the headlight, is this correct?

    To me, it sounds an electrical problem, or to be specific, bad ground. If I were you, I would make sure the ground is fine, especially one for the computer or the ground wire from the battery to the body.

    Good luck.

  4. #3
    Stoneage_Caddy's Avatar
    Stoneage_Caddy is offline Cadillac Owners 10000+ Posts
    Automobile(s): 01 frontier , 89 Shelby CSX vnt
    Join Date
    May 2003
    Location
    Undisclosed location in FL
    Posts
    14,607

    Re: Rough Idle

    how many volts are at the alternator(or battery) with the headlamps on ?

    if its not a mid 12 to low 13 volts they sometimes will run rough , not positive on why but weak volts/amps sometime cause rough running

  5. Remove Advertisements
    Cadillac Forums
    Advertisements
     

  6. #4
    CadiJeff's Avatar
    CadiJeff is offline Cadillac Owners Connoisseur
    Automobile(s): 1981 CoupeDeville, 2 1990 Eldorados, 1994ETC ,1992STS
    Join Date
    Feb 2004
    Location
    Nerk,Ohio
    Age
    36
    Posts
    1,072

    Re: Rough Idle

    I would recomend checking the batt and alternator sounds like a low volt situation to me.

  7. #5
    caddy john is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    Florida
    Posts
    31
    Thread Starter

    Re: Rough Idle

    I just checked the ground on the batt. and cleaned off everything. I checked the voltage and when at idle with lights on I have 12.65 volts, with lights off I have 12.82 volts. When the engine is running rough I give it a little gas and it quites running rough, I knocks and pings when it really gets rough. I am going to check the computer ground after work tonight. Ihope this works, if anyone has any other clues please let me know. Thanks from Florida

  8. #6
    maclugie's Avatar
    maclugie is offline Cadillac Owners Member
    Join Date
    Feb 2004
    Location
    Catskill, NY
    Posts
    13

    Re: Rough Idle

    I don't post too often, however; I've been having the same battle with my car. It is a well-maintained 1993 Seville with 71500 miles and the 4.9 engine. I too have changed the ISC motor, and performed the idle re-learn procedure and cleaned the TB. Still no joy on the rough idle under load condition. Interestingly, the car wasn't throwing any codes - - until now I am getting PO91 - PRNDL problem. I have been doing a little research and was thinking maybe the computer "brain" doesn't know what gear the car is in. Could this cause a problem with the idle when the car is in gear and a load is placed on the engine; i.e., lights, a/c? Would this cause a problem with the car going into looped and closed looped operation? I'm not a mechanic but I do like fixing cars myself, if possible. Does anyone know if I'm going down the right path here?

  9. #7
    Stoneage_Caddy's Avatar
    Stoneage_Caddy is offline Cadillac Owners 10000+ Posts
    Automobile(s): 01 frontier , 89 Shelby CSX vnt
    Join Date
    May 2003
    Location
    Undisclosed location in FL
    Posts
    14,607

    Re: Rough Idle

    Mine throws the po91 every once and awhile , i have no idle problems

    For you , you need to check the tightness of the swtich on the tranny int he area where the shift cable connects . the 3 bolts sometimes come loose causeing slop in that switch/sensor confuseing the car ....

    on the other car , voltage looks fine to me , but check your grounds , ive also heard for a couple people running an extra ground wire helps

    boath cars :when was the last time the fuel filter was changed ?

  10. #8
    maclugie's Avatar
    maclugie is offline Cadillac Owners Member
    Join Date
    Feb 2004
    Location
    Catskill, NY
    Posts
    13

    Re: Rough Idle

    I changed the fuel filter last year - 15000 miles ago.

  11. #9
    caddy john is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    Florida
    Posts
    31
    Thread Starter

    Re: Rough Idle

    I changed my fuel filter 1100 miles ago, I am going to run another ground today and also make sure the gound on the computer is ok. Will let you know later today, I hope it works. Thanks caddy john

  12. #10
    caddy john is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    Florida
    Posts
    31
    Thread Starter

    Re: Rough Idle

    I checked the computer ground it checked out good, I then removed the power to alternator and cleaned it up, then removed both cable connections on batt. the pos. terminal was really cruddy. I reset my codes on computer and tried it out. Darn it still started running rough after all that. So when it started running bad this time I put it in Park, it smoothed out. I then put it back in drive, it ran smooth for about 1 min. the it became rough again, so I tried park again it got smooth. I then put it back in drive, it idled smooth, I let it idle for 10 min. It ran smooth all that time, I hope it is fixed. I will let you know in a few days. Still do not know what fixed it, but it is great now. Thank everyone for the help and if you know what helped let me know.

  13. #11
    caddy john is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    Florida
    Posts
    31
    Thread Starter

    Re: Rough Idle

    Well just got back from a drive of 150 miles, bad news. It idled great going over, but when I stopped to get something to eat when I started to idle rough, I tried putting it in park but no good it keep getting rougher. I gave it some gas and tried again, not good. After about 10 miles it started doing great again. I just do not understand what is going on. Please help, Thanks caddy john

  14. #12
    caddy john is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    Florida
    Posts
    31
    Thread Starter

    Re: Rough Idle

    Still having problems with rough idle when car is warmed up, when it starts to become rough it knocks and makes bad noises. I give it some gas and it will smooth out, it only seems to do it when it is driveat highway speeds and then comes to a stop and beins to idle. It takes about 15 sec. after it is at an idle then it begins. I am at a loss any help is needed. Thanks for Florida

  15. #13
    Stoneage_Caddy's Avatar
    Stoneage_Caddy is offline Cadillac Owners 10000+ Posts
    Automobile(s): 01 frontier , 89 Shelby CSX vnt
    Join Date
    May 2003
    Location
    Undisclosed location in FL
    Posts
    14,607

    Re: Rough Idle

    does it still only do it with the headlamps on ?

  16. #14
    100
    100 is offline Cadillac Owners Enthusiast
    Automobile(s): 1995 Sedan De Ville (4.9 L)
    Join Date
    Oct 2003
    Location
    Woodridge, Illinois
    Posts
    581

    Re: Rough Idle

    It happens when:

    all these 3 conditions are met,
    (1) in "D"
    (2) but idle (no throttle)
    (3) the headlight is on.

    Am I right?

  17. #15
    caddy john is offline Cadillac Owners Member
    Join Date
    May 2004
    Location
    Florida
    Posts
    31
    Thread Starter

    Re: Rough Idle

    It does not make any difference now if the lights are on or off, when it begins to idle rough I put in in park and it continues to get rougher. I give it some gas and it stays rough for about 1-2 seconds, smooths out then I put it back in drive and it usually smoothes out.

  18. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •