1993 Cadillac Deville 4.9L computer problem (ISC problem continued)
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 6 of 6
HT4100 4.1, 4.5, 4.9 Discussion, 1993 Cadillac Deville 4.9L computer problem (ISC problem continued) in Cadillac Engine Technical Discussion; So I continued this in another post since the problem is obviously not what I had originally thought... so I ...
  1. #1
    rumgool is offline Cadillac Owners Member
    Automobile(s): 1993 Cadillac Deville Sixty Special Edition
    Join Date
    Mar 2008
    Location
    Gainesville
    Posts
    22

    1993 Cadillac Deville 4.9L computer problem (ISC problem continued)

    So I continued this in another post since the problem is obviously not what I had originally thought... so I installed a new ECM and catalytic converter after having driveability issues to the point of stalling. Car ran great after installing the new computer, but the 3rd or 4th time I ran the car after doing so... I got my service engine and vehicle light giving me an F32 error (bad connection between BCM and ECM). My speedometer was also not functional (just showed zero), and the car drove like it had no computer.... First off, is there anything I need to do with the ECM after installing (reset computer on console, reset something else), or do I have a grounding issue, and if so, why now? Also when I unplug and reinstall battery, it works fine the first crank, but the second it fails again... sigh...

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    HUF's Avatar
    HUF
    HUF is offline Cadillac Owners Connoisseur
    Automobile(s): 1995 FWB 100,*** miles CURRENT. 1991 Seville 175,000 SOLD
    Join Date
    Dec 2005
    Location
    MA
    Age
    55
    Posts
    2,002

    Re: 1993 Cadillac Deville 4.9L computer problem (ISC problem continued)

    Have you installed correct PROM on the new ECM?

  4. #3
    rumgool is offline Cadillac Owners Member
    Automobile(s): 1993 Cadillac Deville Sixty Special Edition
    Join Date
    Mar 2008
    Location
    Gainesville
    Posts
    22

    Re: 1993 Cadillac Deville 4.9L computer problem (ISC problem continued)

    yea... i just had a loose battery terminal... seems to work fine now... still seems to run a lil rough, but much improved... hopefully o2 sensor will fix the roughness

  5. #4
    rumgool is offline Cadillac Owners Member
    Automobile(s): 1993 Cadillac Deville Sixty Special Edition
    Join Date
    Mar 2008
    Location
    Gainesville
    Posts
    22

    Re: 1993 Cadillac Deville 4.9L computer problem (ISC problem continued)

    Ground failure again today, had to reset battery cables and again, its fine. Any ideas on accessing ground terminals to check connection and clean connectors? I assume a loose ground connection is the source of my troubles...

  6. #5
    HUF's Avatar
    HUF
    HUF is offline Cadillac Owners Connoisseur
    Automobile(s): 1995 FWB 100,*** miles CURRENT. 1991 Seville 175,000 SOLD
    Join Date
    Dec 2005
    Location
    MA
    Age
    55
    Posts
    2,002

    Re: 1993 Cadillac Deville 4.9L computer problem (ISC problem continued)

    Quote Originally Posted by rumgool View Post
    Ground failure again today, had to reset battery cables and again, its fine. Any ideas on accessing ground terminals to check connection and clean connectors? I assume a loose ground connection is the source of my troubles...
    There is a ground on the engine block next to the starter. Clean the area, replace the stud (8 mm x 1.25) and the star washer. Another ground location is behind the passenger side headlight assembly.

  7. #6
    rumgool is offline Cadillac Owners Member
    Automobile(s): 1993 Cadillac Deville Sixty Special Edition
    Join Date
    Mar 2008
    Location
    Gainesville
    Posts
    22

    Re: 1993 Cadillac Deville 4.9L computer problem (ISC problem continued)

    thank you very much... i just picked up some ramps today so I will be replacing the O2 sensor, and checking those grounds... I got a new computer(testing to see if the replacement I got was faulty) and it hasn't failed yet, so my problem may be fixed, and may be fixed! I am still going to check of course, though. I'm also thinking about flushing my power steering system. Doesn't seem to bad...

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting