93 deville problems
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 8 of 8
HT4100 4.1, 4.5, 4.9 Discussion, 93 deville problems in Cadillac Engine Technical Discussion; Hi everyone it's me again i think i figured out why the car is bogging down i got a 70 ...
  1. #1
    mike93 is offline Cadillac Owners Fanatic
    Automobile(s): 1993 Cadillac sedan deville
    Join Date
    Sep 2009
    Location
    Media, Pennsylvania
    Age
    23
    Posts
    281

    93 deville problems

    Hi everyone it's me again i think i figured out why the car is bogging down i got a 70 code intermittent tps fault so i think that's what my problem is also the power steering line is leaking how hard to put new power steering line? also when you tap the gas lightly u feel the motor jump bad motor mount maybe?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    HUF's Avatar
    HUF
    HUF is offline Cadillac Owners Connoisseur
    Automobile(s): 1995 FWB 100,*** miles CURRENT. 1991 Seville 175,000 SOLD
    Join Date
    Dec 2005
    Location
    MA
    Age
    55
    Posts
    2,006

    Re: 93 deville problems

    Quote Originally Posted by mike93 View Post
    Hi everyone it's me again i think i figured out why the car is bogging down i got a 70 code intermittent tps fault so i think that's what my problem is also the power steering line is leaking how hard to put new power steering line? also when you tap the gas lightly u feel the motor jump bad motor mount maybe?
    Connect an ohmmeter to the TPS and watch the resistance while lifting the trottle lever. It should change smoothly. If not, replace and follow the adjustment procedure.

    Powersteering line (one connected to the PS gear? if so, must be rusted) is very tricky to put back. My advice: as soon as you take the original one out, put it back. Otherwise you will be figuring out how to do that for a long time.

    Engine jumping. Check out the rubber bushing in the torque mount connected to the top of the radiator cover (aka "dog bone").

  4. #3
    mike93 is offline Cadillac Owners Fanatic
    Automobile(s): 1993 Cadillac sedan deville
    Join Date
    Sep 2009
    Location
    Media, Pennsylvania
    Age
    23
    Posts
    281

    Re: 93 deville problems

    Ok thanks HUF the line is leaking a lil and ill check the tps and motor mount i have the fsm so ill check the power steering line in the book

  5. #4
    mike93 is offline Cadillac Owners Fanatic
    Automobile(s): 1993 Cadillac sedan deville
    Join Date
    Sep 2009
    Location
    Media, Pennsylvania
    Age
    23
    Posts
    281

    Re: 93 deville problems

    Also I forgot to say the parking brake cable is sticking I need help on what to do about that please help

  6. #5
    HUF's Avatar
    HUF
    HUF is offline Cadillac Owners Connoisseur
    Automobile(s): 1995 FWB 100,*** miles CURRENT. 1991 Seville 175,000 SOLD
    Join Date
    Dec 2005
    Location
    MA
    Age
    55
    Posts
    2,006

    Re: 93 deville problems

    Quote Originally Posted by mike93 View Post
    Also I forgot to say the parking brake cable is sticking I need help on what to do about that please help
    Well, take the rear wheels off and see what's going on when you apply and release the parking brake.

  7. #6
    mike93 is offline Cadillac Owners Fanatic
    Automobile(s): 1993 Cadillac sedan deville
    Join Date
    Sep 2009
    Location
    Media, Pennsylvania
    Age
    23
    Posts
    281

    Re: 93 deville problems

    Ok will do thanks huf

  8. #7
    drewsdeville is offline Cadillac Owners Master
    Automobile(s): 2011 Crown Vic LX
    Join Date
    Oct 2004
    Location
    Oak Creek, WI
    Posts
    5,311

    Re: 93 deville problems

    Correct your TPS code before replacing motor mounts. The faulty TPS could be causing your "jumping"...

  9. #8
    steelybill is offline Cadillac Owners Enthusiast
    Automobile(s): '85 Fleetwood FWD
    Join Date
    Mar 2009
    Location
    mich
    Age
    83
    Posts
    727

    Re: 93 deville problems

    The front parking brake cable is usually a problem when rarely used. I had to lube mine under the dash where it connects to the pedal, and below the body where it comes out of it's housing. The lube worked it's way into the housing when I worked the brake off & on a few times, and became OK again.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting