Strange problem Seville 90
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
HT4100 4.1, 4.5, 4.9 Discussion, Strange problem Seville 90 in Cadillac Engine Technical Discussion; My name is Lars and i live in Sweden,3 months ago i bought this car. The car dident run so ...
  1. #1
    Ekberg1962 is offline Cadillac Owners Member
    Automobile(s): Seville 1990
    Join Date
    Oct 2009
    Age
    52
    Posts
    3

    Strange problem Seville 90

    My name is Lars and i live in Sweden,3 months ago i bought this car.
    The car dident run so well but i tought it would be some minor problems,the
    car has only run 80,000 miles and are in good condition.
    I changed plugs,cables ,distributorcap,rotor,ignitioncoil oil and filters.
    The car stills run badly so i have to go deeper and i found out that i have two
    bad fuel injectors.I orderd 8 new Bosch injectors from fiveomotors becourse they are to expensive in Sweden and i changed the fuel pressure regulator as
    well becourse it dident seem to work properly.The fuel pressure is 42 psi.
    Now when i have explained what i have done with the car here is the problem
    When i start the engine and she is cold it runs well but when the car is in normal operating temperature she begins to run badly it feels like there is not
    the power their should be in the engine,but when i drive the car about 10 miles she starts run wery nice and then i can drive her 100 miles and there is no problem.The next problem is when i stop the engine for about 5 minutes she is wery hard to start,and i have to drive her for about 10 miles and she runs very good again.I hope you can anderstand me and maybe give me a little help.Thanks

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Dave S Texas's Avatar
    Dave S Texas is offline Cadillac Owners Enthusiast
    Automobile(s): '87 Coupe DeVille 4.1L FWD(New engine '08) 1981 F100 '03FXDL
    Join Date
    May 2008
    Location
    Austin(area), Tx
    Age
    71
    Posts
    855

    Re: Strange problem Seville 90

    Do you have the FSM for the car? If not:

    http://shop.ebay.com/?_from=R40&_trk...All-Categories

    From the description: it runs ok after extended warm-up? Just a guess, but maybe the problem is that it's over-cooling. Bad/wrong T-Stat and /or bad/wrong Radiator cap....

    Any trouble codes? Knowing how to access all the info in the computer(not just the trouble codes)would be the best clues to the detective story you have on your hands. The FSM has all the tests/procedures to help solve problems. Best tool you can own.
    BTW: not familiar with 5motors. Ever looked at RockAuto dot com for Cadillac parts?

  4. #3
    Ekberg1962 is offline Cadillac Owners Member
    Automobile(s): Seville 1990
    Join Date
    Oct 2009
    Age
    52
    Posts
    3
    Thread Starter

    Re: Strange problem Seville 90

    Thanks for your answer!I forgot to say that i have a new radiator and cap,the
    only code i have is B120 and i think itīs twilight sentinel.I also have a new t-stat and when the engine is warm the temperature is about 195 degr.F.
    I couldent find a shop manual for the 90 Seville on Ebay.
    I am thankfull for all your help,and i am sorry that i dont now the right words for everything i hope you can anderstand what i mean.

  5. #4
    Dave S Texas's Avatar
    Dave S Texas is offline Cadillac Owners Enthusiast
    Automobile(s): '87 Coupe DeVille 4.1L FWD(New engine '08) 1981 F100 '03FXDL
    Join Date
    May 2008
    Location
    Austin(area), Tx
    Age
    71
    Posts
    855

    Re: Strange problem Seville 90

    The link I put up has over 20 1990 Cadillac Seville Factory Service Manuals!
    Click it.....

  6. #5
    Ekberg1962 is offline Cadillac Owners Member
    Automobile(s): Seville 1990
    Join Date
    Oct 2009
    Age
    52
    Posts
    3
    Thread Starter

    Re: Strange problem Seville 90

    I am sorry to say that i dident understand that it is the same manual for
    Eldorado and Seville.but thanks for your help.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting