4.9 ping!!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 5 of 5
HT4100 4.1, 4.5, 4.9 Discussion, 4.9 ping!!! in Cadillac Engine Technical Discussion; 95 SDN DEVLLE. pings when i accelerate,93oct. premium fuel since day 1 timed an tuned a year ago. thanks in ...
  1. #1
    rick davenport is offline Cadillac Owners Member
    Automobile(s): sedan deville
    Join Date
    Nov 2009
    Age
    52
    Posts
    30

    4.9 ping!!!

    95 SDN DEVLLE. pings when i accelerate,93oct. premium fuel since day 1 timed an tuned a year ago. thanks in advance for any info

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Submariner409's Avatar
    Submariner409 is offline If it won't run, stick on fender vents
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    75
    Posts
    45,969

    Re: 4.9 ping!!!

    Remove and clean the EGR valve and passages, then double check the initial timing setting. A sticky EGR valve pintle will cause a brief rattle on acceleration, at an upshift, or up a light grade: usually no ping on hard or WOT accelerations.

  4. #3
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with DTS floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    74,794

    Re: 4.9 ping!!!

    The EGR passages that Sub speaks of are down in the TB. Two EGR tubes. They are likely carboned closed.

  5. #4
    brougham is offline Cadillac Owners Master
    Automobile(s): 1991 Cadillac Brougham D'Elegance 5.7 Litre
    Join Date
    Jun 2003
    Location
    Canada
    Posts
    5,642

    Re: 4.9 ping!!!

    Add if they aren't the EGR valve could be bad. Changing it is what fixed mine pinging.

  6. #5
    Trilo is offline Cadillac Owners Member
    Automobile(s): 1988 Eldorado
    Join Date
    Dec 2009
    Age
    45
    Posts
    3

    Re: 4.9 ping!!!

    Was there any movement of the Throttle Sensor when you replaced the EGR. There's a specific way to reset the TPS with the ISC and throttle at absolute 0, and the battery cable must be removed to allow the ISC to relearn. Call me crazy but I've always replaced the fuel filter on those years after misdiagnosing everything from fuel injectors to fuel pumps. Clogged filters are notorious for gumming up the works.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting