92 seville 4.9L engine problem
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 9 of 9
HT4100 4.1, 4.5, 4.9 Discussion, 92 seville 4.9L engine problem in Cadillac Engine Technical Discussion; ...
  1. #1
    Tammy is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Nov 2008
    Posts
    2

    92 seville 4.9L engine problem

    Hi,
    I´m from Argentina and I own a 1992 Cadillac Seville (L26 4,9L). I am having some problems with the car, and perhaps someone in this forum can help me find the possible causes and solutions.
    The problem is that when the engine is running, after a few minutes, it starts to vibrate, lose power and produce white smoke –which comes out through the exhaust and also directly out of the engine. The smoke is very dense and makes eyes burn, so its not water vapor.
    I think it’s an electronic problem, because when this happens, I stop the engine and wait for a couple of minutes; after that I start it again and it works normally for a few minutes until the problem happens again.
    I know that to identify the problem I need to use the Tech 2. I have the Tech 2 but the problem is I dont have the card software or the plug adaptor for the Seville model.
    I hope someone here can tell me if they´ve had this problem or suggest where I can buy these diagnose tools (Card software and plug adaptor).
    Thank you in advance!

    Best,

    Tammy

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    52
    Posts
    2,674

    Re: 92 seville 4.9L engine problem

    If you are positive it is not losing coolant, it might be the catalytic converter doing something funny. At the top of this 4.9 section there is a sticky with instructions on getting your codes. Try that and see what comes up.

  4. #3
    HUF's Avatar
    HUF
    HUF is offline Cadillac Owners Connoisseur
    Automobile(s): 1995 FWB 100,*** miles CURRENT. 1991 Seville 175,000 SOLD
    Join Date
    Dec 2005
    Location
    MA
    Age
    55
    Posts
    1,987

    Re: 92 seville 4.9L engine problem


  5. #4
    donwon is offline Cadillac Owners Enthusiast
    Automobile(s): 92 Deville
    Join Date
    Sep 2004
    Location
    SC.
    Posts
    517

    Re: 92 seville 4.9L engine problem

    If it was an origional USA car, Check the PCV valve. If it don't rattel change it.

  6. #5
    NickySantoro is offline Cadillac Owners Fanatic
    Automobile(s): 1993 Eldo 4.9 66K miles
    Join Date
    Nov 2005
    Location
    Nazi Jerky, libtard central
    Posts
    372

    Re: 92 seville 4.9L engine problem

    White smoke might be a sign that the vacuum modulator on the transmission has failed and transmission fluid is being pulled into the intake. This is simply checked by removing the vacuum line at the modulator and inspecting for the presence of fluid. There should be none.

  7. #6
    Tammy is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Nov 2008
    Posts
    2

    Re: 92 seville 4.9L engine problem

    Thank you all for your help! I,m going to try with these solutions. I,ll let you know what happens!

    Best,
    Tammy

  8. #7
    justin4yu is offline Cadillac Owners Member
    Automobile(s): 1992 Cadillac Fleetwood 2door sedan
    Join Date
    Jun 2010
    Location
    Yelm, Washington, United State
    Age
    28
    Posts
    31

    Re: 92 seville 4.9L engine problem

    I had a problem with a injector not working, I found a computer out of a wrecked car for $10 bucks, switched proms and it runs on all eight now, i think you might try that and see if it works. It sounds to me you have injectors firing randomly causing your white smoke maybe I am wrong.

  9. #8
    Ranger's Avatar
    Ranger is offline Cadillac Owners Member
    Automobile(s): White Diamond '03 DHS (with floor shift)
    Join Date
    Jun 2004
    Location
    Woodstock Ill.
    Age
    66
    Posts
    70,262

    Re: 92 seville 4.9L engine problem

    This thread is 2 1/2 yrs old. I'd guess it is fixed, junked or sold by now.

  10. #9
    justin4yu is offline Cadillac Owners Member
    Automobile(s): 1992 Cadillac Fleetwood 2door sedan
    Join Date
    Jun 2010
    Location
    Yelm, Washington, United State
    Age
    28
    Posts
    31

    Talking Re: 92 seville 4.9L engine problem

    I did not realize how old the thread was, thank you for bringing that to my attention, i still think its helpful for the next guy with the same problem looking thru the forum.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting