HELP! 4.9 Missing and Dist. cap clicking!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
HT4100 4.1, 4.5, 4.9 Discussion, HELP! 4.9 Missing and Dist. cap clicking! in Cadillac Engine Technical Discussion; Hi all Ive been working on my friends 91 De ville 4.9 with approx 129K on it. The problem is ...
  1. #1
    my126benz is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    6

    HELP! 4.9 Missing and Dist. cap clicking!

    Hi all

    Ive been working on my friends 91 De ville 4.9 with approx 129K on it. The problem is that the car stumbles when you accelerate. It never stalls or has problems starting but it roughs very rough while you drive. While the car is idling you can hear a click or tap coming from the dist. cap. I'm 99% sure its coming from the cap and not a lifter. I have replaced the cap (badly corroded), rotor and ignition module chip then tried adjusting the timing and checked the play by wiggling the rotor(seems okay), but to no avail. I have not checked the plugs or wires because of the clicking coming from the cap. It sounds like an arc. So I assume that the distributor is bad. My friend doesn't really want the car so I am hesitant to put money in it unless I am sure it will fix it. So does it sound like a distributor problem? Any help would be very helpful.

    Many thanks

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    66
    Posts
    5,471

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    Did you transfer the coil ground strap from the old cap to the new one? What you might be hearing is a spark snap because of no ground.

  4. #3
    my126benz is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    6

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    ah. When I changed the cap I saw no ground strap. Where is supposed to be attached?

    Thanks

  5. #4
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    66
    Posts
    5,471

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    Goes under the coil, between it and the cap, silver in color. Attaches to one of the coil mounting screws into the cap. They sometimes stick to the cap or coil.

  6. #5
    my126benz is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    6

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    Thanks, Ill check it out!

  7. #6
    my126benz is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    6

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    Ok I checked the ground and it is attached. So do I need a distributor?

  8. #7
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    66
    Posts
    5,471

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    I doubt it. Probably faulty cap or rotor. Cheap brand. Did you also transfer the red rubber insulator and coil pick up lead to the new cap? under the coil.

  9. #8
    cadillac_al is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac 78 Seville, 78 Coupe de Ville, 92 Sedan de Ville
    Join Date
    Feb 2007
    Location
    Maine
    Age
    52
    Posts
    2,674

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    If the spark can't get to the plugs it will jump somewhere else. The plugs should be checked/replaced and replacing spark plug wires is kind of routine maintenance. FWIW my Caddy still has the original plug wires at 188,000. I don't usually condone this but if it's running fine I don't touch them. Do you suppose the plug wires could be crossed?

  10. #9
    my126benz is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    6

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    Ok that's what I needed to know. Ill check all the plugs and wires. As far as a bad cap or rotor I guess its possible but the car is doing the same thing it was doing before i touched it. Missing and its arcing in the cap as it misses. Anybody have a good way to get to the back plugs? Ive changed them on a Buick 3.8 and that was a PITA. Not looking forward to it. Thanks for your help and ill let you know how it turns out.

  11. #10
    HUF's Avatar
    HUF
    HUF is offline Cadillac Owners Connoisseur
    Automobile(s): 1995 FWB 100,*** miles CURRENT. 1991 Seville 175,000 SOLD
    Join Date
    Dec 2005
    Location
    MA
    Age
    55
    Posts
    1,987

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    Quote Originally Posted by my126benz View Post
    Ok that's what I needed to know. Ill check all the plugs and wires. As far as a bad cap or rotor I guess its possible but the car is doing the same thing it was doing before i touched it. Missing and its arcing in the cap as it misses. Anybody have a good way to get to the back plugs? Ive changed them on a Buick 3.8 and that was a PITA. Not looking forward to it. Thanks for your help and ill let you know how it turns out.
    To get the back plugs you have to lay across the engine. Not that bad, just you cannot see them.

  12. #11
    my126benz is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jul 2008
    Posts
    6

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    Thanks for all your help!

    I changed the plugs and wires and with the last 2 plugs on the back of the engine (2 and 4 I believe) I smelled gas on the plugs. When I was done (after scrapes and cuts from getting to the back plugs) I started it up and I don't think i have ever heard an engine run better than that one. Its been a long time since I had my caddy (86 Fleetwood Brougham) and now I remember why I liked it so much. Anyway the car is running cherry and thanks for all the help.

  13. #12
    awadecki is offline Cadillac Owners Enthusiast
    Automobile(s): 76 Eldo (54k), 76 Eldo (52k), 78 Eldo (9k), 85 Deville (43k)
    Join Date
    Jun 2005
    Location
    Michigan
    Posts
    662

    Re: HELP! 4.9 Missing and Dist. cap clicking!

    the old cap was probably so corroded that the spark never got to those back plugs, fouling them out. then, once you put the new cap on, the spark plug wires were probably arcing out since the plugs didn't want to fire.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting