Two Problems Not Starting and Stalling - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 19 of 19
HT4100 4.1, 4.5, 4.9 Discussion, Two Problems Not Starting and Stalling in Cadillac Engine Technical Discussion; Well one piece at a time as i can afford it SO far NEW ICM, and rotor. Still stalling... Next ...
  1. #16
    gsabato is offline Cadillac Owners Member
    Join Date
    Oct 2005
    Posts
    33
    Thread Starter

    Re: Two Problems Not Starting and Stalling

    Well one piece at a time as i can afford it SO far NEW ICM, and rotor. Still stalling... Next week new cap wires and plugs... I hope.

  2. #17
    kdcing is offline Cadillac Owners Fanatic
    Automobile(s): 1993 Eldorado, 4.9L, 200k miles
    Join Date
    Dec 2006
    Posts
    273

    Re: Two Problems Not Starting and Stalling

    Quote Originally Posted by gsabato View Post
    All the terminals are black, chipped etc
    For a short term fix, you can try cleaning the cap's terminals w/ emory cloth or emery board (worst case, use sandpaper)....but it does sound like the cap really needs to be replaced, as you mentioned.

  3. #18
    gsabato is offline Cadillac Owners Member
    Join Date
    Oct 2005
    Posts
    33
    Thread Starter

    Re: Two Problems Not Starting and Stalling

    Heres the thing. Since I put in the rotor and the ICM the computer throws code e23 and runs worse than ever... I did find a busted vacuum hose and fixed that. Idle smoothed out a bit. I did clean the cap that helped some too... But whats the e23 code EST Signal? Timing? but why now with a new ICM?

  4. #19
    hthorn is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Feb 2008
    Posts
    47

    Re: Two Problems Not Starting and Stalling

    Hello, n00b hthorn here...first post, FWIW...I once had a DeVille with an otherwise OK and < 130,000-mi 4.5. It would sometimes fail to start, and it gave the Distributor Signal Interrupt code. Replacing the battery (shorted cell) solved this. In your case, it sounds as though you have a combination of problems, one of which could be a vacuum leak. You can (carefully) use a can of ether or brakleen to troubleshoot for it (engine on of course), or you can simply replace all the vacuum hoses, and you could be on the right track with the PCV valve. Sorry I don't have the Haynes manual handy so I can't look up the e23 code...I have heard about defective power steering control switches causing stalling problems. If this switch fails, the idle is not increased enough to compensate for the additional load imposed by turning the wheel at idle; the engine fights to stay on a bit, then loses its struggle and dies...

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting