Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 6 of 6

Thread: Replaced Water Pump on 89 4.5 Still leaking

  1. #1
    americanbudo is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Aug 2007
    Posts
    1

    Unhappy Replaced Water Pump on 89 4.5 Still leaking

    My son replaced the water pump on his 89 Caddy and it still leaks . Had it towed to a shop and they say the antifreeze is leaking out of the timing cover. Is that possible? I've never seen timing gears in an antifreeze bath. Does the cover also contain some ports for directing water jacket flow? I don't want to call the mech a liar. but I don't trust blindly either.
    Dana


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Leeb's Avatar
    Leeb is offline Cadillac Owners Enthusiast
    Automobile(s): did this once... 86 Deville, 86 300E, 78 R100rs
    Join Date
    Jun 2005
    Location
    Palm Spgs CA
    Age
    57
    Posts
    517

    Re: Replaced Water Pump on 89 4.5 Still leaking

    Yes, unfortunately it is possible that situation exists, especially on the firewall side.
    The 2 large bolts that were removed on that side also hold down that corner of the timing cover....
    It is not necessary to remove the duplicate bolts on the radiator side but might have...

  4. #3
    carnut is offline Cadillac Owners Master
    Automobile(s): 1999 BMW 740 Il. 2005 Jag XK8, 1988 Mercedes Benz 300 SE
    Join Date
    Feb 2003
    Location
    california
    Age
    69
    Posts
    6,688

    Re: Replaced Water Pump on 89 4.5 Still leaking

    I agree. Also that gasket is a real bear to get completely off and the surface clean.

  5. #4
    snydly402 is offline Cadillac Owners Member
    Automobile(s): 1990 sedan deville
    Join Date
    Aug 2007
    Location
    Nebraska
    Posts
    9

    Re: Replaced Water Pump on 89 4.5 Still leaking

    i went thru this. it does leak behind the timing cover. the water pump bolts to the "front" part of the motor over the timing cover, and then there it a peice that bolts to the backside of the timing cover which is part of the cooling system. put the left frontside up high on jackstands and unbolt the front and rear engine cradle mounts and slowly lower that with the jack until the cranckshaft pulley is clear of the frame rail. youll need to pull the pully off and unbolt the timing cover and water pump. I know for sure Carquest sells the kit, it comes with timing cover gasket, rear gasketbehind the toming cover, waterpump gasket, and a new seal around the crankshaft. this is time kind of time consuming. also a big vise-grip spreader will help to push the motor to get a little more clearance for your hands.

  6. #5
    wikked_magick45 is offline Cadillac Owners Member
    Automobile(s): Cadillac Seville 4.9L
    Join Date
    Oct 2007
    Location
    Saginaw, MI
    Posts
    24

    Re: Replaced Water Pump on 89 4.5 Still leaking

    I had this happen to my Seville. 3 water pumps, 5 sets of gaskets, and $275 later, I replaced my timing cover. Apparently it was bent - got me how that happened. But it caused a nasty water leak, and if you fix one another leak started. Grr... It's a pain. While I had it apart, I replaced my timing chain and gears. Good suggestion if you go that far - will save you later down the road. Mine was sloppy as hell, and after the new one was installed, nice n tight.

  7. #6
    tommyinajar is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Oct 2006
    Posts
    1

    Re: Replaced Water Pump on 89 4.5 Still leaking

    Where the heck do you buy the actual cover from ? All I can find are water pump gaskets.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum