93 Seville 4.9 rough idle, slow response, P041 code
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 2 of 2
HT4100 4.1, 4.5, 4.9 Discussion, 93 Seville 4.9 rough idle, slow response, P041 code in Cadillac Engine Technical Discussion; Hey guys, I just wanted to pick some brains. I've been working on my brothers 93 Seville with the 4.9. ...
  1. #1
    landscaperluke is offline Cadillac Owners Member
    Automobile(s): 94 STS
    Join Date
    Jul 2005
    Location
    Crandon, WI U.S.A.
    Age
    32
    Posts
    21

    93 Seville 4.9 rough idle, slow response, P041 code

    Hey guys,
    I just wanted to pick some brains. I've been working on my brothers 93 Seville with the 4.9. We have been getting a P041 code which is "No cam reference signal from Ignition Control Module" and it has been on most of the time. It has shut off on its own, and when it does the idle smooths right out and it runs beautifully. Then it goes right back into the same problem. Sometimes it will go into violent surges and even stall out.
    We took a look under cap and rotor and found that the "hall effect switch" was a bit loose, and the wires were just all over the place and in a few places worn right through the insulation. I went through and checked continuity and fixed all worn areas. Still same problem.
    We have replaced cap, rotor, plugs, wires, cleaned throttle body, replaced air and fuel filter. Still no success. Ignition module was replaced not too long ago as well as "hall effect switch" within last year. Also all the plastic ends on all the wires inside the distributor have completely disintegrated and thus the problem of wires going anywhere the wanted. I also found a piece of metal inside dist. cup that seems to be the same size as the one I believe trips the hall effect switch to send cam position to pcm.
    Any suggestions would be greatly appreciated.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    HUF's Avatar
    HUF
    HUF is offline Cadillac Owners Connoisseur
    Automobile(s): 1995 FWB 100,*** miles CURRENT. 1991 Seville 175,000 SOLD
    Join Date
    Dec 2005
    Location
    MA
    Age
    55
    Posts
    1,997

    Re: 93 Seville 4.9 rough idle, slow response, P041 code

    I would replace the whole thing - the distributor.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting