1985 Eldorado thinks it a diesel?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 2 of 2
HT4100 4.1, 4.5, 4.9 Discussion, 1985 Eldorado thinks it a diesel? in Cadillac Engine Technical Discussion; Greetings, 1985 Eldorado, 25K miles When highway driven at speed (40mph or better) for 15 minutes or more, call will ...
  1. #1
    ob1
    ob1 is offline Cadillac Owners Member
    Automobile(s): Cadillac
    Join Date
    Jun 2007
    Posts
    3

    1985 Eldorado thinks it a diesel?

    Greetings,

    1985 Eldorado, 25K miles
    When highway driven at speed (40mph or better) for 15 minutes or more, call will detonate severly upon decelleration. Problem will go away if throttle is flored and kick down into passing gear. The detonation is severe and sounds like a deisel motor. The idle control motor will pulse the throttle to keep engine running. This problem only occurs upon decelleration to a to stop or merge in traffic after driving for at least 10 or 15 minutes at highway speeds. EGR replaced, fuel delivery test done, fuel filter changed, timing checked, car has new exhaust system and new catalytic convertor. Any help appreciated.

    Thanks,
    OB1-

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    awadecki is offline Cadillac Owners Enthusiast
    Automobile(s): 76 Eldo (54k), 76 Eldo (52k), 78 Eldo (9k), 85 Deville (43k)
    Join Date
    Jun 2005
    Location
    Michigan
    Posts
    662

    Re: 1985 Eldorado thinks it a diesel?

    Dieseling on deceleration? That's a new one. Any codes?

    You may have a severly leaking injector, a bad MAP sensor, or perhaps a bad TPS. Turn the key on and watch and see if an injector starts dribbling. Also, check to see if your TPS voltage increases smoothly as you depress the pedal. Check the MAP vacuum hose and you may want to just replace the sensor since it's about $15.

    Maybe an 02 sensor since it only occurs when hot.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting