car runs too rich didnt pass smog
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
HT4100 4.1, 4.5, 4.9 Discussion, car runs too rich didnt pass smog in Cadillac Engine Technical Discussion; i have a 90 4.5 fleetwood fwd and it is running too rich. wont pass smog because of it. i ...
  1. #1
    bshizzle is offline Cadillac Owners Member
    Automobile(s): 90 4.5 fleetwood fwd
    Join Date
    Sep 2005
    Posts
    8

    car runs too rich didnt pass smog

    i have a 90 4.5 fleetwood fwd and it is running too rich. wont pass smog because of it. i have most injectors replaced couple of years ago. did a tune up o2 sensor changed. is there anything someone could recommend before i take this to a mechanic shop and blow 100's of dollars.

    my car also qualified as a gross poluter. the numbers it failed was at like 600 but was suppose to be at 120 or under.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    awadecki is offline Cadillac Owners Enthusiast
    Automobile(s): 76 Eldo (54k), 76 Eldo (52k), 78 Eldo (9k), 85 Deville (43k)
    Join Date
    Jun 2005
    Location
    Michigan
    Posts
    668

    Re: car runs too rich didnt pass smog

    maybe a bad fuel pressure regulator?

  4. #3
    noahsdad's Avatar
    noahsdad is offline Cadillac Owners Connoisseur
    Automobile(s): '87 SDV
    Join Date
    Jun 2005
    Location
    Michigan
    Age
    55
    Posts
    1,296

    Re: car runs too rich didnt pass smog

    Here's the list from the FSM for diagnosing a rich condition:

    Run OBD diagnostic - any codes?

    Double check oxygen sensor parameters and connections

    if oxy sensor is within parameter value 0.00 to 0.63 V:

    1) Check for restricted air cleaner or thermac valve operation
    2) Check EGR operation
    3) Check fuel pressure
    4) Check for injector leaks
    5) Check for vacuum leak to MAP hose
    6) Check purge canister for proper operation

  5. #4
    behind-bars is offline Cadillac Owners Connoisseur
    Automobile(s): 93 Sedan Deville 4.9L
    Join Date
    Sep 2005
    Location
    Texas
    Posts
    1,005

    Re: car runs too rich didnt pass smog

    I just tried seafoam, says on the can it'll help pass emissions test. It cleans carbon out of the engine.

    I would say o2 was at fault if was it replaced before the injectors? If it was one after the injectors it may be fine, Also was the car warmed up when tested or still cold?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting