1970 Gen light always on when engine running, charging system is fine
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
Electrical Technical Information Discussion, 1970 Gen light always on when engine running, charging system is fine in Item Specific Cadillac Discussion; Here's a good one, hopefully this will help somebody someday. This applies to 1970 Cadillac, possibly other years. If your ...
  1. #1
    intragration's Avatar
    intragration is offline Cadillac Owners Fanatic
    Automobile(s): 1970 Coupe DeVille, 2002 Eldorado Collector Series
    Join Date
    Feb 2008
    Location
    Northlake, IL
    Posts
    196

    1970 Gen light always on when engine running, charging system is fine

    Here's a good one, hopefully this will help somebody someday. This applies to 1970 Cadillac, possibly other years. If your gen lamp is always on when the car is running, and you've checked your charging system and it's working fine, check the gauge/trans fuse. The way the gen lamp works, it gets power from both sides of the circuit, and if there is an imbalance in power between sides, it will illuminate. If the gauge/trans fuse is blown, it's not getting power from that side, so the lamp will illuminate even though everything else is working fine. Be aware that SOMETHING caused that fuse to blow, and this root cause should be tracked down. In my case, I believe it was due to a failing battery connector on the back of the alternator causing high resistance and possibly overcharging.
    Attached Images

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    jimsbox is offline Cadillac Owners Enthusiast
    Automobile(s): 2000 DHS
    Join Date
    Apr 2005
    Location
    Kansas City
    Age
    60
    Posts
    560

    Re: 1970 Gen light always on when engine running, charging system is fine

    1970, that can't be right, it had a candle that lit up, they didn't have electricity back then! lol

  4. #3
    londonslimos's Avatar
    londonslimos is offline Cadillac Owners Member
    Automobile(s): 73 calais,
    Join Date
    Oct 2011
    Location
    yellville arkansas
    Age
    52
    Posts
    42

    Re: 1970 Gen light always on when engine running, charging system is fine

    thanks my problem solved

  5. #4
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    67
    Posts
    5,733

    Re: 1970 Gen light always on when engine running, charging system is fine

    It can also be lit dimly and still charge. That is most likely a failed diode trio within the Alternator.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting