'97 Deville Electronic Speedo went blank!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 2 of 2
Electrical Technical Information Discussion, '97 Deville Electronic Speedo went blank! in Item Specific Cadillac Discussion; You guys are great! Very insightful! I hope you guys can help me. My '97 Deville Electronic (green digital) Dash ...
  1. #1
    jah316 is offline Cadillac Owners Member
    Automobile(s): deville
    Join Date
    Aug 2009
    Posts
    3

    '97 Deville Electronic Speedo went blank!

    You guys are great! Very insightful! I hope you guys can help me. My '97 Deville Electronic (green digital) Dash went blank all of a sudden. I drove it to a stop light and then it comes on again for about 10 seconds! Then it slowly dimmed away (as if saying, good bye!). I have checked all the fuses and relays (under hood and behind the back seat - is there any more?) and even removed the dash and opened it up (there is no accessible/replacable bulbs for the center section that doesn't light up!). The wierd thing is that the two side digital screens still work fine (the temperature and estimated distance remaining). I read in another post that someone had a similar problem and found the ignition control relay at the back seat to be the problem. I checked all the relays at the back seat. Does anyone know which one and where it's located? Is it a 4 pin or a 5 pin? There is one black 5 pin one that clicks when I attach or remove it. Could this be it? How can I test it? Can I put a jumper wire and see if the dash lights up? HELP PLEASE! Thanks a million! Peace.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    edilagan is offline Cadillac Owners Member
    Automobile(s): Deville 99
    Join Date
    Mar 2010
    Age
    58
    Posts
    6

    Re: '97 Deville Electronic Speedo went blank!

    I have a 99 De ville with exactly the same problem. I would appreciate any help. Tnx.

  4. Remove Advertisements
    Cadillac Forums
    Advertisements
     

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

What Cadillac(s) do you own? (Or type NONE)

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •