1969 cadillac calais with a 472 i need help!!! - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 29 of 29
Like Tree4Likes
The Classic Cadillac Forum Discussion, 1969 cadillac calais with a 472 i need help!!! in Past Cadillac Vehicle Discussion; I did mine on my 74 last fall. Picked the link up at a local parts store. http://www.cadillacforums.com/forums...l#post10562618...
  1. #16
    talismandave's Avatar
    talismandave is offline Cadillac Owners Master
    Automobile(s): 1987 Brougham, 1974 Fleetwood Talisman, Volvo C70,
    Join Date
    Mar 2012
    Location
    Madison WI
    Age
    55
    Posts
    6,009

    Re: 1969 cadillac calais with a 472 i need help!!!

    I did mine on my 74 last fall. Picked the link up at a local parts store.

    http://www.cadillacforums.com/forums...l#post10562618

  2. #17
    Jeff R's Avatar
    Jeff R is offline Cadillac Owners Fanatic
    Automobile(s): 1970 Coupe De Ville//Cessna 172
    Join Date
    May 2013
    Location
    St. Louis
    Age
    44
    Posts
    197

    Re: 1969 cadillac calais with a 472 i need help!!!

    OK, sorry. I misunderstood. I thought it just wouldn't start. Didn't realize the car was dead. Sorry.
    Looked at the manual for the 70 which is probably similar to yours. There a 3 fuseable links that come off the starter. 1 goes to the ignition switch, 1 to the headlight switch and the last to the fuse block. You'll need to determine what is dead and go from there. If all 3 are dead then it is going to be a common point either to or from the starter.
    Good Luck
    Jeff

  3. #18
    1969CADDY is offline Cadillac Owners Member
    Join Date
    Feb 2014
    Posts
    8

    Re: 1969 cadillac calais with a 472 i need help!!!

    I cant figure it out. This is so frustrating!!! So i check the battery with my tester im reading 12-13 volts. I just put a new alternator and voltage regulator. I checked the wires going to the alternator and voltage regulator and im getting the same. I also checked the wire coming in and out of the starter and im reading around 12-13 volts. Then i go inside the car to check the fuse box and some of the wire under the dash and nothing. No power to the inside of the car what so ever. Im so freaking confused i hope someone on here can help me out. Thanks guys

    ----------

    Oh shit thanks jeff r!!!! I didn't realize there was 3 fuse-able links from the starter. Is there anyway you can send me a pic of the diagram of what your seeing??? Thanks a lot man!

  4. #19
    Roadmaster75's Avatar
    Roadmaster75 is offline Cadillac Owners Member
    Automobile(s): 1978 Eldorado Biarritz
    Join Date
    Feb 2012
    Location
    Illinois
    Posts
    48

    Re: 1969 cadillac calais with a 472 i need help!!!

    Very symptomatic of the fusible links &/or, bad grounds/battery cables.
    You need a shop manual to guide you thru the process.
    Get one, study the chapter on fusible links and troubleshooting.

    Don't buy anything else unless it's that Cadillac Shop Manual!
    (incl." the color wiring diagrams)
    my 2 cents.

  5. #20
    talismandave's Avatar
    talismandave is offline Cadillac Owners Master
    Automobile(s): 1987 Brougham, 1974 Fleetwood Talisman, Volvo C70,
    Join Date
    Mar 2012
    Location
    Madison WI
    Age
    55
    Posts
    6,009

    Re: 1969 cadillac calais with a 472 i need help!!!


    application screenshot

    That is where the link joins the wires. The frayed part from there to the starter is the link.
    70eldo likes this.

  6. #21
    1969CADDY is offline Cadillac Owners Member
    Join Date
    Feb 2014
    Posts
    8

    Re: 1969 cadillac calais with a 472 i need help!!!

    This might be a dumb question but how did you replace them? I cant seem to find fuseable links anywhere online.

  7. #22
    talismandave's Avatar
    talismandave is offline Cadillac Owners Master
    Automobile(s): 1987 Brougham, 1974 Fleetwood Talisman, Volvo C70,
    Join Date
    Mar 2012
    Location
    Madison WI
    Age
    55
    Posts
    6,009

    Re: 1969 cadillac calais with a 472 i need help!!!

    Is post # 16 only showing up on my computer?

  8. #23
    SWEENDOG1969 is offline Cadillac Owners Member
    Automobile(s): 90k 1969 Cadillac Hardtop Sedan Deville
    Join Date
    May 2005
    Location
    seattle
    Age
    29
    Posts
    84

    Re: 1969 cadillac calais with a 472 i need help!!!

    If your fusable link is shot a.k.a melted/popped you wont have door lights,dash lights,tail lights,windows. I my fusable link kept popping because of the drain from the power windows/might have arced on the exhaust. So I put a big self resetting breaker from a local auto parts store in its place and made sure the wires where covered and up out of the way. Also I have had that started and ran great then wouuldnt crank problem and it was the battery connection. It looked good but was just that little bit loose and corrosion is a big key. I also added two wires (a little bigger and longer )from the alternator to the battery because the wire pulled out of the connector on the battery side and ran my battery completley dead and the car just stopped dead in the road.

    ----------

    wtf, the picture of your fusable link just loaded and that might be a problem...

  9. #24
    emsautollc is offline Cadillac Owners Member
    Automobile(s): '59 conv,'76 Eldo bicentenial,'58 coupe
    Join Date
    Sep 2012
    Posts
    8

    Re: 1969 cadillac calais with a 472 i need help!!!

    Fusible links and such are available as close as your local NAPA store...

  10. #25
    1969CADDY is offline Cadillac Owners Member
    Join Date
    Feb 2014
    Posts
    8

    Re: 1969 cadillac calais with a 472 i need help!!!

    yeah because my car wont even start. i have power every where else under the hood but not inside the car. im going to replace the fuseable links tonight and i will let yall know. i also order a service manual lol. thanks for all the help. im getting so frustrated with this car. im almost ready to sell it lol. i will also post some pictures of the fuseable links and yall can let me know what yall think.

  11. #26
    superjeep is offline Cadillac Owners Member
    Automobile(s): 68 sedan deville,69 sedan deville,64 fleetwod 60 special
    Join Date
    Jun 2013
    Age
    32
    Posts
    88

    Re: 1969 cadillac calais with a 472 i need help!!!

    check the big battery to frame ground and mostly the bulkhead connector that goes into the firewall

  12. #27
    Jeff R's Avatar
    Jeff R is offline Cadillac Owners Fanatic
    Automobile(s): 1970 Coupe De Ville//Cessna 172
    Join Date
    May 2013
    Location
    St. Louis
    Age
    44
    Posts
    197

    Re: 1969 cadillac calais with a 472 i need help!!!

    Let us know what you find. His pix of the links is perfect.

  13. #28
    1969CADDY is offline Cadillac Owners Member
    Join Date
    Feb 2014
    Posts
    8

    Re: 1969 cadillac calais with a 472 i need help!!!

    Alright guys, i found the groud from the battery and its was a bad ground. i cleaned it up and now i have power to the car. but now i think i should go ahead and replace a fuseable links bc they are in pretty bad shape. thank you guys very much. its pretty crazy the ground looked good but i un-screwed the bolt and cleaned the frame with brake cleaner and put it back and now i have power. lol thanks again!!! its there a site where i can just order new starter wires? i would like to just replace them all.

  14. #29
    carnut is offline Cadillac Owners Master
    Automobile(s): 1988 Allante' (sold), 1984 Eldorado, 84 Sedan DeVille
    Join Date
    Feb 2003
    Location
    california
    Age
    67
    Posts
    5,733

    Re: 1969 cadillac calais with a 472 i need help!!!

    Be aware that fusible links should be soldered to the harness. Butt connecting them can alter resistance and give you other issues.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting