1969 472 help I'm stumped !!!!! - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 26 of 26
Like Tree7Likes
The Classic Cadillac Forum Discussion, 1969 472 help I'm stumped !!!!! in Past Cadillac Vehicle Discussion; Well all the rockers are tight against the valve tips. If it was hanging open wouldnt a rocker be loose?...
  1. #16
    superjeep is offline Cadillac Owners Member
    Automobile(s): 68 sedan deville,69 sedan deville,64 fleetwod 60 special
    Join Date
    Jun 2013
    Age
    32
    Posts
    88

    Re: 1969 472 help I'm stumped !!!!!

    Well all the rockers are tight against the valve tips. If it was hanging open wouldnt a rocker be loose?

  2. #17
    sawyer is offline Cadillac Owners Member
    Automobile(s): 1969 coupe deville
    Join Date
    Aug 2013
    Age
    39
    Posts
    30
    Not always it could be working half way at slow rpm but can not keep up when rpm increases. I have had it happen to my 56 chevrolet truck and a friends 54 bel air if the valve guides are tight it doesn't take much varnish to gum up.

    ----------

    Quote Originally Posted by sawyer
    Not always it could be working half way at slow rpm but can not keep up when rpm increases. I have had it happen to my 56 chevrolet truck and a friends 54 bel air if the valve guides are tight it doesn't take much varnish to gum up.
    Also when it's not running it is tight against the valve because it's had time to come up but when it's running it's like those valves are in slow motion

  3. #18
    superjeep is offline Cadillac Owners Member
    Automobile(s): 68 sedan deville,69 sedan deville,64 fleetwod 60 special
    Join Date
    Jun 2013
    Age
    32
    Posts
    88

    Re: 1969 472 help I'm stumped !!!!!

    did a comp check all looked good. took the rockers off and pushed on the valves all moved free and felt like they seated solidly. ill try the mystery oil anyway. at this point i don't get it

  4. #19
    superjeep is offline Cadillac Owners Member
    Automobile(s): 68 sedan deville,69 sedan deville,64 fleetwod 60 special
    Join Date
    Jun 2013
    Age
    32
    Posts
    88

    Re: 1969 472 help I'm stumped !!!!!

    SOLVED!!!!!!!! this is one for the books!!!! the only part i didn't replace or try was a dist hosing. i figured there isn't anything that can go wrong with a shaft.......how wrong i was. i pulled the dist out and brought it in the garage under light......3 of the 8 points lobes must have rusted and from the running wore the rust off and the lobes were almost smooth compared to the other 5.
    i had an old dist with a broken housing from trying to get it unstuck. i swapped shafts put it in and fired right up, set the timing to 5 degrees adjusted the mix screwws and she idled like a dream!!!!

    i took it for a ride it goes great under light load,when i try to open it up it goes strong for about 3 seconds then falls on its face like its running out of fuel you have to let it fill back with fuel and it goes smooth again. ill pop the carb off and see if the float is sticking or something. thats easy compared to the last crap hahaha.

    thanks for all the help guys

  5. #20
    CADforce69 is offline Cadillac Owners Connoisseur
    Automobile(s): Cadillac Sedan de Ville 1969, Dodge 3700GT '73, Audi A3 1.8T
    Join Date
    Oct 2010
    Location
    Madrid (Spain)
    Age
    47
    Posts
    1,577

    Re: 1969 472 help I'm stumped !!!!!

    ^I had the feeling it had to be a bad distributor I´m glad the worst problem is solved.

  6. #21
    sawyer is offline Cadillac Owners Member
    Automobile(s): 1969 coupe deville
    Join Date
    Aug 2013
    Age
    39
    Posts
    30
    Glad you found the problem.

  7. #22
    superjeep is offline Cadillac Owners Member
    Automobile(s): 68 sedan deville,69 sedan deville,64 fleetwod 60 special
    Join Date
    Jun 2013
    Age
    32
    Posts
    88

    Re: 1969 472 help I'm stumped !!!!!

    Looks like the fuel filter is a bit clogged and the float was real low. I set it at 5/16. Grab a filter tomorrow and see how it goes
    talismandave likes this.

  8. #23
    70eldo's Avatar
    70eldo is offline Cadillac Owners Connoisseur
    Automobile(s): 1970 Eldorado.
    Join Date
    Sep 2005
    Location
    Dutchman in Germany
    Age
    39
    Posts
    3,849

    Re: 1969 472 help I'm stumped !!!!!

    Quote Originally Posted by superjeep View Post
    Looks like the fuel filter is a bit clogged and the float was real low. I set it at 5/16. Grab a filter tomorrow and see how it goes
    Don't forget to check the secondaries (the top valves that are spring loaded and open under vacuum). In my carb the spring was broken, so the secondaries were stuck open. At full throttle the engine would starve like you described.

  9. #24
    superjeep is offline Cadillac Owners Member
    Automobile(s): 68 sedan deville,69 sedan deville,64 fleetwod 60 special
    Join Date
    Jun 2013
    Age
    32
    Posts
    88

    Re: 1969 472 help I'm stumped !!!!!

    yeah that all looked good. put a new filter in and adjusted the float.......the only issue now is when i punch my 68 from a stop it has no balls and bogs with a brand new qjet........the one i just rebuilt and fixed a few of the qjet problems will bake the tire off from a stop......even like a 15 mph roll will squeal the tire.......so it looks like this carb is going on my 68 since that is the nice one, this 69 is just going to be a driver for my girlfriend and i.

    the 68 is almost all restored on air ride with lots of work done so its not an all the time driver. this one ill do a few custom touches to and prob cruise it everyday when it gets nice out
    70eldo likes this.

  10. #25
    Jeff R's Avatar
    Jeff R is offline Cadillac Owners Fanatic
    Automobile(s): 1970 Coupe De Ville//Cessna 172
    Join Date
    May 2013
    Location
    St. Louis
    Age
    44
    Posts
    198

    Re: 1969 472 help I'm stumped !!!!!

    How about that.... Good Job!!

  11. #26
    all day cadillac is offline Cadillac Owners Member
    Automobile(s): 1994 fleetwood 1981 coupe deville 1976 coupe deville
    Join Date
    Jun 2014
    Age
    46
    Posts
    1

    Re: 1969 472 help I'm stumped !!!!!

    you should have sprayed some carb spray at the seams before pulling the intake. have you checked the springs on the valves?? week springs cause ping also .fuel to air ratio

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting