NEED HELP! (electrical)
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 4 of 4
The Classic Cadillac Forum Discussion, NEED HELP! (electrical) in Past Cadillac Vehicle Discussion; 66 deville...had all my lights working then running lights and brake lights quit found a wire i pinched on the ...
  1. #1
    SIK66CADDY is offline Cadillac Owners Member
    Automobile(s): 1966 cadillac deville
    Join Date
    Nov 2012
    Age
    30
    Posts
    1

    NEED HELP! (electrical)

    66 deville...had all my lights working then running lights and brake lights quit found a wire i pinched on the back bumper fixed it but still no running lights and brake lights on theback any help would be awesome.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    DouglasJRizzo is offline Cadillac Owners Enthusiast
    Automobile(s): 1975 hearse, 1976 hearse
    Join Date
    Nov 2010
    Location
    Franklin Lakes, NJ
    Age
    51
    Posts
    865

    Re: NEED HELP! (electrical)

    possibly the short caused a fuse to blow?

  4. #3
    SWEENDOG1969 is offline Cadillac Owners Member
    Automobile(s): 90k 1969 Cadillac Hardtop Sedan Deville
    Join Date
    May 2005
    Location
    seattle
    Age
    30
    Posts
    92

    Re: NEED HELP! (electrical)

    maybe fusable link? my 69 lost interior lights,windows,door locks,brake lights...after checking fuses and more fuses and jumping fuses still nothing. finally after searching around on the internet for a wiring schematic I figured out where the fusable link was and it was all melted up.

  5. #4
    mgil is offline Cadillac Owners Member
    Automobile(s): 1968 cadillac deville convertible
    Join Date
    Aug 2012
    Posts
    31

    Re: NEED HELP! (electrical)

    The 68 i just bought had electrical issues with the blinkers ,tailights , brake lights etc. the previous owner had jerry rigged a switch for the blinkers on the column, what a mess ! Anyway i bought a new switch for the blinkers and installed it , what a job fixing all the cobbed up wires and such. Well after it was installed we still had the same issue , after hours of trying this and that we finally found the problem. There was a loose ground on the front passenger blinker !! We tightened that up and bingo everything worked, amazing that one ground could cause all that trouble ! check all connections and make sure they are clean and tight !

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting