Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 8 of 8

Thread: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

  1. #1
    zacharybinx is offline Cadillac Owners Member
    Automobile(s): 1983 Commercial Chassis 6.0L Hearse
    Join Date
    Feb 2012
    Location
    Sunland, CA
    Age
    51
    Posts
    8

    1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    I checked the Fuse but not sure what else to look at. Any thoughts would be appreciated.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    77CDV's Avatar
    77CDV is offline Cadillac Owners 10000+ Posts
    Automobile(s): 77 CDV, 06 DTS III, 69 FWB
    Join Date
    Mar 2006
    Location
    Newbury Park, CA
    Age
    45
    Posts
    10,022

    Re: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    Give each horn direct current to see if they're actually working. If yes, check the horn relay and the horn pad connection in the steering wheel. If all that checks out, the problem is likely inside the steering column.

  4. #3
    zacharybinx is offline Cadillac Owners Member
    Automobile(s): 1983 Commercial Chassis 6.0L Hearse
    Join Date
    Feb 2012
    Location
    Sunland, CA
    Age
    51
    Posts
    8

    Re: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    Thanks 77,
    I'll check it out.
    -Z

  5. #4
    zacharybinx is offline Cadillac Owners Member
    Automobile(s): 1983 Commercial Chassis 6.0L Hearse
    Join Date
    Feb 2012
    Location
    Sunland, CA
    Age
    51
    Posts
    8

    Re: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    So I gave the horns direct current from the positive battery terminal, got a little sound (not a full honk). Pulled the relay and paper clipped two of the three terminals, also got a little sound and lots of sparks so I can tell it's getting power so I replaced the relay, hit the pad, nothing. Now just trying to figure out how to test the pad. I know the fuse is good, I pulled it and tested it. This is the same fuse for the power seats which are working fine with the fuse in.
    -Z

  6. #5
    77CDV's Avatar
    77CDV is offline Cadillac Owners 10000+ Posts
    Automobile(s): 77 CDV, 06 DTS III, 69 FWB
    Join Date
    Mar 2006
    Location
    Newbury Park, CA
    Age
    45
    Posts
    10,022

    Re: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    If you're near a jyard, pull a pad from any 1980-1989 RWD Cad, swap it into your car, and see what happens. To differentiate between the pad and steering wheel wiring, with the pad off, give the contact wire direct power. If you get sound, then you know it's the pad. Otherwise, this is where it gets tough.

  7. #6
    zacharybinx is offline Cadillac Owners Member
    Automobile(s): 1983 Commercial Chassis 6.0L Hearse
    Join Date
    Feb 2012
    Location
    Sunland, CA
    Age
    51
    Posts
    8

    Re: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    Thank you 77.

    Turns out it was multiple problems:

    1) Relay was bad
    2) Horns stopped working in the middle of all this testing (replaced them)
    3) pad has a short which is temporally working (paper clips & chewing gum) HaHa.

    Thanks for the steering wheel tip, I am near a jyard (pick ur part) I will do that next and hopefully that will be that. but meanwhile it is working but sometimes sounds at random times but if I hit the pad it stops. Hopefully it doesn't happen behind a cop.

    Thanks again,
    -Z

  8. #7
    77CDV's Avatar
    77CDV is offline Cadillac Owners 10000+ Posts
    Automobile(s): 77 CDV, 06 DTS III, 69 FWB
    Join Date
    Mar 2006
    Location
    Newbury Park, CA
    Age
    45
    Posts
    10,022

    Re: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    Gotta love multiple failures in the same system. Makes diagnosis so easy!

  9. #8
    zacharybinx is offline Cadillac Owners Member
    Automobile(s): 1983 Commercial Chassis 6.0L Hearse
    Join Date
    Feb 2012
    Location
    Sunland, CA
    Age
    51
    Posts
    8

    Re: 1983 Commercial Chassis (6.0L) Hearse Horn Not Working

    Yeah, at one point I just started back from the beginning and strangely the puzzle pieces came together.
    Thanks again,
    -Z


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum