Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 4 of 4

Thread: Service Messages for 3 systems on Brand new XTS Platinum - after changing Cluster

  1. #1
    CDN XTS is offline Cadillac Owners Fanatic
    Automobile(s): 1995 SLS -> 2003 STS ->2013 XTS Platinum ->2016 CT6 Platinum
    Join Date
    Dec 2012
    Location
    Oakville, Ontario, Canada
    Posts
    203

    Service Messages for 3 systems on Brand new XTS Platinum - after changing Cluster

    Just received my XTS Platinum on Jan 22/13 - Love it but now I'm (built during week of Jan 7-Jan 11, 2013 - Software version 23124322 - Gracenote version 22993544).

    Left Dealer last Tuesday with the Metric Uplevel Balanced Cluster. To-day after less than 300 km on the odometer I changed the cluster to the Performance Configuration. Subsequently, when starting the car I received 3 messages related to a) Adaptive Cruise Control, b) Park Assist System and c) Front Camera. Called OnStar and they scanned the system and confirmed that those error codes had been set; I could drive but should see the service department.

    Continued driving for about 10 km while noting that neither the Lane Departure Warning Light nor the Vehicle Ahead Indicator worked.

    I then changing back to the Balanced Cluster, and to my surprise, immediately all worked again as before. Have not yet re-tested it or with the other two clusters. But why would a cluster change affect those systems in the first place resulting in those error messages at every start of the car?

    Anyone else has run into this puzzling problem?

    Update on Jan 28th after further tests.
    Tested today all 4 clusters, starting car in every cluster. No error messages this time. Had OnStar check system again - no set error codes detected. Seems the problem cleared itself. N.B. Windshield was certainly clean yesterday, so not a problem of the forward camera being blocked.

    Last edited by CDN XTS; 01-28-13 at 11:13 AM. Reason: Update after further tests on Jan 28th

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Join Date
    Mar 2010
    Location
    Detroit, USA
    Posts
    12,711

    Re: Service Messages for 3 systems on Brand new XTS Platinum - after changing Cluster

    CDN XTS,

    We're sorry that you're having these issues with your new XTS!

    Should anything else come up and you wanted to speak with customer service for your region, don't hesitate to call GM of Canada at 800-263-3777.

    Sarah (Assisting Katie), Cadillac Customer Service

  4. #3
    Caddy XTS is offline Cadillac Owners Member
    Automobile(s): Xts
    Join Date
    Jul 2013
    Posts
    5
    All has been working fine on my XTS until today I jumped in after being at post office and all three error messages come on as well and none of the sensors are working.

  5. #4
    Join Date
    Mar 2010
    Location
    Detroit, USA
    Posts
    12,711

    Re: Service Messages for 3 systems on Brand new XTS Platinum - after changing Cluster

    Quote Originally Posted by Caddy XTS View Post
    All has been working fine on my XTS until today I jumped in after being at post office and all three error messages come on as well and none of the sensors are working.
    Hello Caddy XTS,

    I am terribly sorry that you are experiencing a concern with your XTS recently. Have you taken your vehicle into a Cadillac dealership to have this concern looked into further? I would be happy to assist you in setting up a dealership appointment and working with them regarding this concern. Please don’t hesitate to reach out to me via private message or by email at socialmedia@gm.com with “ATTN GREG” in the subject line if there is anything I can do to assist. I hope to hear from you soon.

    Gregory W.
    Cadillac Customer Care


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum