P0717/p056 transmission input speed sensor fix!!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 19
Like Tree2Likes
Cadillac Tech Tips - How to fix it Discussion, P0717/p056 transmission input speed sensor fix!! in Item Specific Cadillac Discussion; I'm an automotive service technician and I own a 1995 Cadillac STS. I too, had the P056 code come up. ...
  1. #1
    dto
    dto is offline Cadillac Owners Member
    Automobile(s): 1995 Cadillac STS
    Join Date
    Apr 2011
    Posts
    4

    P0717/p056 transmission input speed sensor fix!!

    I'm an automotive service technician and I own a 1995 Cadillac STS. I too, had the P056 code come up. I could replace the sensor myself, but i really don't want to spend 10+ hours trying to replace the sensor.

    After browsing the forums, I stumbled upon this thread, where someone had made a small signal amplifier.

    I decided to build the exact same device. (photo attached)

    When the vehicle was cold, the sensor worked fine. Go in to diagnostics and view PD72. When the vehicle temperature rose, the data disappeared and a DTC would appear.

    I connected the signal amplifier and now it works great. Data is present, when the vehicle is cold and when warm. A big thanks to 'magnum51' where ever he may be.
    Attached Images
    89falcon, 89falcon, JK198 and 1 others like this.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    dto
    dto is offline Cadillac Owners Member
    Automobile(s): 1995 Cadillac STS
    Join Date
    Apr 2011
    Posts
    4

    Re: P0717/p056 transmission input speed sensor fix!!

    Materials Needed:

    1 x LM741 Operation Amplifier
    2 x 4 AA battery holders
    1 x 1k ohm resistor
    1 x 100k ohm resistor
    1 x printed circuit board

    miscellaneous materials:

    - wire
    - connectors
    - soldering iron and solder

    The items mentioned literally cost me less then $40 to purchase and i've no past experience with electronics.

    I've provided a schematic and several images to aid, if anyone is interested in building one themselves.
    Attached Images

  4. #3
    Rckjaws10 is offline Cadillac Owners Member
    Automobile(s): 1995 Deville
    Join Date
    Aug 2010
    Posts
    3

    Re: P0717/p056 transmission input speed sensor fix!!

    This is very interesting.. I too have the P0717 in my 96 Deville.. Do you have anymore detailed information on how to build, and hook up this device? thanks a lot

  5. #4
    dto
    dto is offline Cadillac Owners Member
    Automobile(s): 1995 Cadillac STS
    Join Date
    Apr 2011
    Posts
    4

    Re: P0717/p056 transmission input speed sensor fix!!

    Use the diagrams i've provided. Or I could build it for you, for which i will charge.

  6. #5
    Extortion00 is offline Cadillac Owners Member
    Automobile(s): 1993 Cadillac Deville
    Join Date
    May 2011
    Age
    26
    Posts
    2

    Re: P0717/p056 transmission input speed sensor fix!!

    how long did it take you to build this?

  7. #6
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,131

    Re: P0717/p056 transmission input speed sensor fix!!

    Quote Originally Posted by Extortion00 View Post
    how long did it take you to build this?
    Once you collect the parts from Radio Shack or an online electronics parts house the build should take a half hour. BUT, practice doing small solder joints FIRST.

  8. #7
    Chino214 is offline Cadillac Owners Member
    Automobile(s): 2001 Cadillac Seville SLS
    Join Date
    Aug 2011
    Location
    Dallas, Texas, United States
    Age
    28
    Posts
    1

    Re: P0717/p056 transmission input speed sensor fix!!

    does anyone have actual pictures of how to actually connect it? i see there's schematics but would like to see actual photo's on how to. Thanks.

  9. #8
    Submariner409's Avatar
    Submariner409 is offline If it won't run, chrome it
    Automobile(s): 2002.5 F55 STS/65500mi, 2004 Ford F150 SuperCab4x4
    Join Date
    Feb 2006
    Location
    MD Eastern Shore - Kent Island
    Age
    74
    Posts
    44,131

    Re: P0717/p056 transmission input speed sensor fix!!

    Quote Originally Posted by Chino214 View Post
    does anyone have actual pictures of how to actually connect it? i see there's schematics but would like to see actual photo's on how to. Thanks.
    Post #1 & #2. The only thing you would see on the underside of the pre-printed PCB is solder dots.

  10. #9
    Extortion00 is offline Cadillac Owners Member
    Automobile(s): 1993 Cadillac Deville
    Join Date
    May 2011
    Age
    26
    Posts
    2

    Re: P0717/p056 transmission input speed sensor fix!!

    does this also work on code p0717??

  11. #10
    Johnny8519 is offline Cadillac Owners Member
    Automobile(s): 1996 SLS
    Join Date
    Aug 2011
    Age
    41
    Posts
    1

    Re: P0717/p056 transmission input speed sensor fix!!

    I have the Code P0717. My situation seems to be totally differnt the all of the ones I see posted here. The Service engine light as well as the service transmission. comes right away as soon as I start the car. It doesnt seem to ever go out, hot or cold. When I clear the code it goes out. It wil stay out until I drive about 75 ft. Can the Signal Amp fix my problem? I did find some similar things. There was a alot of tranny fluid inside the connector. I cleaned it. Did not help.

  12. #11
    dto
    dto is offline Cadillac Owners Member
    Automobile(s): 1995 Cadillac STS
    Join Date
    Apr 2011
    Posts
    4

    Re: P0717/p056 transmission input speed sensor fix!!

    It's still working like a charm.

  13. #12
    rolexcomm is offline Cadillac Owners Member
    Automobile(s): catera
    Join Date
    Jan 2010
    Age
    38
    Posts
    2

    Re: P0717/p056 transmission input speed sensor fix!!

    quick question, is this device supposed to tap into the red/black wire leaving it intact or is it supposed to go in between the sensor and pcm by cutting said wire??? also is there any situation in which this device wouldn't work??

  14. #13
    Atrayyu is offline Cadillac Owners Member
    Automobile(s): 95 Eldorado
    Join Date
    Nov 2011
    Posts
    2

    Re: P0717/p056 transmission input speed sensor fix!!

    Hey all,

    made an account so I could post, been following for a while though.

    Couldn't you substitute a a 12v source from the car instead of using 8 "AA" batteries?

    then you wouldn't have to worry about the batteries going bad right?

    I am about to make one of these for a friends car, because I really don't want to go through the hassle of dropping the motor/tranny down to fix it for him.

  15. #14
    Atrayyu is offline Cadillac Owners Member
    Automobile(s): 95 Eldorado
    Join Date
    Nov 2011
    Posts
    2

    Re: P0717/p056 transmission input speed sensor fix!!

    Quote Originally Posted by rolexcomm View Post
    quick question, is this device supposed to tap into the red/black wire leaving it intact or is it supposed to go in between the sensor and pcm by cutting said wire??? also is there any situation in which this device wouldn't work??
    from dissecting the diagram.... you have to cut the wire, and place the device "in line", can't just tap into the wire and run it in "parallel", must be ran in "series"

    I have not made one yet, but that's just the operation of any signal amplifier... hope it helps.

  16. #15
    jmcl40 is offline Cadillac Owners Member
    Automobile(s): 1996 Seville sts
    Join Date
    Dec 2011
    Age
    73
    Posts
    1

    Re: P0717/p056 transmission input speed sensor fix!!

    Did you build the amp and if so did it work for code p0717 ? I have same problem code at all times but have run car for several thousand miles with no apparent transmission problem.
    Thanks

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting