running rich! please help
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 12 of 12
Cadillac STS-V Series Forum Discussion, running rich! please help in Cadillac V-Series Forums; Well to start the car is an 06 stsv. Its running-31.25% stf at idle. The add ons are from TimC. ...
  1. #1
    rbzstsv is offline Cadillac Owners Fanatic
    Automobile(s): stsv
    Join Date
    Mar 2013
    Posts
    393

    running rich! please help

    Well to start the car is an 06 stsv. Its running-31.25% stf at idle. The add ons are from TimC. Headers intake heat exchanger pulley tb 60lbs injectors flush mount snout corsa and a badass timc tune. I believe thats. I went on a road trip. Heading back from utah to the midwest the car wouldnt get up passed 65mph in D. Using manual i was able to get car to 75mph. Since then we have been running circles trying to figure out the issue. Just had a tune up changing all belts, plugs, wires n flushing of all fluids. Car was throwing bank 1 n 2 rich so cleaned maf with no more codes but still running -31.25% stf. No vacuum leaks, fuel reg checked n ok. Ideas?

    ----------

    Car is also throwing no codes now. At 50% throttle the stf running up to-1% then straight back to -31.25% after release of throttle. O2s are reading 889. No vac leaks. No issues with fuel pressure or injectors. Maf is clean n is working order. Any info would be great

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,536

    Re: running rich! please help

    First have you talk to Tim yet? You need to send him a log so he can make adjustments to the tune unless you have HP Tuners. If you have HP Tuners you can adjust it through histograms set up to log MAF Frequency vs. either LTFT or STFT.

  4. #3
    rbzstsv is offline Cadillac Owners Fanatic
    Automobile(s): stsv
    Join Date
    Mar 2013
    Posts
    393
    I have talked with tim. He said it cant be the tune because nothing has changed. It started halfway thru a road trip. also he said cant diagnose over phone. Both of which makes sense. He lives about 4 hours from me and tuned the car last time i was up there.

  5. #4
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,536

    Re: running rich! please help

    Since you don't have HP Tuners you will have to get back to Tim and see if he can figure it out.

    Also I can't imagine it being a vac or intake leak as those should cause a lean condition as you are drawing in more un-metered air and the O2 sensors would "see" it. What are you using to log the data from the car?

  6. #5
    boomys10 is offline Cadillac Owners Enthusiast
    Join Date
    Dec 2011
    Location
    missouri
    Age
    29
    Posts
    765

    Re: running rich! please help

    Message me. Might have some insight...

  7. #6
    TimmyC is offline Cadillac Owners Connoisseur
    Automobile(s): 99 SLS and Turbo 07 STS-V-Now back to Supercharged
    Join Date
    Feb 2009
    Location
    1/2 hr S of Grand Rapids, MI
    Age
    35
    Posts
    1,565

    Re: running rich! please help

    We determined that there are at least two issues here. One is the whatever caused the problem on the road trip. I got a text that said the check engine light was flashing. I told him to scan for codes. Said he could not do that because he was on the road. No mention of speed limiting.

    Then later I get messages saying that the car is running rich and has 31% negative fuel trims. 30 text messages later I ask who tuned it for the 60s because I did not install them. Turns out no one did, they just installed them. 25% larger fuel injectors is going to cause quite a large negative fuel trim if you don't change the tune.

    If a car was running fine, then is not, something changed. Finding what changed is first priority. Changing other things before figuring the original problem out is just going to complicate things. This goes for everyone, not just Kyle.

    They are going to put the stock injectors back in Monday and see how the trims are. I assume they will be back in line with what they should be. Then the original problem can be diagnosed.

  8. #7
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,536

    Re: running rich! please help

    If the tune was never adjusted for the injectors then it should have been pig rich from the beginning. I am surprised it ran that long without going into limp mode. When he said a bad ass tune from Timc I figured you had adjusted for the injectors and the car just went rich because it learned the trims.

  9. #8
    TimmyC is offline Cadillac Owners Connoisseur
    Automobile(s): 99 SLS and Turbo 07 STS-V-Now back to Supercharged
    Join Date
    Feb 2009
    Location
    1/2 hr S of Grand Rapids, MI
    Age
    35
    Posts
    1,565

    Re: running rich! please help

    No, the injectors were installed a few days ago with no tune adjustment. That's why it was so rich. The other, unrelated problem occurred before the 60s were installed and remains to be diagnosed.

  10. #9
    Fierofiend is offline Cadillac Owners Fanatic
    Automobile(s): 2008 STS-V
    Join Date
    Feb 2012
    Location
    Charlotte, NC
    Posts
    267

    Re: running rich! please help

    Running 'that' rich and then adding 60s probably wasn't the best idea, OP.

  11. #10
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,536

    Re: running rich! please help

    He also didn't tell us that he put the injectors in AFTER the road trip.

  12. #11
    TimmyC is offline Cadillac Owners Connoisseur
    Automobile(s): 99 SLS and Turbo 07 STS-V-Now back to Supercharged
    Join Date
    Feb 2009
    Location
    1/2 hr S of Grand Rapids, MI
    Age
    35
    Posts
    1,565

    Re: running rich! please help

    Re-installing the stock injectors fixed the rich problem and allowed the OP and the shop to focus on the original problem which turned out to be a bad O2 sensor on bank 1. They replaced that and Kyle reported to me that the car is running great now.

    He is going to either send my his ecu or have the tune changed locally for the injectors.

  13. #12
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,536

    Re: running rich! please help

    Glad he figured it out.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting