Engine Hot - AC off . . no temp guage . . rad fans on high
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 41
Like Tree1Likes
Cadillac STS-V Series Forum Discussion, Engine Hot - AC off . . no temp guage . . rad fans on high in Cadillac V-Series Forums; Well yesterday while doing some Christmas shopping with the wife the DIC popped up the message . . The temperature ...
  1. #1
    Berger 93 is offline Cadillac Owners Fanatic
    Automobile(s): Cadillac STS-V
    Join Date
    Feb 2007
    Location
    Schaumburg, IL
    Posts
    301

    Unhappy Engine Hot - AC off . . no temp guage . . rad fans on high

    Well yesterday while doing some Christmas shopping with the wife the DIC popped up the message . .

    The temperature gauge in the cluster would not move, and the radiator fans are running on high.

    Made three - four stops and it came up every time after a few mins of driving.

    Was not hot . . the engine oil was around 163 degrees . .

    I still am on GMPP warranty . . concerned that without a SES code it will be like chasing a ghost.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Dave G is offline Cadillac Owners Fanatic
    Automobile(s): STS-V
    Join Date
    Apr 2009
    Age
    39
    Posts
    281

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    Mine did this once...I let it sit overnight and it hasn't returned.

  4. #3
    carter's_sts is offline Cadillac Owners Connoisseur
    Automobile(s): 06 STS-V & 06 STS 4
    Join Date
    Jun 2009
    Posts
    1,262
    Sounds like coolant temp sensor. I think they don't have a low temp alert, so they default to high temp if something is wrong.

  5. #4
    PGA2B's Avatar
    PGA2B is offline Cadillac Owners Connoisseur
    Automobile(s): Black Raven STS V
    Join Date
    Jun 2009
    Location
    Surprise, AZ
    Posts
    2,537

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    Its the thermostat. They will change several other things that will not fix your issue before they finally will change the thermostat. Do yourself a favor and change it yourself. Takes about 30-45 minutes and less than $20. There are 2 10mm bolts holding the housing on and you don't even have to take any hoses off.

    http://www.cadillacforums.com/forums...-2006-sts.html

  6. #5
    KingOfLacs is offline Cadillac Owners Fanatic
    Automobile(s): 2006 STS-V, Stepside Chevy, 1966 Chevelle
    Join Date
    Dec 2011
    Age
    32
    Posts
    254

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    Not under factory warranty so I would need to pay to have it diagnosed there are several threads on this subject and was advised to change thermostat. I replaced with another factory t-stat and it came back on a quite a few times now. When it does I just clear the code stays off for a while usually when its cold out is when it happens. wondering if this is a recall item and if there is some sort of software update for the car to fix this. My last 8 are 60181580.

  7. #6
    boomys10 is offline Cadillac Owners Enthusiast
    Join Date
    Dec 2011
    Location
    missouri
    Age
    29
    Posts
    770

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    just have someone turn the code off in your ecu. the fault is tripped bc the coolant doesnt reach a certain temp range in a certain amount of time it thinks it should be at. its stupid.. i went thru three stats in 1.5 weeks. easier just to have someone turn it off honestly. just my 2 cents.

  8. #7
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is offline Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    11,506

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    Berger 93, please let me know if you do decide to involve a dealership and would like me to check my resources for you and/or call your dealer on your behalf. I'm just an email away at Katie_Lucille@gmexpert.com.

    Best,

    Katie
    Cadillac Customer Service

  9. #8
    bobs-sts-v's Avatar
    bobs-sts-v is offline Cadillac Owners Fanatic
    Automobile(s): STS-V
    Join Date
    Feb 2007
    Location
    Naperville, IL
    Posts
    392

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    Thermostat is stuck open and not allowing the engine to heat up in a specified period of time. Seems to pop up at the beginning of winter for most of us if the TS is even a little bit slow. Rarely see this in the summer unless the TS is bad. Trust us - those who have had the car for years - it is the TS 98% of the time.

    Bob
    KingOfLacs and KingOfLacs like this.

  10. #9
    BMBSALES's Avatar
    BMBSALES is offline Cadillac Owners Enthusiast
    Automobile(s): 10 CTS-V, 13 ESCALADE, 06 C6, YAM R1
    Join Date
    Mar 2006
    Location
    NC
    Posts
    574
    This is the coolant temp sending unit. CTS-v's do it too.

    ----------

    If it was therm...eventually temp would rise, even if it was stuck open, but it never does...sending unit.

  11. #10
    carter's_sts is offline Cadillac Owners Connoisseur
    Automobile(s): 06 STS-V & 06 STS 4
    Join Date
    Jun 2009
    Posts
    1,262
    That's what I was thinking. Maybe the OP will let us know when they get it fixed.

  12. #11
    bobs-sts-v's Avatar
    bobs-sts-v is offline Cadillac Owners Fanatic
    Automobile(s): STS-V
    Join Date
    Feb 2007
    Location
    Naperville, IL
    Posts
    392

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    Quote Originally Posted by BMBSALES View Post
    This is the coolant temp sending unit. CTS-v's do it too.

    ----------

    If it was therm...eventually temp would rise, even if it was stuck open, but it never does...sending unit.
    I agree. But for most of us, the temp goes to normal yet the message remains. Strange how it seems to pop up especially in winter, though.

    Bob

  13. #12
    BMBSALES's Avatar
    BMBSALES is offline Cadillac Owners Enthusiast
    Automobile(s): 10 CTS-V, 13 ESCALADE, 06 C6, YAM R1
    Join Date
    Mar 2006
    Location
    NC
    Posts
    574
    Yeah local caddy dealer said it was known issue...sometimes sending unit and other times even gauge cluster???? Sounds odd.

    But yes..if temp gauge goes up, but slowly, could be stuck thermo.

    bmb

  14. #13
    boomys10 is offline Cadillac Owners Enthusiast
    Join Date
    Dec 2011
    Location
    missouri
    Age
    29
    Posts
    770

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    i just had my tuner turn the message off in the computer. the gauge works fine and will tell you if your over heating and you wont have to deal with the stupid message. also, i changed coolant when my car was torn apart from dexcool to the green stuff and it works alot better. keeps supercharger cooler and hasnt raised engine temps. also heats up faster.

  15. #14
    BMBSALES's Avatar
    BMBSALES is offline Cadillac Owners Enthusiast
    Automobile(s): 10 CTS-V, 13 ESCALADE, 06 C6, YAM R1
    Join Date
    Mar 2006
    Location
    NC
    Posts
    574
    Yeah..I'm scared to tune that one off...

  16. #15
    boomys10 is offline Cadillac Owners Enthusiast
    Join Date
    Dec 2011
    Location
    missouri
    Age
    29
    Posts
    770

    Re: Engine Hot - AC off . . no temp guage . . rad fans on high

    the only thing you are tuning off is the comps ability to guess where the temp should be. everything still works completely as normal, the comp just gets left out of the equation. the reason you get that dic warning is bc the temp of the coolant isnt where its thought to be. its been documented on here from several people. just turn it off and the car will never have that issue again. the gauge still works, no reason for the stupid warning imo

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting